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Backup-Archive clients sessions hung because of firewall inactivity set-up.

Troubleshooting


Problem

Some Tivoli Storage Manager client/server implementations may experience client connections being blocked if the connection passes through a firewall, even though the appropriate port(s) have been opened on the firewall.

Cause

Some firewall implementations will block a tcp/ip connection if it has
been inactive for a certain period.
If the client remains idle for a period longer than the firewall timeout (inactivity) period, the firewall would block the Tivoli Storage Manager client session.

Resolving The Problem

The Backup-Archive client uses the tcp/ip SO_KEEPALIVE network socket option to prevent a connection from being terminated due to firewall timeout. The client uses the default OS keepalive interval. On AIX and Windows platforms, this would be a default of 2 hours.

The default keepalive interval can be updated from to a different value. For example, to set a keepalive interval of 10 minutes, the following command can be issued :

  • on AIX, "no -o tcp_keepidle=1200"
  • on Solaris, "ndd -set /dev/tcp tcp_keepalive_interval 600000"
  • on Linux rh 7.3, "sysctl -w net.ipv4.tcp_keepalive_time=600"
  • on Windows, use Registry Editor (at your own risk) to modify/create value data for the "KeepAliveTime" DWORD value to 600000 in the following registry key: HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters
  • on NetWare, the "set" command is used to change network options but it is not possible to change the keepalive default using that command. NetWare uses a default of 2 hours.

[{"Product":{"code":"SSGSG7","label":"Tivoli Storage Manager"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Component":"Client","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Supported Versions","Edition":"","Line of Business":{"code":"LOB26","label":"Storage"}}]

Document Information

Modified date:
17 June 2018

UID

swg21109798