IBM Support

IBM Spectrum Protect Server-Client Compatibility and Upgrade Considerations

Technote (troubleshooting)


Problem(Abstract)

IBM Spectrum Protect Server-Client Compatibility and Upgrade Considerations

Resolving the problem

Tip: The product now known as IBM Spectrum Protect™ was named IBM Tivoli® Storage Manager in releases earlier than Version 7.1.3. To learn more about the rebranding transition, see http://www.ibm.com/support/docview.wss?uid=swg21963634.
The following IBM Spectrum Protect client and server combinations are compatible. All other combinations are not supported.

The functionality in the lowest version and release is supported in that compatible combination, for as long as the lowest version and release is in regular support.


IBM SPECTRUM PROTECT CLIENT COMPATIBILITY

includes the Backup-Archive, API, UNIX HSM, and Web clients
that are compatible with, and currently supported with,
IBM Spectrum Protect Servers and Storage Agents.
IBM Spectrum Protect
Client Version
Compatible IBM Spectrum Protect
Server and Storage Agent Versions
8.1
8.1, 7.1, 6.3.x 1
7.1
8.1, 7.1, 6.3.x 1
6.4
8.1, 7.1, 6.3.x 1
6.3 2
8.1, 7.1, 6.3.x 1
General Notes:
Note 1:
  • In TSM 6.3, the Server and Storage Agent level is 6.3.x, where x>=0
  • In TSM 6.4, the Server level is 6.3.x, where x>=3
  • Compatibility with the Server 6.3.x means compatibility with both 6.3 and 6.4
Note 2:
  • 6.3 Client compatibility statements include the V6.1-level z/OS USS Client

Link to Storage-Agent and Library-Client compatibility page:
http://www.ibm.com/support/docview.wss?uid=swg21302789

Link to Operations Center-Server Compatibility page:
http://www.ibm.com/support/docview.wss?uid=swg21640917

Link to Administration Center-Server Compatibility page:
http://www.ibm.com/support/docview.wss?uid=swg21662629

Link to the Operating System Overview page for client and servers on all supported IBM Spectrum Protect releases:
http://www.ibm.com/support/docview.wss?uid=swg21243309

Link to the Client Functionality Compatibility page:
http://www.ibm.com/support/docview.wss?uid=swg21420322


Upgrading from Version 6.3, 6.4, 7.1 to Version 8.1

Please visit the IBM Spectrum Protect Knowledge Center for a migration plan: https://www.ibm.com/support/knowledgecenter/SSEQVQ_8.1.0/srv.install/t_srv_upgrade63_71.html

Upgrading from Version 6.3 or 6.4 to Version 7.1

As part of a migration plan from Tivoli Storage Manager (TSM) Version 6.3 or 6.4 to TSM Version 7.1, TSM clients and servers can be upgraded at different times. This configuration is supported as long as the older version is supported.

When upgrading from a Version 6.x server to a Version 7.1 server, follow this link for more detailed information: http://pic.dhe.ibm.com/infocenter/tsminfo/v7r1/index.jsp?topic=%2Fcom.ibm.itsm.srv.install.doc%2Ft_srv_upgrade.html

To help prevent disruption to your backup and archive activities during the migration, follow these guidelines:
  • A TSM 6.3 or 6.4 client can perform backup, restore, archive, retrieve, and query functions to a TSM 7.1 server
  • A TSM 7.1 client can perform backup, restore, archive, retrieve, and query functions to a TSM 6.2 or 6.3.x server
  • If you back up or archive data from a TSM 6.4 or 6.3 or earlier client to a supported TSM server, you can restore or retrieve that data using a TSM 7.1 client
  • If you back up or archive data from a TSM 7.1 client to a supported TSM server, you cannot restore or retrieve that data using a TSM 6.4 or earlier client.
  • All TSM 7.1 administrative clients can administer TSM 6.2 and 6.3.x servers
  • NAS backups performed on a TSM 7.1 server using the BACKUP NODE server command can only be restored using the RESTORE NODE server command or a TSM 6.3, 6.4, or 7.1 client

Note: the TSM server is shipped at the V6.3.3 level with TSM 6.4


Upgrading from Version 5.5, 6.1, or 6.2 (which are End Of Support) to Version 6.x:

Version 5.5 and Version 6.1 have reached End of Support. Upgrading from a Version 5.x server to a Version 6.x server is significantly different than previous upgrades. Please follow this link for more detailed information you need to know before upgrading your 5.5 server:
http://publib.boulder.ibm.com/infocenter/tsminfo/v6/index.jsp?topic=/com.ibm.itsm.nav.doc/t_upgrading.html

Version 5.5, 6.1, and 6.2 clients can be upgraded to any higher 6.x or 7.1 level, as long as the operating system is supported at that higher level.
Note that all UNIX and Linux clients at Version 6.3 and higher are 64-bit. 32-bit Version 5.5, 6.1, and 6.2 UNIX and Linux clients must be uninstalled before installing the equivalent Version 6.3 or higher 64-bit clients.

Related information

IBM Spectrum Protect Supported Operating Systems
Latest Server and Client Downloads
TSM 5.5 and 6.1 EOS Announcement
TSM 6.2 EOS 30 April 2015
TSM 5.5 and 6.1 Compatibility (now EOS)
TSM 6.2 Compatibility (now EOS)
Storage Agent and Library Client Compatibility
Operations Center Compatibility
Administration Center Compatibility
HSM for Windows Compatibility
TSM Featured Documents

Cross reference information
Segment Product Component Platform Version Edition
Storage Management Tivoli Storage Manager

Document information

More support for: IBM Spectrum Protect

Software version: All Supported Versions

Operating system(s): Platform Independent

Reference #: 1053218

Modified date: 13 May 2015


Translate this page: