IBM Support

Linux x86/x86_64 Client Requirements

Troubleshooting


Problem

Hardware and Software Requirements for IBM Spectrum Protect™ Linux x86_64 Backup-Archive and API Client

Cause

Tip: The product now known as IBM Spectrum Protect™ was named IBM Tivoli® Storage Manager in releases earlier than Version 7.1.3. To learn more about the rebranding transition, see   technote 1963634.
 

Overview of IBM Spectrum Protect™ Client and Server supported operating systems and platforms:  http://www.ibm.com/support/docview.wss?uid=swg21243309
Overview of IBM Tivoli Storage Manager Client and Server supported operating systems and platforms:   http://www.ibm.com/support/docview.wss?uid=swg21994042
 

Latest Client and Server downloads:   http://www.ibm.com/support/docview.wss?uid=swg21239415
 

Resolving The Problem


Hardware and Software Requirements


In the tables below the minimum supported levels are listed. In general, all operating system service pack and maintenance levels are supported. Any exceptions are noted in the tables below.

Version 8.1
Version 7.1
 


Version 8.1

Hardware
System:
Systems based on the X86 64bit processor architecture such as Intel-64 or AMD64
Disk Space:
1.5 GB disk space is required to install the client, and all language packs.
Note: using the web user interface requires minimum 4,4 GB disc space (preferred 9 GB disc space)
Memory:
No additional RAM is required for product installation. RAM requirements for running the product vary widely and depend on your environment, configuration, and tasks that you perform. Additional RAM might be required to run the product.
Note: using the web user interface requires minimum 4 GB RAM (preferred 8 GB RAM)
Communication Protocol
  • TCP/IP, which comes standard with Linux
  • Shared Memory (only with Linux x86_64 IBM Spectrum Protect server)
Operating System
Backup-Archive client supports the following operating systems:
-
SLES15 (Beginning with backup-archive client v8.1.6)
- SLES 12
- SLES 11 (including SLES 11 level in Novell OES 11 and OES 2015 details )
- SLED 11
- RHEL 7 for Servers & Desktop editions
- RHEL 6 for Servers & Desktop editions
- Ubuntu 18.04 (Beginning with backup-archive client v8.1.6)
- Ubuntu 16.04
- Ubuntu 14.04

Note: For "best effort" support of other Linux distributions, see this technote: http://www.ibm.com/support/docview.wss?uid=swg21417165
Backup-Archive client supports the following filesystems:
For supported file systems on latest fix pack see this web page: https://www.ibm.com/support/knowledgecenter/SSEQVQ_8.1.6/client/c_bac_aclsupt.html

The following IBM Spectrum Scale (previously known as GPFS) versions are supported:
  • IBM Spectrum Scale v4.2.1 or higher fix pack (Beginning with backup-archive client v8.1.0) on operating systems
    • SLES 12.1 or higher service pack and maintenance levels
    • RH 7.1 or higher service pack and maintenance levels
  • IBM Spectrum Scale v4.2.2 or higher fix pack (Beginning with backup-archive client v8.1.0) on operating systems
    • SLES 12.1 or higher service pack and maintenance levels
    • RH 7.1 or higher service pack and maintenance levels
  • IBM Spectrum Scale v4.2.3 or higher fix pack (Beginning with backup-archive client v8.1.2) on operating systems
    • SLES 12.1 or higher service pack and maintenance levels
    • RH 7.1 or higher service pack and maintenance levels
  • IBM Spectrum Scale v5.0.0 or higher fix pack (Beginning with backup-archive client v8.1.4) on operating systems
    • SLES 12.1 or higher service pack and maintenance levels
    • RH 7.1 or higher service pack and maintenance levels
  • IBM Spectrum Scale v5.0.1 or higher fix pack (Beginning with backup-archive client v8.1.6) on operating systems
    • SLES 12.1 or higher service pack and maintenance levels
    • RH 7.1 or higher service pack and maintenance levels
  • IBM Spectrum Scale v5.0.2 or higher fix pack (Beginning with backup-archive client v8.1.6) on operating systems
    • SLES 12.1 or higher service pack and maintenance levels
    • RH 7.1 or higher service pack and maintenance levels
  • IBM Spectrum Scale v5.0.3 or higher fix pack (Beginning with backup-archive client v8.1.7) on operating systems
    • SLES 15 or higher service pack and maintenance levels
    • SLES 12.1 or higher service pack and maintenance levels
    • RH 7.1 or higher service pack and maintenance levels
Note: As per APAR IT12256 :
GPFS 3.4.0.4 was supported with 7.1.0 but can no longer be supported with the 7.1.1 and higher client, because of technical reasons. GPFS 3.4 reached End of Support (EOS) in April 2015.
Additional Software
The Java GUI and Web backup-archive client requires Java: JRE 7 or JRE 8
Note:
- In backup-archive client v8.1.0, the web client is supported when running in a Mozilla Firefox browser.
- In backup-archive client v8.1.2-v8.1.6.x,  you can no longer use the web client to connect to the IBM Spectrum Protect V8.1.2 or later V8 server or the V7.1.8 or later V7 server. For more information, see  Using the web client in the new security environment.
- Beginning with backup-archive client v8.1.7 a new web user interface for file-restore operations is supported when running in a Mozilla Firefox, Microsoft Edge, Google Chrome browsers.
Be aware web user interface requires IBM Spectrum Protect V8.1.2 or later V8 server or the V7.1.8 or later V7 server. For more information see:   8.1.7 backup-archive client New features and updates
EXT2/EXT3/XFS ACL support, you need the acl package.
The image backup and restore functions for LVM2 volumes require libdevmapper.so v1.01 or higher. If the library is at a lower level than required or it is not available, image backups for LVM2 volumes fail.
The libdevmapper.so library is distributed with the device mapper packages. On RHEL, the package is called device-mapper-libs and on SLES it is called device-mapper.
Novell NSS is supported by this client. For NetApp Data ONTAP support see http://www.ibm.com/support/docview.wss?uid=swg21474217
No automatic client deployment support on:
- Ubuntu 14.04
- Ubuntu 16.04
- Ubuntu 18.04
No GPFS file system support on:
- Ubuntu 14.04
- Ubuntu 16.04
- Ubuntu 18.04
IBM Spectrum Scale SOBAR is supported.
Note:
- On IBM Spectrum Scale 4.2.3 you need at least 4.2.3.5 fix pack.
- Installation of IBM Spectrum Protect Backup-Archive client and IBM Spectrum Protect for Space Management client in the same (matching) release level is required.
-
For IBM Spectrum Protect for Space Management client requirements see: http://www.ibm.com/support/docview.wss?uid=swg21248771


 


Version 7.1

Hardware
System:
Systems based on the X86 64bit processor architecture such as Intel-64 or AMD64
Disk Space:
1.5 GB disk space is required to install the client, and all language packs.
Memory:
No additional RAM is required for product installation. RAM requirements for running the product vary widely and depend on your environment, configuration, and tasks that you perform. Additional RAM might be required to run the product.
Communication Protocol
  • TCP/IP, which comes standard with Linux
  • Shared Memory (only with Linux x86_64 IBM Spectrum Protect server)
Operating System
Backup-Archive client supports one of the following operating systems:
-
SLES 12 (Beginning with backup-archive client v7.1.2)
- SLES 11 (including SLES 11 level in Novell OES 11 and OES 2015 details )
- SLED 11
- RHEL 7 for Servers & Desktop editions (Beginning with backup-archive client v7.1.1)
- RHEL 6 for Servers & Desktop editions
- RHEL 5 for Servers & Desktop editions
- Ubuntu 14.04 (Beginning with backup-archive client v7.1.2)
- Ubuntu 16.04 (Beginning with backup-archive client v7.1.6.3)
Note: For "best effort" support of other Linux distributions, see this technote: http://www.ibm.com/support/docview.wss?uid=swg21417165
Backup-Archive client supports the following filesystems:
For supported file systems on latest fix pack see this web page: https://www.ibm.com/support/knowledgecenter/SSGSG7_7.1.8/client/c_bac_aclsupt.html

The following GPFS versions are supported:
- GPFS 3.5.0 or higher fix pack level
- GPFS 4.1.0 or higher fix pack levels (Beginning with backup-archive client v7.1.1)
   Note: RHEL 7 requires GPFS 4.1.0.10 (TL1) or higher fix pack levels
- GPFS 4.1.1 or higher fix pack levels (Beginning with backup-archive client v7.1.3)
   Note: SLES 12 requires GPFS 4.1.1 or higher fix pack levels
- GPFS 4.2.0 or higher fix pack levels (Beginning with backup-archive client v7.1.4.4)
- GPFS 4.2.1 or higher fix pack levels (Beginning with backup-archive client v7.1.6)

Note: As per APAR IT12256 :
GPFS 3.4.0.4 was supported with v7.1.0 but can no longer be supported with the v7.1.1 and higher client, because of technical reasons. GPFS 3.4 reached End of Support (EOS) in April 2015.
Additional Software
Java GUI and Web backup-archive client require:
- prior to 7.1.2.1: Java GUI requires Java: JRE 7. The Web client requires the Java plugin that is included in JRE 7
- Beginning with 7.1.2.1: Java GUI requires Java: JRE 7 or JRE 8. The Web client requires the Java plugin that is included in JRE 7 or JRE 8.
Note: The client is supported when running in a Firefox browser with the required plugin.
EXT2/EXT3/XFS ACL support, you need the acl package.
The image backup and restore functions for LVM2 volumes require libdevmapper.so v1.01 or higher. If the library is at a lower level than required or it is not available, image backups for LVM2 volumes fail.
The libdevmapper.so library is distributed with the device mapper packages. On RHEL, the package is called device-mapper-libs and on SLES it is called device-mapper.
Prior to 7.1.3, to use the Common Inventory Technology components in a pure 64-bit Linux environment the following 32-bit run-time support packages should be installed:
- with RHEL 7, the compat-libstdc++-33 package is required.
- with SLES 12, the libstdc++33-32bit package is required
   Note: this package is provided by SUSE Legacy Module, see https://www.suse.com/products/server/features/modules.html.
- with Ubuntu 14.04, the libstdc++5:i386 package is required.
To perform backups or restores of VMware virtual machines using the Backup-Archive Client the following package must be installed:
- On a SUSE Linux system, the libfuse.so.2 shared object library must be installed. Install the libfuse version 2 package.
- On RHEL system, the libfuse.so2, libxml2.so, and libexpat.so shared object libraries must be installed. Install fuse-libs version 2 package.
Novell NSS is supported by this client. For NetApp Data ONTAP support see http://www.ibm.com/support/docview.wss?uid=swg21474217
Journal Based Backup (JBB) is:
- supported on RHEL 7 and SLES 12, in addition to previously supported distributions (Beginning with 7.1.2 backup-archive client)
- supported on RHEL 7.1 (Beginning with 7.1.4 backup-archive client)
No automatic client deployment support on:
- Ubuntu 14.04
- Ubuntu 16.04
No GPFS file system support on:
- Ubuntu 14.04
- Ubuntu 16.04
IBM Spectrum Scale SOBAR is supported.
Note:
- requires GPFS 3.5 TL 3 or higher.
- IBM Spectrum Protect for Space Management of the same version as the backup archive client is also required.
- For IBM Spectrum Protect for Space Management client requirements see: http://www.ibm.com/support/docview.wss?uid=swg21248771


Versions past End of Support (EOS)

Note:

  • The LAN-Free client also requires IBM Tivoli Storage Manager for Storage Area Networks (5608-SAN).

  • HSM client also requires IBM Tivoli Storage Manager for Space Management. See this page for HSM client requirements: http://www.ibm.com/support/docview.wss?uid=swg21248771
     

 
 


Client Components Offered

Administrative Backup/Archive HSM API
Command Line Interface Graphical User Interface Command Line Interface Web Browser Interface Graphical User Interface (until version 7.1.1) Command Line Interface Interface
yes yes yes yes yes yes yes

Related information

Latest client downloads
Overview Spectrum Protect Operating Systems
Overview Tivoli storage Manager Operating Systems
Featured Documents Spectrum Protect
Space Management (HSM) all requirements doc

Cross reference information
Product Component Platform Version Edition
Tivoli Storage Manager Client

Document information

More support for: IBM Spectrum Protect

Component: Client

Software version: 7.1, 8.1

Operating system(s): Linux

Reference #: 1052223

Modified date: 23 April 2019