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What is causing a PDF error: "dispatch -acroexch.app could not be loaded"?

Question & Answer


Question

When viewing a PDF document in OnDemand, I receive the following error: "dispatch -acroexch.app could not be loaded"

Cause

If the application's Data Type is defined as PDF, the OnDemand client requires Adobe® Acrobat to be installed in order to view the PDF document.

The OnDemand client requires an Adobe Acrobat viewer that contains an OLE interface to view the PDF, which is only provided in Adobe Acrobat (Adobe Reader does not provide this OLE interface).

Answer

If you get the error: unable to load adobeacrobatexch when you view a PDF document from the OnDemand client, take the following steps:

  1. Ensure that you have Adobe Acrobat installed and associated with the .pdf extension in Windows®.
  2. In the C:\Program Files\IBM\OnDemand32\PDF directory, copy the ARSPDF32.API file to your adobe/acrobat/plugins directory.
  3. Restart your OnDemand client and attempt to view the PDF document again.

Note: The OnDemand client will attempt to automatically perform step 2 during installation if Adobe Acrobat is previously installed.

Alternatively, if the Data Type under the application is user-defined .pdf, the OnDemand client will instead launch the application associated with this extension in Windows to handle the viewing of this document. In this situation, Adobe Reader can be used to view the PDF, as this will bypass viewing the document within the OnDemand client and through the OLE interface.

[{"Product":{"code":"SSEPCD","label":"Content Manager OnDemand for Multiplatforms"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Not Applicable","Platform":[{"code":"PF033","label":"Windows"}],"Version":"7.1;7.1.1;8.3;8.4","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
17 June 2018

UID

swg21046703