IBM Support

CTG TESTECI sample fails with return code -26 or -3

Troubleshooting


Problem

After installing the CTG, the TESTECI may fail with return code -26 or -3

Cause

User configuration incomplete

Resolving The Problem

When running ctgstart from the OMVS shell, the -26 return code is resolved by adding DFHJVSYSTEM_nn and DFHJVPIPE variables to the script. If the CTG is run as a started task, these need to be set by coding an export command instead. Also, it is a REQUIREMENT to code the comments too. Otherwise, the -26 code will not be cleared up.

The CICSECI.CBL sample supplied with CTG describes the different error codes which can be returned by the CICS External Call Interface. Currently, those values are:

0ECI-NO-ERROR
-1ECI-ERR-INVALID-DATA-LENGTH
-2ECI-ERR-INVALID-EXTEND-MODE
-3ECI-ERR-NO-CICS
-4ECI-ERR-CICS-DIED
-5ECI-ERR-REQUEST-TIMEOUT
-5ECI-ERR-NO-REPLY
-6ECI-ERR-RESPONSE-TIMEOUT
-7ECI-ERR-TRANSACTION-ABEND
-8ECI-ERR-EXEC-NOT-RESIDENT
-8ECI-ERR-LUW-TOKEN
-9ECI-ERR-SYSTEM-ERROR
-10ECI-ERR-NULL-WIN-HANDLE
-12ECI-ERR-NULL-MESSAGE-ID
-13ECI-ERR-THREAD-CREATE-ERROR
-14ECI-ERR-INVALID-CALL-TYPE
-15ECI-ERR-ALREADY-ACTIVE
-16ECI-ERR-RESOURCE-SHORTAGE
-17ECI-ERR-NO-SESSIONS
-18ECI-ERR-NULL-SEM-HANDLE
-19ECI-ERR-INVALID-DATA-AREA
-21ECI-ERR-INVALID-VERSION
-22ECI-ERR-UNKNOWN-SERVER
-23ECI-ERR-CALL-FROM-CALLBACK
-24ECI-ERR-INVALID-TRANSID
-25ECI-ERR-MORE-SYSTEMS
-26ECI-ERR-NO-SYSTEMS
-27ECI-ERR-SECURITY-ERROR
-28ECI-ERR-MAX-SYSTEMS
-29ECI-ERR-MAX-SESSIONS
-30ECI-ERR-ROLLEDBACK

[{"Product":{"code":"SSGMJ2","label":"CICS Transaction Gateway"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Component":"CTG","Platform":[{"code":"PF035","label":"z\/OS"}],"Version":"8.0;7.2;7.1;7.0;6.1;6.0;5.1;5.0","Edition":"","Line of Business":{"code":"LOB35","label":"Mainframe SW"}}]

Document Information

Modified date:
15 June 2018

UID

swg21038732