'Make Executable' fails with a Stack Trace

Technote (troubleshooting)


Problem(Abstract)

'Make Executable' fails with a Stack Trace indicating 'EpPackager does not understand neverRequired:'.

Resolving the problem

Problem: Attempting to 'Make Executable' from the composition editor gets a Stack Trace with 'EpPackager does not understand neverRequired:'.

Resolution: The neverRequired: method in question should be brought in via the AbtEpPackager class of the AbtRuntimePackaging application. This app is in the "VisualAge for Smalltalk" config map. The neverRequired: method is an accessor method for the neverRequired instance variable of the AbtEpPackager class (which is a subclass of EpPackager). Reloading the config map resolves the problem.

Rate this page:

(0 users)Average rating

Document information


More support for:

VisualAge Smalltalk
Packaging

Software version:

5.0, 5.0.1, 5.5

Operating system(s):

All Platforms

Reference #:

1000787

Modified date:

2007-12-21

Translate my page

Machine Translation

Content navigation