PM88992: CREATE VERSION CLASS FOR WS-SECURITY RUNTIME

Subscribe

You can track all active APARs for this component.

APAR status

  • Closed as program error.

Error description

  • The only way to find the level of the was-wssecurity-8.0.jar
    that is being used is to inspect the META-INF/MANIFEST.MF file
    contained within the jar.  A more user-friendly way of doing
    this is required.
    

Local fix

Problem summary

  • ****************************************************************
    * USERS AFFECTED:  IBM WebSphere Application Server            *
    *                  administrators of JAX-WS WS-Security        *
    *                  applications                                *
    ****************************************************************
    * PROBLEM DESCRIPTION: Create a Version class for the          *
    *                      WS-Security runtime                     *
    ****************************************************************
    * RECOMMENDATION:  Install a fix pack that includes this       *
    *                  APAR.                                       *
    ****************************************************************
    The WebSphere Application Server WS-Security runtime is
    included in IBM products other than the WebSphere Application
    Server.  These products include either the thincient
    (com.ibm.jaxws.thinclient*.jar) or the common component
    (was-wssecurity-*.jar).
    When a problem in the WS-Security runtime is reported by one
    of these products, it is sometimes difficult to determine the
    level of the WS-Security runtime that is being used.
    The only way to find the level of the was-wssecurity-*.jar
    that is being used is to inspect the META-INF/MANIFEST.MF file
    contained within the jar.
    The only way to find the level of the
    com.ibm.jaxws.thinclient_* file that is used is to rely on the
    output of the web services version from
    com.ibm.ws.webservices.Version.
    A more user-friendly and consistent way of obtaining the level
    of the WS-Security runtime being used is required.
    

Problem conclusion

  • A new class called com.ibm.ws.wssecurity.util.Version is added
    to the WS-Security runtime.  This class can be run from a
    command line.  For example:
    
    java -cp ./(jarName) com.ibm.ws.wssecurity.util.Version
    
    IBM WS-Security build: gm1318.01
    IBM WS-Security release: 8.5.5
    Time stamp: 5/8/13 16:52:50
    
    This new class file is included in the following jars:
    
    was-wssecurity-8.0.jar
    was-wssecurity-8.5.5.jar
    com.ibm.jaxws.thinclient_7.0.0.jar
    com.ibm.jaxws.thinclient_8.0.0.jar
    com.ibm.jaxws.thinclient_8.5.0.jar
    com.ibm.wsfp.main.jar
    
    
    The fix for this APAR is currently targeted for inclusion in
    fix packs 7.0.0.31, 8.0.0.7, and 8.5.5.1.  Please refer to the
    Recommended Updates page for delivery information:
    http://www.ibm.com/support/docview.wss?rs=180&uid=swg27004980
    

Temporary fix

Comments

APAR Information

  • APAR number

    PM88992

  • Reported component name

    WEBS APP SERV N

  • Reported component ID

    5724H8800

  • Reported release

    800

  • Status

    CLOSED PER

  • PE

    NoPE

  • HIPER

    NoHIPER

  • Special Attention

    NoSpecatt

  • Submitted date

    2013-05-14

  • Closed date

    2013-05-17

  • Last modified date

    2013-10-15

  • APAR is sysrouted FROM one or more of the following:

  • APAR is sysrouted TO one or more of the following:

Fix information

  • Fixed component name

    WEBS APP SERV N

  • Fixed component ID

    5724H8800

Applicable component levels

  • R700 PSY

       UP

  • R800 PSY

       UP

  • R850 PSY

       UP



Rate this page:

(0 users)Average rating

Add comments

Document information


More support for:

WebSphere Application Server
General

Software version:

8.0

Reference #:

PM88992

Modified date:

2013-10-15

Translate my page

Machine Translation

Content navigation