PM82584: Rational Integration Tester's Intercept API exit for WebSphere MQ running on AIX only works for AIX 7

Subscribe

You can track all active APARs for this component.

APAR status

  • Closed as program error.

Error description

  • If the Intercept MQ API exit is configured for a Queue Manager
    running on AIX 6, that Queue Manager cannot be started.
    Attempting to do so from the command line gives an error, for
    example:
    
    -bash-3.2$ strqm venus.queue.manager
    
    WebSphere MQ queue manager 'venus.queue.manager' starting.
    The queue manager is associated with installation
    'Installation1'.
    AMQ7214: The module for API Exit 'Intercept' could not be
    loaded.
    

Local fix

Problem summary

  • ****************************************************************
    * USERS AFFECTED:                                              *
    * Anyone users wishing to use the Rational Integration Tester  *
    * Intercept MQ API exit on AIX 6                               *
    ****************************************************************
    * PROBLEM DESCRIPTION:                                         *
    * If the Intercept MQ API exit is configured for a Queue       *
    * Manager                                                      *
    * running on AIX 6, that Queue Manager cannot be started.      *
    * Attempting to do so from the command line gives an error,    *
    * for                                                          *
    * example:                                                     *
    *                                                              *
    * -bash-3.2$ strqm venus.queue.manager                         *
    *                                                              *
    * WebSphere MQ queue manager 'venus.queue.manager' starting.   *
    * The queue manager is associated with installation            *
    * 'Installation1'.                                             *
    * AMQ7214: The module for API Exit 'Intercept' could not be    *
    * loaded.                                                      *
    ****************************************************************
    * RECOMMENDATION:                                              *
    * Use the Intercept API exit modules shipped with Rational     *
    * Integration Tester 8.0.1.3 and above as this supports AIX 6. *
    ****************************************************************
    

Problem conclusion

  • A new version of the Intercept API exit that is compatible with
    AIX 6 is shipped with Rational Integration Tester 8.0.1.3 and
    above.
    

Temporary fix

Comments

APAR Information

  • APAR number

    PM82584

  • Reported component name

    RATL INTEGRA TE

  • Reported component ID

    5725G79IT

  • Reported release

    801

  • Status

    CLOSED PER

  • PE

    NoPE

  • HIPER

    NoHIPER

  • Special Attention

    NoSpecatt

  • Submitted date

    2013-02-12

  • Closed date

    2013-07-12

  • Last modified date

    2013-07-12

  • APAR is sysrouted FROM one or more of the following:

  • APAR is sysrouted TO one or more of the following:

Fix information

  • Fixed component name

    RATL INTEGRA TE

  • Fixed component ID

    5725G79IT

Applicable component levels

  • R800 PSN

       UP

  • R801 PSY

       UP

  • R850 PSY

       UP



Document information


More support for:

Rational Test Workbench

Software version:

8.0.1

Reference #:

PM82584

Modified date:

2013-07-12

Translate my page

Content navigation