PM81537: DEPLOYING A MIDDLEWARE APPLICATION TO WASCE 3.0 SERVER ON WEBSPHERE VIRTUAL ENTERPRISE 7.0 FAILS

Subscribe

You can track all active APARs for this component.

APAR status

  • Closed as program error.

Error description

  • Deploy a middleware application to WASCE 3.0 server fails with
    the following error:
    
    WASCE log:
    
    2012-12-27 15:03:39,295 ERROR [DeployTool] Error:
    org.apache.geronimo.common.DeploymentException: No target named
    or matching
    'com.ibm.ws.xd.ce.configs/CE_Cluster_test_repository/
    2.1/car?ServiceModule=com.ibm.ws.xd.ce.configs/
    CE_Cluster_test_repository/2.1/car,
    j2eeType=ConfigurationStore,name=CE_Cluster_test_repository
    was found
    

Local fix

  • Manually edit the ce_3.0.xml in the <WAS_HOME>/properties/
    directory for the Nodes and the DMGR and change all references
    of 2.1 to 2.2
    
    Example of changed ce_3.0.xml:
    
    <target name="installApp" depends="init">
            <exec dir="${GERONIMO_HOME}/bin"
    executable="${GERONIMO_HOME}/bin/deploy.${OSEXT}"
    failonerror="true">
                <arg line="-port ${NamingPort} -u ${USERID} -p
    ${PASSWORD}
    ${SecureJMXParam} deploy --targets
    com.ibm.ws.xd.ce.configs/${SERVER}_repository/2.2/car?ServiceMod
    ule=com.
    ibm.ws.xd.ce.configs/${SERVER}_repository/2.2/car,j2eeType=Confi
    guration
    Store,name=${SERVER}_repository ${appLocation}"/>
                <env key="JAVA_HOME" value="${JAVA_HOME}"/>
                <env key="GERONIMO_OPTS"
    value="-Dorg.apache.geronimo.server.dir=${serverDir}"/>
                    <env key="JAVA_OPTS" value="${JavaOptions}"/>
            </exec>
    
    This needs to be done for target name="installPlan", target
    name="installAppWithPlan", and target name="installApp".
    

Problem summary

  • ****************************************************************
    * USERS AFFECTED:  All users of WebSphere Virtual Enterprise   *
    *                  using WebSphere Community Edition 3.0       *
    ****************************************************************
    * PROBLEM DESCRIPTION: The middleware application deployment   *
    *                      to a WebSphere Community Edition        *
    *                      3.0.0.2 server fails.                   *
    ****************************************************************
    * RECOMMENDATION:                                              *
    ****************************************************************
    The middleware application deployment to WebSphere Community
    Edition 3.0.0.2 server fails because the wrong 'car' version is
    used in the deploy command.
    

Problem conclusion

  • The ce_3.0.xml file was changed to use the correct 'car'
    version 2.2.
    
    This fix will be included in the next available fix pack
    for WebSphere Virtual Enterprise.
    

Temporary fix

Comments

APAR Information

  • APAR number

    PM81537

  • Reported component name

    WAS VIRTUAL ENT

  • Reported component ID

    5725C9203

  • Reported release

    700

  • Status

    CLOSED PER

  • PE

    NoPE

  • HIPER

    NoHIPER

  • Special Attention

    NoSpecatt

  • Submitted date

    2013-01-28

  • Closed date

    2013-02-13

  • Last modified date

    2013-02-13

  • APAR is sysrouted FROM one or more of the following:

  • APAR is sysrouted TO one or more of the following:

    PM82465

Fix information

  • Fixed component name

    WAS VIRTUAL ENT

  • Fixed component ID

    5725C9203

Applicable component levels

  • R700 PSY

       UP



Rate this page:

(0 users)Average rating

Add comments

Document information


More support for:

WebSphere Virtual Enterprise
General

Software version:

7.0

Reference #:

PM81537

Modified date:

2013-02-13

Translate my page

Machine Translation

Content navigation