PM76864: VERIFYR CODE INCORRECT UNDER OPT(3) AND HIGH ARCH LEVELS

A fix is available

Subscribe

You can track all active APARs for this component.

APAR status

  • Closed as program error.

Error description

  • VERIFYR code incorrect under OPT(3) and high ARCH levels
    

Local fix

Problem summary

  • ****************************************************************
    * USERS AFFECTED: Users of the VERIFRY (not VERIFY) and OPT(3) *
    *                 and an ARCH level of 7 or higher             *
    ****************************************************************
    * PROBLEM DESCRIPTION: Under ARCH(7) or higher, the TRTR       *
    *                      instruction is used. But unfortunately  *
    *                      there is an error in the code generated *
    *                      for the TRTR under higher opt levels.   *
    ****************************************************************
    * RECOMMENDATION:                                              *
    ****************************************************************
    

Problem conclusion

  • The compiler bug has been fixed. Code using VERIFYR will now
    work correctly when recompiled.
    

Temporary fix

Comments

APAR Information

  • APAR number

    PM76864

  • Reported component name

    ENT PL/I FOR ZO

  • Reported component ID

    5655W6700

  • Reported release

    420

  • Status

    CLOSED PER

  • PE

    NoPE

  • HIPER

    NoHIPER

  • Special Attention

    NoSpecatt

  • Submitted date

    2012-11-09

  • Closed date

    2012-12-11

  • Last modified date

    2013-01-02

  • APAR is sysrouted FROM one or more of the following:

  • APAR is sysrouted TO one or more of the following:

    UK90231 UK90232

Modules/Macros

  • IBM3TBY
    

Fix information

  • Fixed component name

    ENT PL/I FOR ZO

  • Fixed component ID

    5655W6700

Applicable component levels

  • R420 PSY UK90231

       UP12/12/13 P F212

  • R430 PSY UK90232

       UP12/12/13 P F212

Fix is available

  • Select the PTF appropriate for your component level. You will be required to sign in. Distribution on physical media is not available in all countries.



Rate this page:

(0 users)Average rating

Add comments

Document information


More support for:

Enterprise PL/I for z/OS

Software version:

4.2

Reference #:

PM76864

Modified date:

2013-01-02

Translate my page

Machine Translation

Content navigation