PM74876: The Javascript Validator causes a build error after upgrading to v8.0.4.1

Subscribe

You can track all active APARs for this component.

APAR status

  • Closed as program error.

Error description

  • Abstract:
    
    In some scenarios after upgrading to v8.0.4.1 from then attempts
    to build applications that involve JavaScript results in the
    following JavaScript Validator exception:
    Errors running builder 'JavaScript Validator' on project
    MyProject.
    org.eclipse.wst.jsdt.internal.compiler.lookup.BaseTypeBinding
    incompatible with
    org.eclipse.wst.jsdt.internal.compiler.lookup.ReferenceBinding.
    
    Problem:
    
    When you have a project that includes JavaScript files then
    after upgrading to v8.0.4.1 your project build does not compile
    due to the following error:
    
    Errors running builder 'JavaScript Validator' on project
    MyProject.
    org.eclipse.wst.jsdt.internal.compiler.lookup.BaseTypeBinding
    incompatible with
    org.eclipse.wst.jsdt.internal.compiler.lookup.ReferenceBinding.
    
    The error will then appear in the Marker tab and prevents you
    from successfully compiling your project.
    
    Local fix:
    
    Disable the JavaScript validator.
    

Local fix

Problem summary

  • ****************************************************************
    * USERS AFFECTED:                                              *
    ****************************************************************
    * PROBLEM DESCRIPTION:                                         *
    ****************************************************************
    * RECOMMENDATION:                                              *
    ****************************************************************
    While merging the definitions of types across multiple
    files, it was assumed that a base type would never be
    encountered; all bindings are expected to be
    ReferenceBindings.  This isn't even necessary, though, as
    nothing from the ReferenceBinding interface is required
    later on.
    

Problem conclusion

  • The Typecast was removed to fix this problem.
    
    The fix for this APAR is included in Rational Application
    Developer v8.0.4.2.
    

Temporary fix

Comments

APAR Information

  • APAR number

    PM74876

  • Reported component name

    RATL APP DEV WI

  • Reported component ID

    5724J1901

  • Reported release

    804

  • Status

    CLOSED PER

  • PE

    NoPE

  • HIPER

    NoHIPER

  • Special Attention

    NoSpecatt

  • Submitted date

    2012-10-11

  • Closed date

    2012-12-15

  • Last modified date

    2012-12-15

  • APAR is sysrouted FROM one or more of the following:

  • APAR is sysrouted TO one or more of the following:

Fix information

  • Fixed component name

    RATL APP DEV WI

  • Fixed component ID

    5724J1901

Applicable component levels

  • R804 PSN

       UP



Rate this page:

(0 users)Average rating

Document information


More support for:

Rational Application Developer for WebSphere Software

Software version:

8.0.4

Reference #:

PM74876

Modified date:

2012-12-15

Translate my page

Machine Translation

Content navigation