PM73692: 'Line level code coverage' feature is missing in RSA4WS 8.5 Installation

Subscribe to this APAR

By subscribing, you receive periodic emails alerting you to the status of the APAR, along with a link to the fix after it becomes available. You can track this item individually or track all items by product.

Notify me when this APAR changes.

Notify me when an APAR for this component changes.

APAR status

  • Closed as program error.

Error description

  • Environment:
    - Microsoft Windows
        - Product: RSA4WS 8.5
    
    Reproducible: Y
    
    Description of problem:
    
    The 'Line level code coverage' feature is missing in RSA4WS 8.5
    Installation.
    
    According to the infocenter, this feature should be available
    after the 'server tools' features under the 'Extension for SOA
    and web applications' group, but it?s not there, nor anywhere
    else, whether a 32 bits or 64bits installation is requested. On
    the other hand, with RSA4WS 8.0.x, the feature is there, as
    expected.
    
    Steps to reproduce
    
    1) Launch the installation of IBM Rational Software Architect
    for Websphere 8.5
    2) Proceed with the installation, until the 'Features' page of
    the wizard. 32bits or 64bits installation can be chosen
    indifferently.
    3) Notice that there is no 'Line level code coverage' feature
    under the 'Extension for SOA and web applications' group or
    anywhere else.
    
    Workaround
    
    1. Install RSA4WS 85 with these features installed:
    - Architect - Minimal
    - Architect - Standard
    - MDD for Java - Minimal
    - MDD for Java - Standard
    2. Unzip rational-code-coverage.zip to temp directory
    3. Copy plugins directory to ?install_dir?
    4. Copy features directory to ?install_dir?
    5. Start the product
    

Local fix

Problem summary

  • ****************************************************************
    * USERS AFFECTED:                                              *
    ****************************************************************
    * PROBLEM DESCRIPTION:                                         *
    ****************************************************************
    * RECOMMENDATION:                                              *
    ****************************************************************
    The Line level code coverage feature is missing in the
    Rational Software Architect for WebSphere Application Server
    v8.5 offering.
    

Problem conclusion

  • The Line level code coverage feature is now available in the
    Rational Software Architect for WebSphere Application Server
    v8.5.1 offering.
    

Temporary fix

Comments

APAR Information

  • APAR number

    PM73692

  • Reported component name

    SW ARCHITECT WI

  • Reported component ID

    5724I7001

  • Reported release

    850

  • Status

    CLOSED PER

  • PE

    NoPE

  • HIPER

    NoHIPER

  • Special Attention

    NoSpecatt

  • Submitted date

    2012-09-26

  • Closed date

    2012-12-19

  • Last modified date

    2012-12-19

  • APAR is sysrouted FROM one or more of the following:

  • APAR is sysrouted TO one or more of the following:

Fix information

  • Fixed component name

    SW ARCHITECT WI

  • Fixed component ID

    5724I7001

Applicable component levels

  • R850 PSN

       UP



Rate this page:

(0 users)Average rating

Add comments

Document information


More support for:

Rational Software Architect

Software version:

850

Reference #:

PM73692

Modified date:

2012-12-19

Translate my page

Machine Translation

Content navigation