IBM Support

PM05187: Build Forge UI has cross site scripting vulnerability.

Subscribe

You can track all active APARs for this component.

APAR status

  • Closed as program error.

Error description

  • The customer ran Rational App Scan against Build Forge and found
    a high priority security vulnerability in the UI.
    

Local fix

Problem summary

  • A couple of the variables were cleanly passed through from
    any request. This was a non-issue in most cases, but fixed.
    For future tickets of this nature please submit the exact
    process to recreate.
    

Problem conclusion

  • Fixed
    

Temporary fix

Comments

APAR Information

  • APAR number

    PM05187

  • Reported component name

    BUILD FORGE EE

  • Reported component ID

    5724S2701

  • Reported release

    702

  • Status

    CLOSED PER

  • PE

    NoPE

  • HIPER

    NoHIPER

  • Special Attention

    NoSpecatt

  • Submitted date

    2010-01-14

  • Closed date

    2011-03-05

  • Last modified date

    2011-03-05

  • APAR is sysrouted FROM one or more of the following:

  • APAR is sysrouted TO one or more of the following:

Fix information

  • Fixed component name

    BUILD FORGE EE

  • Fixed component ID

    5724S2701

Applicable component levels

  • R712 PSY

       UP



Document information

More support for: Rational Build Forge

Software version: 7.0.2

Reference #: PM05187

Modified date: 05 March 2011