IBM Support

PK97516: ASE 5.5 vulnerable to XSS

 

APAR status

  • Closed as program error.

Error description

  • The vulnerable parameter in question is tabstripid on the URL  h
    ttp://host/ase/Help/Help.aspx.
    

Local fix

Problem summary

  • XSS Vulnerability in Query String of ASE inside help pages
    

Problem conclusion

  • Fixed in Release Rational AppScan Enterprise 5.6.
    

Temporary fix

Comments

APAR Information

  • APAR number

    PK97516

  • Reported component name

    RATL APPSCAN EE

  • Reported component ID

    5724T5200

  • Reported release

    550

  • Status

    CLOSED PER

  • PE

    NoPE

  • HIPER

    NoHIPER

  • Special Attention

    NoSpecatt

  • Submitted date

    2009-09-30

  • Closed date

    2009-10-20

  • Last modified date

    2009-10-20

  • APAR is sysrouted FROM one or more of the following:

  • APAR is sysrouted TO one or more of the following:

Fix information

  • Fixed component name

    RATL APPSCAN EE

  • Fixed component ID

    5724T5200

Applicable component levels

  • R550 PSN

       UP

Document information

More support for: IBM Security AppScan Enterprise

Software version: 550

Reference #: PK97516

Modified date: 20 October 2009