JR46025: SYBASE DRS STAGE FOR IS 8.7 HAS BEEN COMPILED WITH SYBASE SDK 12.5 WHILE SUPPORT MATRIX SAYS THAT IQ 15.3 IS CERTIFIED.

Subscribe

You can track all active APARs for this component.

APAR status

  • Closed as program error.

Error description

  • Sybase DRS stage for IS 8.7 has been compiled with Sybase SDK
    12.5 despite our support matrix claiming we support ASE 15.5
    and IQ 15.3.
    Sybase claims we must always "be certain that the runtime
    libraries are for the same major release as the version used to
    build the application".
    

Local fix

  • Use Sybase-related stages.
    

Problem summary

  • Sybase requires that client applications be compiled/linked with
     the same major version of OCS that they will be run with. In
    order to support 15.3, we need to compile/link with version 15
    of OCS
    

Problem conclusion

  • Until now we have been compiling with 12.5 of OCS.  We are now
    building with version 15.
    

Temporary fix

  • Use 12.5 client runtime.
    

Comments

APAR Information

  • APAR number

    JR46025

  • Reported component name

    WIS DATASTAGE

  • Reported component ID

    5724Q36DS

  • Reported release

    870

  • Status

    CLOSED PER

  • PE

    NoPE

  • HIPER

    NoHIPER

  • Special Attention

    NoSpecatt

  • Submitted date

    2013-03-14

  • Closed date

    2013-05-06

  • Last modified date

    2013-05-06

  • APAR is sysrouted FROM one or more of the following:

  • APAR is sysrouted TO one or more of the following:

Fix information

  • Fixed component name

    WIS DATASTAGE

  • Fixed component ID

    5724Q36DS

Applicable component levels

  • R870 PSY

       UP



Rate this page:

(0 users)Average rating

Add comments

Document information


More support for:

InfoSphere DataStage

Software version:

8.7

Reference #:

JR46025

Modified date:

2013-05-06

Translate my page

Machine Translation

Content navigation