IZ76368: UNABLE TO RUN WEBSPHERE MQ V7 RESOURCE ADAPTER IVT ON WEBSPHERE APPLICATION SERVER CE V2.1

Subscribe

You can track all active APARs for this component.

APAR status

  • Closed as program error.

Error description

  • When attempting to deploy the WebSphere MQ V7 Resource Adapter
    Installation Verification Test (IVT) program on WebSphere
    Application Server, Community Edition (WAS CE) V2.1, the
    deployment fails with the following error:
    
    Deployment Failed
    Failed parsing descriptors for module:
    /home/WASCE/var/temp/
    geronimo-deploymentUtil3410776142431146141.jar
    org.apache.geronimo.common.DeploymentException: Failed parsing
    descriptors for module:
    /home/WASCE/var/temp/
    geronimo-deploymentUtil3410776142431146141.jar
    at
    org.apache.geronimo.openejb.deployment.EjbModuleBuilder
    .createModule(EjbModuleBuilder.java:300)
    at
    org.apache.geronimo.openejb.deployment.EjbModuleBuilder
    .createModule(EjbModuleBuilder.java:229)
    at
    org.apache.geronimo.j2ee.deployment.EARConfigBuilder
    .addModules(EARConfigBuilder.java:784)
    at
    org.apache.geronimo.j2ee.deployment.EARConfigBuilder
    .getEarPlan(EARConfigBuilder.java:400)
    at
    org.apache.geronimo.j2ee.deployment.EARConfigBuilder
    .getDeploymentPlan(EARConfigBuilder.java:293)
    at
    org.apache.geronimo.deployment.Deployer
    .deploy(Deployer.java:227)
    at
    org.apache.geronimo.deployment.Deployer
    .deploy(Deployer.java:134)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at
    sun.reflect.NativeMethodAccessorImpl
    .invoke(NativeMethodAccessorImpl.java:39)
    at
    sun.reflect.DelegatingMethodAccessorImpl
    .invoke(DelegatingMethodAccessorImpl.java:25)
    at java.lang.reflect.Method.invoke(Method.java:597)
    at
    org.apache.geronimo.gbean.runtime.ReflectionMethodInvoker
    .invoke(ReflectionMethodInvoker.java:34)
    at
    org.apache.geronimo.gbean.runtime.GBeanOperation
    .invoke(GBeanOperation.java:124)
    at
    org.apache.geronimo.gbean.runtime.GBeanInstance
    .invoke(GBeanInstance.java:867)
    at
    org.apache.geronimo.kernel.basic.BasicKernel
    .invoke(BasicKernel.java:239)
    at
    org.apache.geronimo.deployment.plugin.local
    .AbstractDeployCommand.doDeploy
    (AbstractDeployCommand.java:116)
    at
    org.apache.geronimo.deployment.plugin.local
    .DistributeCommand.run(DistributeCommand.java:61)
    at java.lang.Thread.run(Thread.java:619)
    Caused by: org.apache.openejb.OpenEJBException: Cannot
    unmarshall the openejb-jar.xml. Xml content written to:
    /home/WASCE/var/temp/openejb-jar-5593926981505461455.xml:
    unexpected element
    (uri:"http://geronimo.apache.org/xml/ns/deployment-1.1",
    local:"environment"). Expected elements are
    <{http://openejb.apache.org/xml/ns/openejb-jar-2.2}
    ejb-ql-compiler-factory>,
    <{http://geronimo.apache.org/xml/ns/deployment-1.2}service>,
    <{http://geronimo.apache.org/xml/ns/naming-1.2}
    message-destination>,
    <{http://openejb.apache.org/xml/ns/openejb-jar-2.2}
    db-syntax-factory>,
    <{http://geronimo.apache.org/xml/ns/security-2.0}security>,
    <{http://geronimo.apache.org/xml/ns/deployment-1.2}
    environment>,
    <{http://java.sun.com/xml/ns/persistence}persistence>,
    <{http://geronimo.apache.org/xml/ns/naming-1.2}
    cmp-connection-factory>,
    <{http://openejb.apache.org/xml/ns/openejb-jar-2.2}
    relationships>,
    <{http://geronimo.apache.org/xml/ns/deployment-1.2}gbean>,
    <{http://openejb.apache.org/xml/ns/openejb-jar-2.2}
    enterprise-beans>,
    <{http://openejb.apache.org/xml/ns/openejb-jar-2.2}
    enforce-foreign-key-constraints>,
    <{http://geronimo.apache.org/xml/ns/j2ee/application-1.2}
    security>
    :    :    :    :    :    :    :    :    :    :    :    :    :
    <additional lines removed for readability>
    

Local fix

Problem summary

  • ****************************************************************
    USERS AFFECTED:
    This issue affects users of the WebSphere MQ V7 Resource
    Adapter (WMQ RA) and the Resource Adapter IVT with WAS CE V2.1.
    
    Platforms affected:
    All Distributed (iSeries, all Unix and Windows) +Java
    ****************************************************************
    PROBLEM SUMMARY:
    The deployment descriptors provided with the WMQ V7 RA IVT were
    not compatible with WAS CE V2.1.
    

Problem conclusion

  • The WMQ RA IVT has been updated to make use of the XML V1.1
    schemas that are required by WAS CE V2.1.
    
    ---------------------------------------------------------------
    The fix is targeted for delivery in the following PTFs:
    
                       v7.0
    Platform           Fix Pack 7.0.1.4
    --------           --------------------
    Windows            U200323
    AIX                U835793
    HP-UX (PA-RISC)    U836458
    HP-UX (Itanium)    U836463
    Solaris (SPARC)    U836459
    Solaris (x86-64)   U836465
    iSeries            tbc_p700_0_1_4
    Linux (x86)        U836460
    Linux (x86-64)     U836464
    Linux (zSeries)    U836461
    Linux (Power)      U836462
    
    The latest available maintenance can be obtained from
    'WebSphere MQ Recommended Fixes'
    http://www-1.ibm.com/support/docview.wss?rs=171&uid=swg27006037
    
    If the maintenance level is not yet available, information on
    its planned availability can be found in 'WebSphere MQ
    Planned Maintenance Release Dates'
    http://www-1.ibm.com/support/docview.wss?rs=171&uid=swg27006309
    ---------------------------------------------------------------
    

Temporary fix

Comments

APAR Information

  • APAR number

    IZ76368

  • Reported component name

    WMQ LIN X86 V7

  • Reported component ID

    5724H7224

  • Reported release

    700

  • Status

    CLOSED PER

  • PE

    NoPE

  • HIPER

    NoHIPER

  • Special Attention

    NoSpecatt

  • Submitted date

    2010-05-24

  • Closed date

    2010-06-28

  • Last modified date

    2010-06-28

  • APAR is sysrouted FROM one or more of the following:

  • APAR is sysrouted TO one or more of the following:

Fix information

  • Fixed component name

    WMQ LIN X86 V7

  • Fixed component ID

    5724H7224

Applicable component levels

  • R700 PSY

       UP



Rate this page:

(0 users)Average rating

Add comments

Document information


More support for:

WebSphere MQ
APAR / Maintenance

Software version:

7.0

Reference #:

IZ76368

Modified date:

2010-06-28

Translate my page

Machine Translation

Content navigation