IBM Support

IV51057: UTILITIES 7501 DOES NOT WORK UNDER TPAE7505

Subscribe

You can track all active APARs for this component.

APAR status

  • Closed as program error.

Error description

  • Summary:
    UTILITIES 7501 does not work under TPAE7505
    
    How to reproduce - New user scenario:
    - Install Utilities 7501 on the top of TPAE7505;
    
    How to reproduce - Existing user scenario:
    - Install Utilities 7501 on the top of TPAE7504;
    - Update the TPAE for version 7505.
    
    The error below is displayed in both scenarios above:
    insert into amcrewlabor (amcrewlaborid, amcrew, orgid, position,
    effectivedate, enddate, laborcode, craft, skilllevel, vendor,
    contractnum, calnum, shiftnum ) select amcrewlaborseq.nextval,
    plusdcrewlabor.crew, plusdcrewlabor.orgid,
    plusdcrewlabor.position, plusdcrewlabor.effectivedate,
    plusdcrewlabor.enddate, plusdcrewlabor.laborcode,
    plusdcrewlabor.craft, plusdcrewlabor.skilllevel,
    plusdcrewlabor.vendor, plusdcrewlabor.contractnum,
    plusdcrewlabor.calnum, plusdcrewlabor.shiftnum  from
    plusdcrewlabor
    ;
    insert into amcrewlabor (amcrewlaborid, amcrew, orgid, position,
    effectivedate, enddate, laborcode, craft, skilllevel, vendor,
    contractnum, calnum, shiftnum ) select amcrewlaborseq.nextval,
    plusdcrewlabor.crew, plusdcrewlabor.orgid,
    plusdcrewlabor.position, plusdcrewlabor.effectivedate,
    plusdcrewlabor.enddate, plusdcrewlabor.laborcode,
    plusdcrewlabor.craft, plusdcrewlabor.skilllevel,
    plusdcrewlabor.vendor, plusdcrewlabor.contractnum,
    plusdcrewlabor.calnum, plusdcrewlabor.shiftnum  from
    plusdcrewlabor
    ;
    
    // Inserted no records.
    
    java.lang.NullPointerException
            at
    psdi.script.industrysolution.AutoUpgradeTemplateIS.linkTargetToS
    ourceMetadata(AutoUpgradeTemplateIS.java:6347)
            at
    psdi.tnd.en.V7501_05.migratePlusDCrewLabPos(V7501_05.java:202)
            at psdi.tnd.en.V7501_05.process(V7501_05.java:106)
            at psdi.script.AutoUpgradeTemplate.<init>(Unknown
    Source)
            at
    psdi.script.industrysolution.AutoUpgradeTemplateIS.<init>(AutoUp
    gradeTemplateIS.java:117)
            at psdi.tnd.en.V7501_05.<init>(V7501_05.java:59)
            at
    sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native
    Method)
            at
    sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeCons
    tructorAccessorImpl.java:56)
            at
    sun.reflect.DelegatingConstructorAccessorImpl.newInstance(Delega
    tingConstructorAccessorImpl.java:39)
            at
    java.lang.reflect.Constructor.newInstance(Constructor.java:527)
            at psdi.tools.UpdateDB.runScriptClass(Unknown Source)
            at psdi.tools.UpdateDB.runScripts(Unknown Source)
            at psdi.tools.UpdateDB.startProcess(Unknown Source)
            at psdi.tools.UpdateDB.startProcess(Unknown Source)
            at psdi.tools.UpdateDB.loadScriptInfo(Unknown Source)
            at psdi.tools.UpdateDB.main(Unknown Source)
    
    -- BEGINUPDATEDBERROR
    -- Product: IBM Maximo for Utilities
    -- Error running file: V7501_05
    -- UPDATEDBFILE:V7501_05.class
    -- Script: Error
    rollback
    ;
    
    java.lang.Exception
            at psdi.tools.UpdateDB.runScriptClass(Unknown Source)
            at psdi.tools.UpdateDB.runScripts(Unknown Source)
            at psdi.tools.UpdateDB.startProcess(Unknown Source)
            at psdi.tools.UpdateDB.startProcess(Unknown Source)
            at psdi.tools.UpdateDB.loadScriptInfo(Unknown Source)
            at psdi.tools.UpdateDB.main(Unknown Source)
    
    java.lang.Exception: DATABASE Script UPDATE COMPLETED WITH
    ERROR. CHECK ERRORS IN UPDATE LOG FILE
    -Updatedb20130516035636.log
    null
            at psdi.tools.UpdateDB.startProcess(Unknown Source)
            at psdi.tools.UpdateDB.startProcess(Unknown Source)
            at psdi.tools.UpdateDB.loadScriptInfo(Unknown Source)
            at psdi.tools.UpdateDB.main(Unknown Source)
    

Local fix

  • No workaround has been found.
    

Problem summary

  • ****************************************************************
    * USERS AFFECTED:                                              *
    * All users that install Utilitites 7.5.0.1 in Maximo 7.5.0.5  *
    * or has Utilitites 7.5.0.1 in Maximo 7.5.0.4 less and want to *
    * upgrade Maximo to 7.5.0.5+                                   *
    ****************************************************************
    * PROBLEM DESCRIPTION:                                         *
    * UTILITIES 7501 DOES NOT WORK UNDER TPAE7505                  *
    ****************************************************************
    * RECOMMENDATION:                                              *
    * Check Technotes                                              *
    ****************************************************************
    

Problem conclusion

  • There were two error, one for new users and other to users that
    want to upgrade Maximo base. All erros was fixed.
    

Temporary fix

Comments

APAR Information

  • APAR number

    IV51057

  • Reported component name

    MAXIMO UTILITIE

  • Reported component ID

    5724R5600

  • Reported release

    750

  • Status

    CLOSED PER

  • PE

    NoPE

  • HIPER

    NoHIPER

  • Special Attention

    NoSpecatt

  • Submitted date

    2013-10-18

  • Closed date

    2014-01-09

  • Last modified date

    2014-01-09

  • APAR is sysrouted FROM one or more of the following:

  • APAR is sysrouted TO one or more of the following:

Modules/Macros

  • UNKNOWN
    

Fix information

  • Fixed component name

    MAXIMO UTILITIE

  • Fixed component ID

    5724R5600

Applicable component levels

  • R750 PSY

       UP



Document information

More support for: Maximo for Utilities
Utilities Installation

Software version: 750

Reference #: IV51057

Modified date: 09 January 2014