IV42075: EVDO RNCPM REMEDIATION MAY FAIL IF FILES ARE LARGE

Subscribe

You can track all active APARs for this component.

APAR status

  • Closed as program error.

Error description

  • Product: Prospect
    Component Id: 5724T0500
    Release: 807
    Severity: 3
    
    
    PROBLEM:
    
    In the script callPreparse.sh, the call to
    remediation_1xEVDO.pl, may hit a Perl bug when the files are
    large and it may fail with below errors:
     Out of memory!
     Attempt to free unreferenced scalar at remediation_1xEVDO.pl
    line 183, <CDF> line 7226542.
     panic: POPSTACK
     panic: POPSTACK
     ....
     ....
     panic: POPSTACK
     /u01/apps/WatchMark/FlexPM/NortelMTX/vendor/Nortel/MSC/1.3/1xEV
    DO/scripts/callPreparse.sh[227]: 26474 Segmentation Fault
    

Local fix

  • This issue happnes with the currently supported version of Perl
    which is 5.6. The workaround here is to use Perl 5.8.4 for the
    call to the remediation script inside callPreparse.sh. Please
    note that the workaround is to change only the call to the
    remediation script inside callPreparse.sh.
    

Problem summary

  • PROBLEM DESCRIPTION:
    
    EVDO RNCPM REMEDIATION MAY FAIL IF FILES ARE LARGE.
    
    PROBLEM SUMMARY:
    
    In the script callPreparse.sh, the call to
    remediation_1xEVDO.pl, may hit a Perl bug when the files are
    large and it may fail with below errors:
     Out of memory!
     Attempt to free unreferenced scalar at remediation_1xEVDO.pl
    line 183, <CDF> line 7226542.
     panic: POPSTACK
     panic: POPSTACK
     ....
     ....
     panic: POPSTACK
     /u01/apps/WatchMark/FlexPM/NortelMTX/vendor/Nortel/MSC/1.3/1xEV
    DO/scripts/callPreparse.sh[227]: 26474 Segmentation Fault
    RESOLUTION:
    
    Support Perl 5.8.4 in latest Prospect version.
    

Problem conclusion

  • This is projected to be fixed in Prospect 8.0.7 Interim Fix 10
    (8.0.7.10)
    Note that this is subject to change at the discretion of IBM.
    

Temporary fix

  • This issue happens with the currently supported version of Perl
    which is 5.6. The workaround here is to use Perl 5.8.4 for the
    call to the remediation script inside callPreparse.sh. Please
    note that the workaround is to change only the call to the
    remediation script inside callPreparse.sh
    

Comments

APAR Information

  • APAR number

    IV42075

  • Reported component name

    PROSPECT

  • Reported component ID

    5724T0500

  • Reported release

    807

  • Status

    CLOSED PER

  • PE

    NoPE

  • HIPER

    NoHIPER

  • Special Attention

    NoSpecatt

  • Submitted date

    2013-05-08

  • Closed date

    2013-10-29

  • Last modified date

    2013-10-29

  • APAR is sysrouted FROM one or more of the following:

  • APAR is sysrouted TO one or more of the following:

Fix information

  • Fixed component name

    PROSPECT

  • Fixed component ID

    5724T0500

Applicable component levels

  • R807 PSY

       UP



Rate this page:

(0 users)Average rating

Add comments

Document information


More support for:

Prospect

Software version:

807

Reference #:

IV42075

Modified date:

2013-10-29

Translate my page

Machine Translation

Content navigation