IBM Support

IV36499: LAUNCHPAD.SH FAILS WITH FIREFOX VERSIONS > 9.X

Subscribe

You can track all active APARs for this component.

APAR status

  • Closed as program error.

Error description

  • When running launchpad.sh that is delivered with 7.3.0.1, there
    is an error with current versions of Firefox.
    
    ./launchpad.sh
    cp: cannot stat `/root/ITCAM/install/launchpad/lib': No such
    file or
    directory
    cp: cannot stat `/root/ITCAM/install/launchpad/../jre': No such
    file or
    directory
    ++ cat /root/ITCAM/install/launchpad/en/noBrowser.html
    
    Unable to find supported browser
    
    In browser.sh, change:
    supportedFirefoxVersion()
    {
            case "$*" in
                    *Firefox\ [1-9].*) return 0;;
                    *Firefox/[1-9].*) return 0;;
                    *Firefox*) return 1;;
                    *rv:1.[7-9]*) return 0;;
                    *rv:[2-9].*) return 0;;
                    *rv:*) return 1;;
                    Mozilla*\ 1.[7-9]*) return 0;;
                    Mozilla*\ [2-9].[0-9]*) return 0;;
                    *) return 1;;
            esac
    }
    
    to
    
    supportedFirefoxVersion()
    {
     case "$*" in
      *Firefox\ [1-9].*) return 0;;
      *Firefox/[1-9].*) return 0;;
      *Firefox\ [1-9][0-9].*) return 0;;
      *Firefox/[1-9][0-9].*) return 0;;
      *Firefox*) return 1;;
      *rv:1.[7-9]*) return 0;;
      *rv:[2-9].*) return 0;;
      *rv:*) return 1;;
      Mozilla*\ 1.[7-9]*) return 0;;
      Mozilla*\ [2-9].[0-9]*) return 0;;
      *) return 1;;
     esac
    }
    
    supportedMozillaVersion might also need updating.
    

Local fix

  • In browser.sh, change:
    supportedFirefoxVersion()
    {
            case "$*" in
                    *Firefox\ [1-9].*) return 0;;
                    *Firefox/[1-9].*) return 0;;
                    *Firefox*) return 1;;
                    *rv:1.[7-9]*) return 0;;
                    *rv:[2-9].*) return 0;;
                    *rv:*) return 1;;
                    Mozilla*\ 1.[7-9]*) return 0;;
                    Mozilla*\ [2-9].[0-9]*) return 0;;
                    *) return 1;;
            esac
    }
    
    to
    
    supportedFirefoxVersion()
    {
     case "$*" in
      *Firefox\ [1-9].*) return 0;;
      *Firefox/[1-9].*) return 0;;
      *Firefox\ [1-9][0-9].*) return 0;;
      *Firefox/[1-9][0-9].*) return 0;;
      *Firefox*) return 1;;
      *rv:1.[7-9]*) return 0;;
      *rv:[2-9].*) return 0;;
      *rv:*) return 1;;
      Mozilla*\ 1.[7-9]*) return 0;;
      Mozilla*\ [2-9].[0-9]*) return 0;;
      *) return 1;;
     esac
    }
    

Problem summary

  • ****************************************************************
    * USERS AFFECTED:  Customers using UNIX/LINUX with a version of
    * Firefox > 9.X
    ****************************************************************
    * PROBLEM DESCRIPTION: The launchpad installer does not support
    * Firefox over version 9.X.
    ****************************************************************
    * RECOMMENDATION: Apply 7.3 FP2
    ****************************************************************
    

Problem conclusion

  • The launchpad installer now supports validation for Firefox over
     version 9.X.
    
    The fix for this APAR is contained in the following maintenance
    packages:
        | fix pack | 7.3.0.0-TIV-CAMRT-FP0002
    

Temporary fix

Comments

APAR Information

  • APAR number

    IV36499

  • Reported component name

    ITCAM TRANSACT

  • Reported component ID

    5724S7900

  • Reported release

    730

  • Status

    CLOSED PER

  • PE

    NoPE

  • HIPER

    NoHIPER

  • Special Attention

    NoSpecatt / Xsystem

  • Submitted date

    2013-02-08

  • Closed date

    2013-07-11

  • Last modified date

    2013-07-11

  • APAR is sysrouted FROM one or more of the following:

  • APAR is sysrouted TO one or more of the following:

Fix information

  • Fixed component name

    ITCAM TRANSACT

  • Fixed component ID

    5724S7900

Applicable component levels

  • R730 PSY

       UP



Document information

More support for: Tivoli Composite Application Manager for Transactions
5724S7900 ITCAM for Transactions Routing ID

Software version: 7.3

Reference #: IV36499

Modified date: 2013-07-11