IV36151: JAVA 1.4.2 IS NO LONGER A SUPPORTED JAVA VERSION FOR TSA MP 3.2.2.X AND ABOVE

Subscribe

You can track all active APARs for this component.

APAR status

  • Closed as documentation error.

Error description

  • Tivoli System Automation for Multiplatform installs own java
    runtime and make use of it.
    On AIX Java must be installed separately.
    The documentation states that Java 1.4.2 is a supported Java
    version for TSAMP 3.2.2.x.
    
    Because version 3.2.2 uses Java 5 and no longer Java 1.4.2
    classes the Java version 1.4.2 is no longer
    supported.
    The documentation must be updated to reflect this requirement.
    
    If e.g. sampolicy command is executed with installed Java
    1.4.2 it might fail with message:
    
       The java class could not be loaded.
          java.lang.UnsupportedClassVersionError:
          com/ibm/sam/policy/XMLPolicyLoadController
          (Unsupported major.minor version 49.0)
    

Local fix

  • install Java 5 SR5 and newer
    

Problem summary

  • ****************************************************************
    * USERS AFFECTED: Tivoli System Automation for Multiplatforms
    * (SA MP) 3.2.2 users on AIX using sampolicy or the end-to-end
    * automation adapter
    ****************************************************************
    * PROBLEM DESCRIPTION:
    * The SA MP Installation and Configuration guide describes the
    * required Java level for the operating system AIX. It states
    * that Java 1.4.2 is required. Starting with SA MP 3.2.2 the
    * required Java level has changed to Java 5 SR5 or higher, but
    * the documentation has not been updated to reflect this new
    * requirement.
    * The same is true for the Release Notes of SA MP 3.2.2 .
    * The issue is only with AIX, where the Java of the operating
    * system is used, while on all other supported platforms the
    * required Java is installed with the SA MP product.
    ****************************************************************
    * RECOMMENDATION:
    ****************************************************************
    

Problem conclusion

  • The Tivoli System Automation for Multiplatforms Installation and
    Configuration guide will be updated as follows to address this
    issue:
    
    Chapter 1. Installing on UNIX and Linux
      Planning for the installation
        Preparing for installation
          Prerequisites
    
     The 4th bullet of the bullet list will be changed from:
    
       On AIX, the 32-bit version of Java 1.4.2 or Java 5 SR5 (or
       higher) is required.
    
     to:
    
       On AIX, the 32-bit version of Java 5 SR5 (or higher) is
       required.
    
    The Release Notes will be adjusted as well.
    Furthermore the check tool 'prereqSAM' will be adjusted to check
    for the new required minimum Java level on AIX. This check will
    be available with SA MP 3.2.2 fix pack 4.
    .
    Additional Search Keywords
    .
    

Temporary fix

Comments

APAR Information

  • APAR number

    IV36151

  • Reported component name

    SA MULTIPLATFOR

  • Reported component ID

    5724M0000

  • Reported release

    322

  • Status

    CLOSED DOC

  • PE

    NoPE

  • HIPER

    NoHIPER

  • Special Attention

    NoSpecatt

  • Submitted date

    2013-02-01

  • Closed date

    2013-02-08

  • Last modified date

    2013-02-08

  • APAR is sysrouted FROM one or more of the following:

  • APAR is sysrouted TO one or more of the following:

Fix information

Applicable component levels



Rate this page:

(0 users)Average rating

Add comments

Document information


More support for:

Tivoli System Automation for Multiplatforms

Software version:

322

Reference #:

IV36151

Modified date:

2013-02-08

Translate my page

Machine Translation

Content navigation