IBM Support

IT20298: MQ INSTALLATION ON AIX FAILS WITH MISSING REQUISITES

Subscribe

You can track all active APARs for this component.

APAR status

  • Closed as documentation error.

Error description

  • Installation MQ 8.0 or higher MQ versions fails with "MISSING
    REQUISITES" errors for
     mqm.xr.clients and/or mqm.txclient.rte.
    
    Error message example:
    
     MISSING REQUISITES:  The following filesets are required by one
    or
    more
      of the selected filesets listed above.  They are not currently
    installed
      and could not be found on the installation media.
    
        mqm.xr.clients 9.0.0.0                    # Base Level
    Fileset
    

Local fix

  • Uninstall  mqm.xr.clients and/or mqm.txclient.rte from older MQ
    version before migrating to MQ 8.0 or higher MQ version.
    

Problem summary

  • ****************************************************************
    USERS AFFECTED:
    Users migrating MQ from MQ 7.5 and lower version to MQ 8.0 and
    higher MQ versions on AIX.
    
    
    Platforms affected:
    AIX
    
    ****************************************************************
    PROBLEM DESCRIPTION:
    This error occurred because mqm.xr.clients and mqm.txclient.rte
    file sets were shipped as separate file sets in MQ 7.5 and older
    MQ versions. There is a prerequisite test during the install to
    make sure that there is not a mixture of filesets from different
    releases. If mqm.xr.clients and mqm.txclient.rte or any other
    file set is installed that is not in 8.0 and higher MQ versions
    they must be uninstalled first. This is not documented in the
    InfoCenter for 8.0/9.0.
    

Problem conclusion

Temporary fix

Comments

APAR Information

  • APAR number

    IT20298

  • Reported component name

    WMQ BASE MULTIP

  • Reported component ID

    5724H7251

  • Reported release

    800

  • Status

    CLOSED DOC

  • PE

    NoPE

  • HIPER

    NoHIPER

  • Special Attention

    NoSpecatt / Xsystem

  • Submitted date

    2017-04-20

  • Closed date

    2017-05-15

  • Last modified date

    2017-05-15

  • APAR is sysrouted FROM one or more of the following:

  • APAR is sysrouted TO one or more of the following:

Fix information

Applicable component levels



Document information

More support for: WebSphere MQ

Software version: 8.0.0.0

Reference #: IT20298

Modified date: 15 May 2017


Translate this page: