IBM Support

IT02314: CVE-2014-0224 - VULNERABILITY IN SSL CHANGECIPHERSPEC PROCESSING

Subscribe

You can track all active APARs for this component.

APAR status

  • Closed as program error.

Error description

  • A security vulnerability in ChangeCipherSpec processing allows
    intermediate nodes to intercept encrypted data and decrypt them
    and can force the use of weak keying material in SSL/TLS clients
    and servers.
    

Local fix

Problem summary

  • An attacker using a carefully crafted handshake can force the
    use of weak keying material in SSL/TLS clients and servers. This
     can be exploited by a Man-in-the-middle (MITM) attack where the
     attacker can decrypt and modify traffic from the attacked
    client and server. The attack can only be performed between a
    vulnerable client *and* server.
    

Problem conclusion

Temporary fix

Comments

APAR Information

  • APAR number

    IT02314

  • Reported component name

    DATAPOWER

  • Reported component ID

    DP1234567

  • Reported release

    401

  • Status

    CLOSED PER

  • PE

    NoPE

  • HIPER

    NoHIPER

  • Special Attention

    NoSpecatt

  • Submitted date

    2014-06-09

  • Closed date

    2014-06-17

  • Last modified date

    2014-06-17

  • APAR is sysrouted FROM one or more of the following:

  • APAR is sysrouted TO one or more of the following:

Fix information

  • Fixed component name

    DATAPOWER

  • Fixed component ID

    DP1234567

Applicable component levels

  • R500 PSY

       UP

  • R600 PSY

       UP

  • R601 PSY

       UP

  • R700 PSY

       UP



Document information

More support for: IBM DataPower Gateways
General

Software version: 4.0.1

Reference #: IT02314

Modified date: 17 June 2014


Translate this page: