IBM Support

IC70095: THE 6.2.1.1 TSM LINUX X86 CLIENT PACKAGE MAY NOT INSTALL DUE TO DEPENDENCIES ON GSKCRYPT AND GSKSSL

Subscribe

You can track all active APARs for this component.

APAR status

  • Closed as program error.

Error description

  • An install of the RPMs included in
    6.2.1.1-TIV-TSMBAC-LinuxX86.tar may fail with the
    following errors:
    # rpm -ivh TIVsm-API.i386.rpm TIVsm-API64.i386.rpm
    TIVsm-BA.i386.rpm
    error: Failed dependencies:
      gskcrypt32 >= 8.0-13.3 is needed by TIVsm-API-6.2.1-1.i586
      gskssl32 >= 8.0-13.3 is needed by TIVsm-API-6.2.1-1.i586
      libgsk8cms.so is needed by TIVsm-API-6.2.1-1.i586
      libgsk8iccs.so is needed by TIVsm-API-6.2.1-1.i586
      libgsk8iccs.so(ICCSTUB) is needed by TIVsm-API-6.2.1-1.i586
      libgsk8ssl.so is needed by TIVsm-API-6.2.1-1.i586
      libgsk8ssl.so(GSKSSL) is needed by TIVsm-API-6.2.1-1.i586
      libgsk8sys.so is needed by TIVsm-API-6.2.1-1.i586
      gskcrypt64 >= 8.0-13.3 is needed by TIVsm-API64-6.2.1-1.i586
      gskssl64 >= 8.0-13.3 is needed by TIVsm-API64-6.2.1-1.i586
      libgsk8cms_64.so()(64bit) is needed by
          TIVsm-API64-6.2.1-1.i586
      libgsk8iccs_64.so()(64bit) is needed by
          TIVsm-API64-6.2.1-1.i586
      libgsk8iccs_64.so(ICCSTUB)(64bit) is needed by
          TIVsm-API64-6.2.1-1.i586
      libgsk8ssl_64.so()(64bit) is needed by
          TIVsm-API64-6.2.1-1.i586
      libgsk8ssl_64.so(GSKSSL)(64bit) is needed by
          TIVsm-API64-6.2.1-1.i586
      libgsk8sys_64.so()(64bit) is needed by
          TIVsm-API64-6.2.1-1.i586
    The libraries mentioned in the "Failed dependencies" are
    provided by the following RPMs:
      gskcrypt32-8.0.13.3.linux.x86.rpm
      gskcrypt64-8.0.13.3.linux.x86_64.rpm
      gskssl32-8.0.13.3.linux.x86.rpm
      gskssl64-8.0.13.3.linux.x86_64.rpm
    but these RPMs were not included in the 6.2.1.1 Linux x86
    client interim fix package.
    Tivoli Storage Manager Versions Affected:
      6.2.1.1 Tivoli Storage Manager client for Linux
    Initial Impact: High
    

Local fix

  • The required RPMs are included in the 6.2.1.0 Tivoli Storage
    Manager client download for Linux.  The gskcrypt and gskssl
    RPMs from 6.2.1.0 will satisfy the dependencies for the
    6.2.1.1 client RPMs.
    

Problem summary

  • ****************************************************************
    * USERS AFFECTED: Version 6.2.1.1 backup-archive client on     *
    *                 Linux x86 downloaded prior to 23 July 2010   *
    ****************************************************************
    * PROBLEM DESCRIPTION: See ERROR DESCRIPTION                   *
    ****************************************************************
    * RECOMMENDATION: Apply fixing level when available. This      *
    *                 problem is currently projected to be fixed   *
    *                 in level 6.2.2. Note that until the fixing   *
    *                 package is actually available, this          *
    *                 information is subject to change at the      *
    *                 discretion of IBM.                           *
    ****************************************************************
    *
    

Problem conclusion

  • The original 6.2.1.1 package was replaced with a new package
    containing the missing libraries.
    

Temporary fix

Comments

APAR Information

  • APAR number

    IC70095

  • Reported component name

    TSM CLIENT

  • Reported component ID

    5698ISMCL

  • Reported release

    62L

  • Status

    CLOSED PER

  • PE

    NoPE

  • HIPER

    NoHIPER

  • Special Attention

    NoSpecatt

  • Submitted date

    2010-07-21

  • Closed date

    2010-07-30

  • Last modified date

    2010-08-02

  • APAR is sysrouted FROM one or more of the following:

  • APAR is sysrouted TO one or more of the following:

Fix information

  • Fixed component name

    TSM CLIENT

  • Fixed component ID

    5698ISMCL

Applicable component levels

  • R62L PSY

       UP



Document information

More support for: Tivoli Storage Manager

Software version: 62L

Reference #: IC70095

Modified date: 02 August 2010