IBM Support

Microsoft Office 2007/2010 on Windows Vista, Windows Server 2008 and Windows 7 Clients Fail to Save Files

Troubleshooting


Problem

An issue has been identified where Microsoft Office 2007/2010 on Windows Vista, Windows Server 2008 and Windows 7 clients fail to save files to IBM Storwize V7000 Unified shares.

Symptom

When saving files in Microsoft Office, the following error message is displayed: "There has been a network or file permission error. The network connection may be lost (Z:\<filename>.docs)".

Cause

This issue happens when an application opens a file and tries to rename it while still holding the file open. Microsoft Office does this when saving a document by first creating a temporary file and then renaming it to the final name. The file rename operation fails, preventing the document from being saved.

Other applications that save files using similar methods may also experience this problem when accessing files using the SMB2 protocol.

Environment

This problem affects access to Storwize V7000 Unified file shares from clients using Server Message Block protocol version 2 (SMB2), including Microsoft Windows Vista, Windows Server 2008 and Windows 7 operating systems.

Microsoft Windows XP and other CIFS/SMB clients are not affected.
Affected Releases: IBM Storwize V7000 Unified Version 1.3.0.X and 1.3.1.0

Resolving The Problem


The following 2 workarounds are available:

A) Apply special settings:
If you need assistance in applying a workaround, please call IBM support.

For 1.3.0.0 - 1.3.0.2 :
Disable SMB2 access to the Storwize V7000 Unified File Modules:

  1. Using SSH, connect to the active management node as the 'root' user.
  2. Run the following command to disable SMB2:
    chservice --cifs 'max protocol = NT1'
  3. Reboot affected clients to trigger them to recognize that the Storwize V7000 Unified system does not support SMB2. Clients should then auto negotiate to use the CIFS/SMB protocol instead.
For 1.3.0.3 and 1.3.0.5:
Disable sharemode propagation for SMB2 access to the Storwize V7000 Unified File Modules:
  1. Connect to the Storwize V7000 Unified system as 'admin' user.
  2. Run the following command to disable sharemode propagation for each export that host MS Office documents:
    chexport <exportname> --cifs "sharemodes=no"
  3. Reconnect network drives on affected clients.
For 1.3.1.0:
Enable GPFS setting for file rename using SMB2 access to the Storwize V7000 Unified File Modules:
  1. Using SSH, connect to the active management node as the 'root' user.
  2. Run the following command to set the cifsBypassShareLocksOnRename flag:
    [root@1300003.mgmt001st001 ~]# mmchconfig cifsBypassShareLocksOnRename=yes -i
    mmchconfig: Command successfully completed
    mmchconfig: Propagating the cluster configuration data to all affected nodes. This is an asynchronous process.
  3. Verify the settings.
    [root@1300003.mgmt001st001 ~]# mmfsadm dump config |grep -i cifs
    cifsBypassShareLocksOnRename 1 <------- check that this is now set to 1
    cifsBypassTraversalChecking 0

No reconnect of network drives or reboot of clients is required.


Note: Support for SMB2 will automatically be re-enabled when an upgrade has been applied.
Please check and reapply any workarounds that may be needed on the upgraded release, especially if a workaround had been applied prior to an upgrade.


OR


B) Edit and save files locally on client and then copy those files to the network share.


NOTE: This issue has been fixed in the IBM Storwize V7000 Unified V1.3.1.1 release.

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Document Information

Modified date:
17 June 2018

UID

ssg1S1004008