Troubleshooting
Problem
QNTC problems with NetApp with SMB2
Symptom
A QNTC connection to a NetApp server does not show any directories and does not log any errors.
Cause
When QNTC requests a listing of the available shares, NetApp does not return any shares. The result is a working connection to a file server that appears to have no visible shares.
Resolving The Problem
Until a fix can be obtained from NetApp to correct the defective behavior on the file server, the problem can be circumvented by forcing QNTC to use SMB1. The version of SMB used by QNTC is controlled through an environment variable, QIBM_ZLC_SMB_VERS. If the variable is not set or set to a value of 0, then QNTC uses SMB2 with an SMB1 negotiation, that is, it sends an SMB1 negotiation requesting SMB2 support. If set to a value of 1 it uses SMB1 only and if set to a value of 2, it uses SMB2 only.
ADDENVVAR ENVVAR(QIBM_ZLC_SMB_VERS) VALUE(1) LEVEL(*SYS)
After you set the environment variable, start a new job and connect to the NetApp server from that job.
To circumvent the problem with NetApp file servers, run the command:
ADDENVVAR ENVVAR(QIBM_ZLC_SMB_VERS) VALUE(1) LEVEL(*SYS)
After you set the environment variable, start a new job and connect to the NetApp server from that job.
Related Information
[{"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Product":{"code":"SWG60","label":"IBM i"},"Component":"Integrated File System","Platform":[{"code":"PF012","label":"IBM i"}],"Version":"7.3;7.2;7.4","Edition":"","Line of Business":{"code":"LOB57","label":"Power"}}]
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Document Information
Modified date:
29 June 2021
UID
nas8N1022549