IBM Support

Removal of Support for IBM JDK 6.0/6.2.6 with IAS v8.5 and v2.6 servers in IBM i 7.1 SF99368 level 52 and IBM i 7.2 SF99713 level 26

Flash (Alert)


Abstract

Beginning with IBM i 7.1 SF99368 level 52 and IBM i 7.2 SF99713 level 26, the underlying WebSphere Liberty runtime will be updated to v17.0.0.3 for the IBM Integrated Application Server (IAS) v8.5 and Integrated Web Services (IWS) v2.6 servers, which will no longer support IBM JDK 6.0/6.2.6. If your IAS v8.5 or IWS v2.6 server is currently configured to use JDK 6.0/6.2.6, you will need to modify its configuration to use JDK 7.0 or newer.

Content

The IBM i 7.1 (SF99368 level 52) and IBM i 7.2 (SF99713 level 26) HTTP Group PTF levels will install the WebSphere Liberty v17.0.0.3 runtime, which will no longer support JDK 6.0/6.2.6.
This will cause all IAS v8.5 and IWS v2.6 servers configured to use JDK v6.0/v6.2.6 not to start properly after the Group PTF is applied!!!!

IBM recommends upgrading all IWS/IAS servers to JDK 8.0 64 bit if possible. The upgrade of the JDK version is recommended before applying the PTF Group, but can also be done in the ADMIN GUI after the HTTP Group PTF is applied. This should have no impact on deployed Web Services to IWS servers, but might affect deployed WAR applications deployed to IAS v8.5 servers. Clients should test their IAS v8.5 web applications on IBM JDK v7.0 or later first to ensure everything works properly.

Clients can determine their IAS or IWS server version in the IBM Web Administration for i console (http://[server]:2001/HTTPAdmin or https://[server]:2010/HTTPAdmin) under Manage -> Application Servers -> Select your server from the "Server" drop-down list. Next to your server name, you will see "V8.5 (int app svr) for an IAS v8.5 server or "V2.6 (web services)" for an IWS v2.6 server. IAS v8.1/v7.1 and IWS v1.3/v1.5 server versions are no longer supported by development and should be migrated to the latest IAS v8.5 or IWS v2.6 versions. Refer to the following IBM Technical Document to assist with IWS server migrations.

How To Migrate Your IBM Integrated Web Services (IWS) Server From v1.3/v1.5 to v2.6

Clients can refer to the following IBM Technical Document for detailed information on how to change the IBM JDK version used by their IWS v2.6 or IAS v8.5 servers.

How To Change The IBM Java Development Kit (JDK) Version Used By an IBM Integrated Web Services (IWS) v2.6 Server or Integrated Application Server (IAS) v8.5 Server


Cross reference information
Segment Product Component Platform Version Edition
Operating System IBM i 7.2
Operating System IBM i 7.1

Document information

More support for: IBM i
Web technologies

Software version: 7.1, 7.2

Operating system(s): IBM i

Reference #: N1022408

Modified date: 28 December 2017


Translate this page: