Troubleshooting
Problem
MSGSOCK007 Could Not Connect. Connection Refused
Symptom
Cannot connect to IBM Navigator for i through IBM i Access Client Solutions or you cannot connect to a 5250 SSL connection using IBM i Access Client Solutions.
Cause
Either a service is not started or ports are not open through the firewall.
Diagnosing The Problem
Users can receive this message when trying to connect to IBM Navigator for i or when using SSL to connect to a 5250 session using IBM i Access Client Solutions.
Resolving The Problem
For issues with IBM Navigator for i:
1- Make sure you are using i Access Client Solutions 1.1.6.2 or later
2- Make sure you have the HTTP Group PTF installed at the following level or later.
r7.1: SF99368 Level 45
r7.2: SF99713 Level 19
r7.3: SF99722 Level 6
Note: When installing HTTP Group PTFs it it recommended to install the current Java Group PTF at the same time.
3- Make sure the HTTP server Admin2 is started and ports 2004 and/or 2005 are listening.
For issues with SSL:
1- Make sure you have certificates assigned to the telnet server and ALL host servers
(Especially, Central Server, Signon Server, Telnet, Remote Command)
2- Make sure the ports for the servers are open
(992, 449, 9470-9476. Minimum ports are 992, 449, 9470, 9475 and 9476)
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Document Information
Modified date:
18 December 2019
UID
nas8N1021940