IBM Support

Circumvention for High CPU queuing with low CPU utilization on POWER7 and POWER8

Troubleshooting


Problem

A performance issue has been found that causes delays in the dispatching of shared processors partition. This affects shared processor partitions that are marked as capped or uncapped partitions that are in a defined shared processor pool. The circumvention to the problem is to create a new AIX or Linux partition and boot the partition to the SMS prompt. There is no need to install an operating system image for this partition. The following are step-by-step instructions to create this partition, once these steps are completed this should provide immediate relief to the performance problem. This defect is fixed in the following releases. F770.61 - GA F780.40 - GA F783.20 - GA F810.33 - GA F820.21 - GA F830.10 - GA

Symptom

High CPU queuing with low CPU utilization

Cause

Defect in hypervisor firmware

Environment

POWER7 and POWER8

Diagnosing The Problem

Contact iGSC performance team for verification

Resolving The Problem

Select the option to create an AIX or Linux partition from the HMC.

Specify a name for the partition, we used “circumvention”

Specify a name for the partition profile, we used “circumvention”

Indicate the partition is using shared processors

Indicate that the partition should be assigned 0.05 processor units, 1 virtual processor and specify the partition is uncapped.

Specify the partition as a dedicated memory partition with 256 MB of assigned memory.

Do NOT assign any I/O to the partition

Do not add any virtual adapters

Do not select any optional settings. Indicate to boot the partition to the system management services prompt.

Activate the new partition using the profile option

Boot the partition

Leave the partition in the activated state to circumvent the shared processor dispatching issue. If you need to reboot this entire system, remember to reactivate this partition to circumvent the problem. After loading the firmware service pack with the fix for this issue, you can power off and delete the partition.

[{"Product":{"code":"SGYVHK","label":"FSP\/Firmware"},"Business Unit":{"code":"BU054","label":"Systems w\/TPS"},"Component":"Not Applicable","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"none","Edition":"","Line of Business":{"code":"","label":""}}]

Document Information

Modified date:
17 June 2018

UID

nas8N1020863