IBM Support

Official Support Statement for the IBM WebSphere Application Server Product on the IBM i OS

Technote (FAQ)


Question

What IBM WebSphere Application Server versions, editions, and fix levels are supported on the IBM i OS releases?

Answer

The IBM WebSphere Application Server (WAS) product is supported on the IBM i OS based on the following criteria.

1) The IBM WebSphere Application Server product is only supported on supported versions of the IBM i OS. Please refer to the following table and URL regarding the current supported versions of the IBM i OS.

IBM i Release Support
http://www.ibm.com/support/docview.wss?uid=nas8N1022035



Note 1: End of program support date will be announced with at least 12 months notice prior to the effective termination date.

Note 2: For V5R4 (5.4.x), includes both Machine Code Level V5R4M0 and V5R4M5. For 6.1, includes both Machine Code Level V6R1M0 and V6R1M1.

Note 3: IBM Service Extension Offering for IBM i 6.1 and 7.1 is available for customers.

2) Only currently supported versions of IBM WebSphere Application Server are FULLY supported. FULLY supported = best-effort AND development/defect support

End of Support for WebSphere V7.0, V8.0 after April 30th, 2018 & JDK 6.0 after December 31st, 2017

End of Support Dates:
***WebSphere Application Server V7.0 – April 30, 2018 - No longer fully supported***
***WebSphere Application Server V8.0 – April 30, 2018 - No longer fully supported ***
Java 6 in traditional WAS V8.5 – December 31, 2017
Java 7 in traditional WAS V8.5 – September 30, 2019
Java 6 in Liberty - September 30, 2017
Java 7 in Liberty - September 30, 2019
For complete details please reference the announcements for
Distributed and z/OS environments.

Last September, IBM announced that the End of Service date for WebSphere Application Server V7.0 and WebSphere Application Server V8.0 is April 30th, 2018. WAS V8.5 and V9.0 are available today at no additional charge to WAS clients with active subscription and support.

For WAS V8.5 users, support of Java 6 with traditional WAS will end December 31st, 2017 and support for Java 6 with Liberty will end September 30th, 2017.  Support for Java 7 with both traditional WAS and Liberty will be discontinued after September 30th, 2019.  WAS V8.5 provides the option to use Java 6, Java 7 or Java 8. Customers using WAS V8.5 are recommended to move up to Java 8. Refer to these URLs for further information(
http://www.ibm.com/support/docview.wss?uid=nas8N1020692 & http://www.ibm.com/support/docview.wss?uid=nas8N1019730)

Please refer to the following IBM WAS Lifecycle document to check and see if your WAS version and release is currently supported.
http://www-01.ibm.com/software/support/lifecycleapp/PLCDetail.wss?from=spf&synkey=C578916B44100K52

FULLY supported IBM WAS versions on the IBM i as of 5/1/18:
WAS v9.0.x & v8.5.x

NOTE: WAS v8.0.x and v7.0.x versions are no longer be fully supported after April 30th, 2018!!!!
3) IBM WAS v8.0.x, v7.0.x, and v6.1.x Express edition is still supported on a best-effort basis on IBM i 6.1.x (with valid service extension), 7.1 (with valid service extension) and IBM i 7.2.

NOTE: IBM reserves the right to require clients to download and install the latest IBM i Group PTFs and WAS Fix Pack level for out of support IBM i OS VRMs and WAS versions.

Best-effort support is still provided even though the WAS version and release is not fully supported since the IBM WAS Express edition is part of the 5722-WE2 IBM Web Enablement product, which is covered under the IBM SWMA. Please refer to the following URLs for more information.

https://www-03.ibm.com/systems/power/software/i/websphere/v855/index.html
http://www-03.ibm.com/systems/power/software/i/subscription/list.html
4) IBM WAS v6.0.x Express edition is still supported on a best-effort basis on IBM i 6.1.x (with valid service extension).

NOTE: IBM reserves the right to require clients to download and install the latest IBM i Group PTFs and WAS Fix Pack level for out of support IBM i OS VRMs and WAS versions.

Best-effort support is still provided even though the WAS version and release is not fully supported since the IBM WAS Express edition is part of the 5722-WE2 IBM Web Enablement product, which is covered under the IBM SWMA. Please refer to the following URLs for more information.

https://www-03.ibm.com/systems/power/software/i/websphere/v855/index.html
http://www-03.ibm.com/systems/power/software/i/subscription/list.html
5) IBM WAS v5.1.x and earlier are no longer supported by IBM. No support will be provided by IBM on these products.

==========================================================================
Here is a table that summarizes the currently supported versions of WAS on the IBM i OS.
==========================================================================
Not supported (No) = Technical support is no longer available from IBM without a special extended support contract.
Best effort support = As long as a valid support contract exists for the IBM i OS VRM, clients can create PMRs and L2 support will assist the best they can. No defect or development support is available.
Full support (Yes)= As long as a valid support contract exists for the IBM i OS VRM, defect and development support is available.
IBM i 5.4 (w/ valid service extension contract)
IBM i 6.1 (w/ valid service extension contract)
IBM i 7.1 (w/ valid service extension contract)
IBM i 7.2
IBM i 7.3
WAS v6.0.x
Express edition
Best effort support
(No support in Japan)
Best effort support
6.0.2.23 and later
N/A
N/A
N/A
WAS v6.0.x
Base and ND editions
No
No
N/A
N/A
N/A
WAS v6.1.x
Express edition
Best effort support
(No support in Japan)
Best effort support
6.1.0.11 and later
Best effort support
6.1.0.29 and later
N/A
N/A
WAS v6.1.x
Base and ND editions
No
No
No
N/A
N/A
WAS v7.0.x
Express edition
Best effort support
Best effort support
Best effort support
7.0.0.7 and later
N/A
WAS v7.0.x
Base and ND editions
No
No
No
N/A
N/A
WAS v8.0.x
Express edition
N/A
Best effort support
Best effort support
Best effort support
8.0.0.8 and later
N/A
WAS v8.0.x
Base and ND editions
N/A
No
No
No
N/A
WAS v8.5.x
Express edition
N/A
Best effort support
Best effort support
Yes
8.5.5.2 and later
Yes
8.5.5.10 and later
WAS v8.5.x
Base and ND editions
N/A
Best effort support
Best effort support
Yes
8.5.5.2 and later
Yes
8.5.5.10 and later
WAS v9.0.x
Base and ND editions
N/A
N/A
Best effort support
Yes
Yes
NOTE : N/A indicates the WAS version and edition is not supported and will not function on the IBM i OS version and release.

For IBM WAS Base and ND editions that are no longer supported, please refer to the following information if you want to inquire about a Support Extension Offering:

Support Extension Offering, if necessary: 
IBM WebSphere Application Server recognizes that there might be unique situations where a Client is not able to migrate to a supported product version prior to an End of Support date. Application Server may, at its discretion, extend customer technical support and defect support for a withdrawn release. Extended support for a product will be considered and provided on an individual Client basis. Information on how to pursue requesting and purchasing a Support Extension can be found in the  IBM WebSphere Application Server Support Extension technote. 

Information about our expanded lifecycle support policy for our IBM WebSphere Application Server products can be found in the  IBM Software Support Lifecycle Policy. 


Cross reference information
Segment Product Component Platform Version Edition
Operating System IBM i 7.2
Operating System IBM i 7.1
Operating System IBM i 6.1
Operating System IBM i 7.3

Document information

More support for: IBM i
WebSphere Application Server

Software version: 6.1.0, 6.1.1, 7.1, 7.2, 7.3

Operating system(s): IBM i

Software edition: All Editions, WAS v7.0, WAS v8.0, WAS v8.5.5, WAS v9.0

Reference #: N1020185

Modified date: 01 May 2018


Translate this page: