IBM Support

IBM i Classic Java Virtual Machine (JVM) - Official Product Support Information

Technote (troubleshooting)


Problem(Abstract)

This document discusses current information related to the support of the IBM i Classic Java Virtual Machine (JVM).

Resolving the problem

This document discusses current information related to the support of the IBM i Classic Java Virtual Machine (JVM).

IBM i Classic JVM LPPs per OS VRM:

V5R4Mx
5722JV1 Options 5,6,7, & 10

V6R1Mx
5761JV1 Options 6,7,& 10

V7R1Mx and later
No Classic JVM options exist at this OS VRM.

The IBM i Classic Java Virtual Machine (JVM) is currently supported on the IBM i 5.4.x and 6.1.x operating systems on a best-effort basis. Back-end development support is very limited because the product is now considered deprecated.

Development has stopped providing updates for the Classic JVMs beginning in the first quarter of 2012, including updates that fixed security vulnerabilities. Fixes are still being provided for the IBM Technology for Java VMs (57xxJV1 Option 8,9,11,12,13,14,15). IBM recommends the latest Java group PTF be downloaded and applied to obtain the latest fixes and security updates for the new IBM Technology for Java VMs.

It is recommended all clients immediately migrate their Java applications away from the Classic JVMs and use the IBM Technology for Java VMs instead. You should refer to the following URL for more information on how to install and set up your Java environment to use one of the new IBM Technology for Java VMs:
http://publib.boulder.ibm.com/infocenter/iseries/v7r1m0/topic/rzaha/rzahainstalljdk.htm


Cross reference information
Segment Product Component Platform Version Edition
Operating System IBM i 6.1

Historical Number

661178172

Document information

More support for: IBM i
Java

Software version: 5.4.0, 5.4.5, 6.1, 6.1.0, 6.1.1

Operating system(s): IBM i

Reference #: N1010513

Modified date: 01 March 2013