IBM Support

SI57468 - SC1-SSL-UNPRED OPENSSL SECURITY VULNERABILITIES

PTF ( Program Temporary Fixes ) Cover letter


Order this fix

Abstract

SC1-SSL-UNPRED OPENSSL SECURITY VULNERABILITIES


Pre/Co-Requisite PTF / Fix List

REQ  LICENSED           PTF/FIX  LEVEL

TYPE PROGRAM  RELEASE   NUMBER   MIN/MAX  OPTION
---- -------- --------- -------  -------  ------
NONE



NOTICE:
-------
Application of this PTF may disable or render ineffective programs that
use system memory addresses not generated by the IBM translator,
including programs that circumvent control technology designed to limit
interactive capacity to purchased levels.  This PTF may be a prerequisite
for future PTFs.  By applying this PTF you authorize and agree to the
foregoing.

This PTF is subject to the terms of the license agreement which
accompanied, or was contained in, the Program for which you are obtaining
the PTF.  You are not authorized to install or use the PTF except as part
of a Program for which you have a valid Proof of Entitlement.

SUBJECT TO ANY WARRANTIES WHICH CAN NOT BE EXCLUDED OR EXCEPT AS EXPLICITLY
AGREED TO IN THE APPLICABLE LICENSE AGREEMENT OR AN APPLICABLE SUPPORT
AGREEMENT, IBM MAKES NO WARRANTIES OR CONDITIONS EITHER EXPRESS OR IMPLIED,
INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OR CONDITIONS OF
MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, AND NON INFRINGEMENT,
REGARDING THE PTF.

The applicable license agreement may have been provided to you in printed
form and/or may be viewed using the Work with Software Agreements (WRKSFWAGR)
CL command.





APAR Error Description / Circumvention

-----------------------------------------------
OpenSSL for i needs to be updated to comply with
security vulnerabilities:

CVE-2015-1788
CVE-2015-1789
CVE-2015-1790
CVE-2015-1792
CVE-2014-8176
CVE-2015-1791
CVE-2015-1793

CORRECTION FOR APAR SE62447 :
-----------------------------
OpenSSL for i is updated to comply with security
security vulnerabilities:

CVE-2015-1788
CVE-2015-1789
CVE-2015-1790
CVE-2015-1792
CVE-2014-8176
CVE-2015-1791
CVE-2015-1793

CIRCUMVENTION FOR APAR SE62447 :
--------------------------------
None.


Activation Instructions


None.




Special Instructions


If this PTF is applied in immediate mode, the following instructions
are suggested in order to ensure the updated code takes immediate
affect on your system.

Restart any running processes that use OpenSSL.

In the case of SSH, do the following:

1) End any active SSH connections in NETSTAT, Option 3.
2) Restart the *SSHD daemon job via. ENDTCPSVR SERVER(*SSHD) &
STRTCPSVR SERVER(*SSHD)


Default Instructions

THIS PTF CAN BE APPLIED IMMEDIATE OR DELAYED.



Supersedes

PTF/FIX NO(S).  APAR TITLE LINE
--------------  ------------------------------------------------------------
   SI56636      SC1-SSL-UNPRED OPENSSL SECURITY VULNERABILITIES
   SI55951      SC1-SSL-UNPRED OPENSSL SECURITY VULNERABILITIES
   SI55951      SC1-UTL-UNPRED SFTP CLIENTS WITH USER PROFILES GREATER THAN
   SI55757      SC1-UTL STRTCPSVR *SSHD OR ENDTCPSVR *SSHD FAILING WITH QLGO
   SI55606      SC1-SSH-UNPRED ENDTCPSVR *SSHD WILL NOT END SSHD DAEMON JOB
   SI55341      Upgrade OpenSSL to 1.0.1j
   SI55341      SC1-SSL-UNPRED OpenSSH 6.6p1
   SI54468      SC1-SSL-UNPRED OPENSSL SECURITY VULNERABILITIES
   SI53327      SC1-UTL-INCORROUT ENDTCPSVR *SSHD WILL NOT END JOB QP0ZSPWP
   SI53960      SC1-UTL-WAIT SCP IS HANG WHILE TRANSFER DATA
   SI53663      Integrity Problem
   SI53540      Integrity Problem
   SI53171      Integrity Problem
   SI52784      INCORROUT SFTP-SERVER DOES NOT RECOGNIZE IBMPASEFORILANGID O
   SI52297      SC1-UTL-UNPRED UNABLE TO GET SSHD AUTOMATICALLY STARTED WITH
   SI52297      SC1-UTL-INCORROUT SFTP GET

Summary Information

System.............................. i
Models..............................
Release............................. V7R2M0
Licensed Program............... 5733SC1
APAR Fixed.......................... SE62447
Superseded by:...................... View fix details for PTF SI71505
Recompile........................... N
Library............................. QUTL
MRI Feature ........................ NONE
Cum Level........................... C6085730


IBM i Support

IBM disclaims all warranties, whether express or implied, including, but not limited to, the implied warranties of merchantability and fitness for a particular purpose. By furnishing this document, IBM grants no licenses to any related patents or copyrights. Copyright © 1996,1997,1998, 1999, 2000, 2001, 2002, 2003, 2004, 2005, 2006, 2007, 2008, 2009, 2010, 2011, 2012, 2013, 2014, 2015, 2016, 2017, 2018, 2019 IBM Corporation. Any trademarks and product or brand names referenced in this document are the property of their respective owners. Consult the Terms of use link for trademark information.

Document information

More support for: i family

Software version: V7R2M0

Operating system(s): OS/400

Reference #: SI57468

Modified date: 23 July 2015