IBM Support

IBM AIX: CIFS client and Daylight Saving Time

Question & Answer


Question

Why do file and directory time stamps in shares mounted with the AIX® CIFS client bos.cifs_fs.rte not reflect changes in Daylight Saving Time?
Note:  This issue applies to the old AIX CIFS client (bos.cifs_fs.rte).  The new CIFS client (smbc.rte) does not have this problem.

Cause

The AIX CIFS client uses an older version of the SMB protocol to negotiate sessions with CIFS servers.  During session negotiation, AIX gets the server's time zone offset to be able to compute appropriate time stamps for file and directory updates on the CIFS server.  Within the protocol, there is no way for the server to inform its clients when its time zone offset changes. After a transition into and out of Daylight Saving Time, file and directory time stamps can be off by one hour.

Answer

To resolve this problem, the SMB session must be renegotiated with the CIFS server so that the client receives the updated time zone offset. Simply unmounting and remounting shares can be insufficient because it might not close the session with the server.
To ensure session renegotiation, the connection with the CIFS server must be terminated before remounting CIFS shares. The easiest way is to restart the AIX system. Another option is to perform the following instructions. However, if any of these steps fail,  the only option is to restart AIX.

1. Unmount all CIFS shares.

2. Run the following commands as root.

rmdev -l nsmb0
mkdev -l nsmb0

3. Remount the CIFS shares.

SUPPORT:

If the instructions in this document do not lead to resolution of the problem, follow these instructions to open a case.  The product must be under warranty or have an active and valid support contract.

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d.  Provide a detailed description of the issue and reference this technote.

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Document Information

Modified date:
15 September 2021

UID

isg3T1026850