IBM Support

Security Bulletin: Vulnerabilities in grub2 affect PowerKVM (CVE-2015-5281, CVE-2015-8370)

Security Bulletin


Summary

PowerKVM is affected by two vulnerabilities in grub2. These vulnerabilities are now fixed.

Vulnerability Details

CVEID: CVE-2015-5281
DESCRIPTION:
grub2 builds for EFI systems could allow a local attacker to execute arbitrary code on the system, caused by the presence of modules deemed unsuitable to be loaded in a Secure Boot environment. An attacker could exploit this vulnerability to circumvent secure boot and execute arbitrary code on the system.
CVSS Base Score: 5.9
CVSS Temporal Score: See https://exchange.xforce.ibmcloud.com/vulnerabilities/108206 for the current score
CVSS Environmental Score*: Undefined
CVSS Vector: (CVSS:3.0/AV:L/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L)

CVEID: CVE-2015-8370
DESCRIPTION:
GRUB2 could allow a local attacker to gain elevated privileges on the system, caused by the improper handling of backspace characters entered in username and password prompts by grub-core/lib/crypto.c' and 'grub-core/normal/auth.c. An attacker could exploit this vulnerability to bypass password protection and gain administrative access to the system.
CVSS Base Score: 8.4
CVSS Temporal Score: See https://exchange.xforce.ibmcloud.com/vulnerabilities/108954 for the current score
CVSS Environmental Score*: Undefined

Affected Products and Versions

PowerKVM 2.1 and PowerKVM 3.1

Remediation/Fixes

Customers can update PowerKVM systems by using "yum update".

Fix images are made available via Fix Central. For version 3.1, see https://ibm.biz/BdHggw for 3.1 service build 3 or later.

For version 2.1, the fix is made available via Fix Central (https://ibm.biz/BdEnT8) in 2.1.1 Build 65.6 and all later 2.1.1 SP3 service builds and 2.1.1 service packs. Customers running v2.1 are, in any case, encouraged to upgrade to v3.1.

For v2.1 systems currently running fix levels of PowerKVM prior to 2.1.1, please see http://download4.boulder.ibm.com/sar/CMA/OSA/05e4c/0/README for prerequisite fixes and instructions.

Workarounds and Mitigations

v2.1 customers can work around the problem by upgrading to the fixed release of v3.1

Get Notified about Future Security Bulletins

References

Related information

Change History

19 February 2016 - Initial Version

*The CVSS Environment Score is customer environment specific and will ultimately impact the Overall CVSS Score. Customers can evaluate the impact of this vulnerability in their environments by accessing the links in the Reference section of this Security Bulletin.

Disclaimer

According to the Forum of Incident Response and Security Teams (FIRST), the Common Vulnerability Scoring System (CVSS) is an "industry open standard designed to convey vulnerability severity and help to determine urgency and priority of response." IBM PROVIDES THE CVSS SCORES "AS IS" WITHOUT WARRANTY OF ANY KIND, INCLUDING THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. CUSTOMERS ARE RESPONSIBLE FOR ASSESSING THE IMPACT OF ANY ACTUAL OR POTENTIAL SECURITY VULNERABILITY.

Document information

More support for: PowerKVM

Software version: 2.1, 3.1

Operating system(s): Linux

Software edition: KVM

Reference #: T1023376

Modified date: 04 March 2016