Howto Submit Information to IBM Linux / VMware Support

Technote (FAQ)


Question

Howto Submit Information to IBM Linux / VMware Support

Cause

Request from IBM Support

Answer


This document provides information for customers who have been asked by their Linux / VMware support representative to deliver testcases associated with PMRs to IBM over the Internet. Delivering these testcases electronically helps IBM resolve problems for you quicker by enabling our support centers to obtain needed information faster.



Before you begin
Before delivering testcases via the Internet, you must be instructed to do so by the Linux or VMware support representative who is working on your problem. You will need the PMR number and other necessary information which your support representative will discuss with you.

Delivery via the Internet
Follow these steps to deliver your testcase:
    1. Create your testcase following the recommended File naming convention below .

      NOTE: Failure to use the recommended file naming convention will delay resolution of your problem.
    2. Use ftp to put your testcase onto an IBM server.


Create a compressed tar archive
All testcases delivered electronically to IBM must be in compressed tar format (.tar.Z).

File naming convention

When you create the tar or pax archive, using the following naming convention allows support tools to move the testcase automatically to the proper directories and update the PMR to indicate that the testcase is available.

If the testcase files cannot be associated with an existing PMR, they will be tagged as lost and eventually deleted.

ppppp.bbb.ccc.tar.Z

ppppp is the 5 character PMR number.

bbb is the 3 character branch office number

ccc is the 3 character country code (may be omitted if the country code is 000)

tar indicates a tar archive

Z indicates that the archive is compressed (if you have the gzip command available, this will be .gz rather than .Z)

Examples:
9x999.999.999.tar.gz (problem_report_#.branch_office_#.country_code.tar.gz)
1x234.001.tar.Z (problem_report_#.branch_office_#.tar.Z)



Deliver the testcase via FTP
Failure to use the file naming convention will delay resolution to the problem you are experiencing. If you need help understanding how to create a compressed tar archive, contact the support representative who is working on your problem.

Read the "Statement on Confidentiality". By submitting your testcase to IBM you are agreeing to comply with the statement on confidentiality. If you do not agree, do not use this service.

You should also read and understand the "Service Use Agreement".

There are 2 methods / locations for uploading data to IBM.

The following link provides information about ECUREP. An easy to use method that can be done via the web or commandline ftp.

http://www-05.ibm.com/de/support/ecurep/

The other method uses an ftp server and it's use is described below.



    1. Connect to the server using FTP:
      ftp testcase.software.ibm.com

      NOTE: If you have problems accessing this machine, contact your Internet service provider.

    2. Log in as an anonymous user giving your complete e-mail address as the password. For example:
      Name: anonymous
      Password: sampleuser@samplecompany.com
    3. Switch to binary mode:
      bin
    4. Change to the /toibm/linux for Linux testcases or /toibm/vmware directory for VMware:

      cd /toibm/linux

      or

      cd /toibm/vmware
    5. Put your compressed tar archive file into the directory. For example:
      put 81230.469.000.tar.Z

      NOTE:   For subsequent testcases sent within 72 hours of the first testcase, the name must be changed. The pmr#, branch#, and country code# must still appear, however, it must be distinguished from the first somehow. For example, ppppp.bbb.ccc.2.pax.Z. Additional testcases should be named with '3', '4', etc.
    6. Notify your service representative that delivery is complete.


**** Service Use Agreement ****
International Business Machines Corporation
Internet Testcase Delivery Service
Service Use Agreement

This is a legal agreement to which you are consenting to be bound. If you do not agree to all of the terms of this license, do not use the service.
  • International Business Machines Corporation (IBM) grants you nonexclusive access to the Testcase Delivery Service via the Internet.
  • IBM makes no representations about the suitability of this service or about any content or information made accessible by the service, for any purpose. The service is provided "as is" without express or implied warranties, including warranties of merchantability and fitness for a particular purpose or noninfringement. This service is provided gratuitously and, accordingly, IBM shall not be liable for any damages suffered by you or any user of the service.
  • While IBM intends to maintain this Service, IBM reserves the right at any time to alter access, features, capabilities and functions of this Service. IBM may terminate this Service at any time without notice to you.
  • You may not download or upload or otherwise export or reexport images or files from or to systems providing this Service except in full compliance with all United States and other applicable laws and regulations. In particular, but without limitation, none of the images or files provided or received by this Service may be downloaded or uploaded or otherwise exported or reexported (i) into or received from (or to a national or resident of) Cuba, Haiti, Iraq, Libya, Yugoslavia, North Korea, Iran, or Syria or (ii) to anyone on the US Treasury Department's list of Specially Designated Nationals or the US Commerce Department's Table of Deny Orders. By downloading or uploading images or files from or to systems providing this Service, you are agreeing to the foregoing and you are representing and warranting that you are not located in, under control of, or a national or resident of any such country on any such list.

Statement on Confidentiality

Exchanging diagnostic data with IBM

To assist you in isolating the cause of a problem with the program, our support specialists may request that you send IBM the problem information, systems data, test cases, etc., or that our support specialists be able to view it with you electronically by remotely accessing your system. IBM uses information about errors and problems to improve its products and services, and assist with its provision of related support offerings. For these purposes, IBM may use IBM entities and subcontractors (including in one or more countries other than the one in which You are located), and You authorize IBM to do so. You confirm that you have the right to provide us with the data you send to us regarding your problems and errors for the purpose of analyzing that data.

You remain responsible for 1) any data and the content of any database you make available to IBM, 2) the selection and implementation of procedures and controls regarding access, security, encryption, use, and transmission of data (including any personally-identifiable data), and 3) backup and recovery of any database and any stored data. You will not send or provide IBM access to any personally-identifiable information, whether in data or any other form, and will be responsible for reasonable costs and other amounts that IBM may incur relating to any such information mistakenly provided to IBM or the loss or disclosure of such information by IBM, including those arising out of any third party claims.

By sending us problem information, you warrant that none of the data exported to, or otherwise accessible by, IBM is controlled as a defense article under the U.S. International Traffic in Arms Regulation (ITAR) or under any other country’s laws or regulations. You may not upload or otherwise export or re-export images or files from or to us except in full compliance with all applicable export and import laws and regulations. You understand and acknowledge that IBM is a U.S. headquartered company and that applicable U.S. export laws and regulations may prohibit IBM from providing services to certain end users and for certain end uses.

Once your data is completely received by IBM approved means, IBM will use it only for the purposes for which it was provided - that is, to fix IBM defects or to support IBM products or services. We will not disclose it to other parties, except to contractors of IBM who we may use to help us fix defects or provide support; and we will delete, destroy or return it when it is no longer required. If you elect to have us return physical media, you will be responsible for arranging for return transport of the media. IBM will provide the tapes to your designated carrier at the IBM location, but other­wise will have no responsibility/liability for return of the media.




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Document information


More support for:

Linux family

Software version:

1.0

Operating system(s):

Linux, VMWare

Reference #:

T1010246

Modified date:

2011-08-22

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