IBM Support

IV69977: DIAG SERVICE EVENT FAILED - CANNOT REPORT H/W PROBLEM TO SFP APPLIES TO AIX 6100-08

A fix is available

Subscribe

You can track all active APARs for this component.

 

APAR status

  • Closed as program error.

Error description

  • LABEL:          SERVICE_EVENT
    IDENTIFIER:     C231441F
    <snip>
    Class:           S
    Type:            INFO
    WPAR:            Global
    Resource Name:   oppanel
    
    Description
    Cannot report H/W problem to SFP.
    
    Probable Causes
    diagServiceEvent returned an error
    
    Failure Causes
    Service Focal Point not informed of hardware problem.
    
            Recommended Actions
            Use /usr/lpp/diagnostics/bin/diagrpt -a and the
    following sequence number to find the hardware problem.
            Report the hardware problem and this failure to
    the IBM Support Center.
    
    Detail Data
    Diagnostic Event Log Sequence Number
           537
    Return Code
        9
    diagServiceEvent Error Message
    mkrsrc command failed rc = 1
    

Local fix

Problem summary

  • With CT_MANAGEMENT_SCOPE=2 ,invoking diagServiceEvent may fail:
    DIAG SERVICE EVENT FAILED - CANNOT REPORT H/W PROBLEM TO SFP
    

Problem conclusion

  • Ensure CT_MANAGEMENT_SCOPE is appropriately handled inside
    diagServiceEvent.
    

Temporary fix

Comments

  • 6100-08 - use AIX APAR IV69977
    6100-09 - use AIX APAR IV66046
    7100-02 - use AIX APAR IV70233
    7100-03 - use AIX APAR IV66061
    

APAR Information

  • APAR number

    IV69977

  • Reported component name

    AIX 610 STD EDI

  • Reported component ID

    5765G6200

  • Reported release

    610

  • Status

    CLOSED PER

  • PE

    NoPE

  • HIPER

    NoHIPER

  • Submitted date

    2015-02-26

  • Closed date

    2015-02-26

  • Last modified date

    2015-09-30

  • APAR is sysrouted FROM one or more of the following:

    IV62601

  • APAR is sysrouted TO one or more of the following:

Fix information

  • Fixed component name

    AIX 610 STD EDI

  • Fixed component ID

    5765G6200

Applicable component levels

  • R610 PSY U868777

       UP15/09/18 I 1000

PTF to Fileset Mapping

[{"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Product":{"code":"SG11Q","label":"AIX 6.1 HIPERS, APARs and Fixes"},"Component":"","ARM Category":[],"Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"610","Edition":"","Line of Business":{"code":"LOB08","label":"Cognitive Systems"}},{"Business Unit":{"code":"BU054","label":"Systems w\/TPS"},"Product":{"code":"SSMV87","label":"AIX 6.1 Enterprise Edition"},"Component":"","ARM Category":[],"Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"610","Edition":"","Line of Business":{"code":"LOB08","label":"Cognitive Systems"}},{"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Product":{"code":"SSMVAX","label":"AIX Express Edition"},"Component":"","ARM Category":[],"Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"610","Edition":"","Line of Business":{"code":"LOB08","label":"Cognitive Systems"}},{"Business Unit":{"code":"BU054","label":"Systems w\/TPS"},"Product":{"code":"SSAUMY","label":"IBM AIX Enterprise Edition"},"Component":"","ARM Category":[],"Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"610","Edition":"","Line of Business":{"code":"LOB08","label":"Cognitive Systems"}},{"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Product":{"code":"SG11Q","label":"AIX 6.1 HIPERS, APARs and Fixes"},"Component":"","ARM Category":[],"Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"610","Edition":"","Line of Business":{"code":"LOB08","label":"Cognitive Systems"}},{"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Product":{"code":"SG11R","label":"APARs - AIX 7.1 environment"},"Component":"","ARM Category":[],"Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"610","Edition":"","Line of Business":{"code":"LOB08","label":"Cognitive Systems"}}]

Document Information

Modified date:
17 December 2021