IBM Support

Cassandra and MongoDB ODBC Drivers are not registered on Windows

Troubleshooting


Problem

On a new IS 11.7 install or IS 11.7.0.1 install, the Cassandra and MongoDB ODBC Drivers are not registered on Windows platform.

Symptom

Users would not be able to create ODBC DSNs for Cassandra and MongoDB databases.

Cause

The registration of the Cassandra and MongoDB ODBC Drivers is missing in the install.

Environment

Windows Only

Diagnosing The Problem

The Cassandra and MongoDB ODBC Drivers are not listed in the ODBC Administrator tool's Drivers tab.

Resolving The Problem

Download and install the latest available DataDirect ODBC Driver Set from IBM fixcentral

Related Information

[{"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSZJPZ","label":"IBM InfoSphere Information Server"},"Component":"ODBC Connector","Platform":[{"code":"PF033","label":"Windows"}],"Version":"11.7;11.7.0.1","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
10 July 2018

UID

ibm10716799