IBM Support

Importing a Microsoft Word document into RequisitePro

Technote (FAQ)


Question

How do you import a Microsoft Word document into IBM Rational RequisitePro?

Answer

There is an Import Wizard to import a Microsoft Word document in its entirety into a Rational RequisitePro project.

  • The document you are importing must be in Word format (see Saving requirements documents as Word documents in RequisitePro help).
  • If your document was created in an application other than Word, refer to the Microsoft Word documentation to save the file in Word format.

Note: If the document type you selected contains formatting, you have the option of retaining the formatting of the imported document or overwriting it with the format of the document type outline that you selected.

  1. Turn off Word's spelling, grammar, and background re-pagination options (in the Word menu's Tools > Options dialog box) before importing a Word document.
  2. Ensure there are no pending, unaccepted changes in the source document from Word's Document Protect or Track Changes functions. If there are, then they must be cleared prior to importing the document into RequisitePro.
    • To unprotect the document, go to Tools > Unprotect Document.
    • Turn off Track Changes, go to Tools > Track Changes > Highlight Changes and uncheck Track Changes while editing.
    • To accept all changes, go to Tools > Track Changes > Accept or Reject Changes and Accept all Changes.
  3. To begin importing a Word document, open the RequisitePro project and choose File > Import from the main RequisitePro menu. The Import Wizard appears. Each screen of the Import Wizard includes a Help button. To view step-by-step instructions about using the screen, click the Help button in that screen.
  4. In the Select a source window, choose Microsoft Word document, click Browse to and navigate to the Word document then select on Next.
  5. Choose what you want to import and click on Next.
    • Select Requirements and Document if the document came from another RequisitePro project and you want to keep the same requirements.
    • Select Requirements only if there are RequisitePro requirements in the document which you want in this RequisitePro project, but you do not want the other text of the document to be imported.
    • Select Document only if there are no existing RequisitePro requirements in this document.
  6. In the Document Properties window, give the document the name it will appear as in RequisitePro.
    • You can enter a description or leave it blank.
    • You can select a package to place this into, or RequisitePro will automatically create a package for this document if one isn't selected.
    • The filename will automatically fill with the information entered in under Name.
    • Choose the directory where the document will be saved by browsing to it.
    • Choose a document type and click on OK.
  7. If the document contains formatting, a message will appear asking whether the existing formatting should be kept or not.
  8. If the document contains existing RequisitePro requirements, a message will appear asking whether these bookmarks should be deleted or not. If importing requirements, do not remove these bookmarks.
  9. If importing requirements, a window will appear allowing you to set the requirement type, how to select requirements (keywords, text delimiters, Word styles), select the range, and enter keywords. Click on Next.
  10. Requirements found will be posted in the window. If importing existing RequisitePro requirements, they will not appear in this window but will still be committed to the database. Click on Commit.

Document information

More support for: Rational RequisitePro
General Information

Software version: 7.0, 7.0.0.1, 7.0.0.2, 7.0.0.3, 7.0.0.4, 7.0.0.5, 7.0.0.6, 7.0.1, 7.0.1.1, 7.0.1.2, 7.0.1.3, 7.0.1.4, 7.0.1.5, 7.0.1.6, 7.1, 7.1.0.1, 7.1.0.2, 2003.06.00, 2003.06.10, 2003.06.12, 2003.06.13, 2003.06.14, 2003.06.15, 2003.06.16

Operating system(s): Windows

Reference #: 1135529

Modified date: 27 October 2010


Translate this page: