IBM Support

AIX requirement for hosting CM Server and ClearQuest Web 7.1.x to prevent crashing or hanging

Troubleshooting


Problem

Hosting IBM Rational ClearQuest Web 7.1.x on AIX may result in process crashes or hanging when the server is under heavy load.

Cause

This issue was identified as a product defect under APAR PM07903. This defect is fixed starting in ClearQuest 7.1.1.2.

Resolving The Problem

This issue has been resolved in 4025565: Rational ClearQuest Fix Pack (7.1.1.2) for version 7.1.1

In addition to the Rational ClearQuest fix, you must also apply a fix to the AIX operating system for defect APAR IZ39394.

These are the minimum, recommended versions to which you should upgrade:

  • AIX 6.1 TL4 (6100-04)
  • AIX 5.3 TL11 (5300-11-00-0943)

If it is not immediately possible to upgrade to either technology level (TL) for your respective version, you can upgrade your release of the xlC runtimes to these versions:
  • xlC.rte 10.1.0.2
  • xlC.rte 9.0.0.9
  • xlC.rte 8.0.0.14

You can verify the current runtime level on AIX and upgrade to one of above versions as required. The installed xlC runtime version on AIX can be verified using this command:

lslpp -L | grep xlC.rte

Here are the links to the cumulative fix packs for the different versions of xlC:

[{"Product":{"code":"SSSH5A","label":"Rational ClearQuest"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Web Server (7.1)","Platform":[{"code":"PF002","label":"AIX"}],"Version":"7.1;7.1.1;7.1.2;8.0","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}},{"Product":{"code":"SSSH5A","label":"Rational ClearQuest"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"CM Server","Platform":[{"code":"","label":""}],"Version":"","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
16 June 2018

UID

swg21428822