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Child records not appearing in parent within ClearQuest client when DBID added to List View

Troubleshooting


Problem

This technote identifies an issue that can occur in the IBM Rational ClearQuest Eclipse RCP client. Child records are not shown in the parent record if the DBID of the child record type is in the list view field.

Symptom

A parent-child relationship is setup between a stated and stateless record type. An example of this would be in the out-of-the-box DefectTracking schema, with the Defect and Customer record types.

You open a parent record. You try to add or create a new child record to the parent form. The child record does not appear. However, if you perform a 'Find a Record' for the child record it does in fact exist.

Cause

If the DBID is a display field for the list view, the records will not appear in the parent record. This issue was identified as a product defect under APAR PK99706.

Resolving The Problem


This defect is fixed starting in version 7.1.1.1. Upgrade to the latest version to resolve this problem.

WORKAROUND

Do not use the DBID field within your List View control. Instead, use the unique key or other fields. You can change the columns of the list field in ClearQuest Designer. See the List view control topic of the ClearQuest Information Center for more information.

[{"Product":{"code":"SSSH5A","label":"Rational ClearQuest"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Client - Eclipse RCP","Platform":[{"code":"PF033","label":"Windows"}],"Version":"7.1.0.2;7.1.1","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
23 June 2018

UID

swg21410260