Skip to main content

Software  >  Rational  >  

Reqmaster fails even if reqmaster is allowed at remote replica

 Technote (troubleshooting)
 
Problem(Abstract)
This technote explains how to resolve an error, You do not have permission to request mastership from the sibling replica, that can occur when requesting IBM Rational ClearCase MultiSite mastership even if reqmaster is allowed at the remote site.
 
Symptom

Running a reqmaster command fails with an error:


$ cleartool reqmaster -nc my_element@@/main

cleartool: Error:  my_element@@/main

The following blocked the "reqmaster" operation at replica "remote_replica".

    You do not have permission to request mastership from the sibling replica.

 
Cause

If the VOB is stored remotely on a network attached storage (NAS) device, the root user on the VOB server may not have write permission to the NAS device where the VOB storage is located.
 
Diagnosing the problem

At the remote site (where the mastership is requested):

$  cleartool describe my_element@@/main

branch "my_element@@/main"

  created 20-Dec-04.17:35:11 by me.Domain Users@my_pc

  branch type: main

  master replica: remote_replica@/vob/my_vob

  request for mastership: allowed

  Element Protection:

    User : vobadm   : r-x

    Group: mygroup   : r-x

    Other:          : r-x

  element type: text_file


At remote site, mastership ACL cannot be retrieved:

$ multitool reqmaster -acl -get vob:/vob/my_vob

msadm_vob_rfm_get_acl_V1: RPC: Unable to receive; errno = Connection reset by peer

multitool: Error:  vob:/vob/my_vob

The following prevented the local "get ACL" operation.

Could not get Request Mastership ACL.

 
Resolving the problem

Refer to the Enabling requests for mastership section in the IBM Rational ClearCase information center for information about enabling mastership requests for replicas in a VOB family.

Make sure that the root user on the VOB server has write permission to the NAS device where the VOB storage is located.

Do you need more help?

For additional assistance, contact IBM Rational Customer Support:
Submit a Service Request (SR)

 
Related information
Could not set ACL when changing reqmaster permissions
Status messages
 
 
 

Copyright and trademark information
IBM, the IBM logo and ibm.com are trademarks of International Business Machines Corp., registered in many jurisdictions worldwide. Other product and service names might be trademarks of IBM or other companies. A current list of IBM trademarks is available on the Web at "Copyright and trademark information" at www.ibm.com/legal/copytrade.shtml.
Rate this page
Please take a moment to complete this form to help us better serve you.
This material provides me with the information I need.




This material is clear and easy to understand.




Did the information help you to achieve your goal?
What updates, improvements, or related information would you like to see in this document?
Your response will be used to improve our document content. Requests for assistance, if applicable, should be submitted through your normal support channel as we cannot respond from this site.
Input the verification number to submit feedback:
Document information
 Product categories:
 Software
 Software Development
 Change, Configuration, & Release Management
 Rational ClearCase MultiSite
 Mastership: Reqmaster
 Operating system(s):
  AIX, HP-UX, Linux, Solaris
 Software version:
  7.0, 7.0.0.1, 7.0.0.2, 7.0.0.3, 7.0.0.4, 7.0.0.5, 7.0.0.6, 7.0.0.7, 7.0.0.8, 7.0.1, 7.0.1.1, 7.0.1.2, 7.0.1.3, 7.0.1.4, 7.0.1.5, 7.0.1.6, 7.0.1.7, 7.1, 7.1.0.1, 7.1.0.2, 2003.06.00, 2003.06.16
 Reference #:
  1409536
 IBM Group:
 Software Group
 Modified date:
 2009-11-05

Translate My Page
 
 

Rate this page

Help us improve this page. Your response will be used to improve our document content. Requests for assistance, if applicable, should be submitted through your normal support channel as we cannot respond from this site.