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Possible corruption caused editing files from Visual Studio.NET using remote dynamic views

Troubleshooting


Problem

This technote serves as a warning of potential file corruption from Microsoft® Visual Studio®.NET IDE when using IBM® Rational® ClearCase® dynamic views serviced by a remote view server.

Symptom


The following errors will be reported in the system log:

{Delayed Write Failed}
Windows was unable to save all the data for the file \Device\LanmanRedirector. The data has been lost. This error may be caused by a failure of your computer hardware or network connection. Please try to save this file elsewhere.

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.
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Application popup: Windows - Delayed Write Failed : Windows was unable to save all the data for the file \Views_Synapse\FMSUZ\KevinN\test_delayed_write_problem.vws\.s\00051\800001f647e7c1ebFujiPrst.cab. The data has been lost. This error may be caused by a failure of your computer hardware or network connection. Please try to save this file elsewhere.

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.

Cause

There is a known problem reported and confirmed by Microsoft as a defect in the Windows redirector that causes potential file corruption when files that are being served up from a remote file share are edited from within Visual Studio .NET.

In ClearCase, this has been determined to affect editing from the Visual Studio.NET IDE in dynamic views when the view server is remote. In this configuration, the Visual Studio.NET IDE can truncate files resulting in data loss.

The problem is traceable to a memory mapped file issue and the specific way that the IDE editor maps files for editing.

The operating systems where this defect exists include Windows 2000, Windows XP and Windows 2003.

Note: This problem is also more prevalent in Windows 2000 with Service Pack 4 than earlier Windows 2000 service packs.

Resolving The Problem


Microsoft has hot-fixes for this defect.

You need to contact Microsoft Support Services to obtain the fix by specifying the appropriate Knowledge Base Article.

The links to the Microsoft hot-fixes are below, under the Related information section.

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Document Information

Modified date:
29 September 2018

UID

swg21139357