System Requirements for WebSphere Message Broker V6.1 for AIX

Product documentation


Abstract

This document contains system requirements for the WebSphere Broker V6.1 products on AIX.

Content

The Configuration Manager, User Name Server and Broker requirements for AIX platform are documented below.


Configuration Manager, User Name Server and Broker Requirements:

Please read first
  • WebSphere Message Broker, WebSphere MQ Integrator, and Integrator Broker product READMEs
  • Where patches for a product are specified, this means that these patches were required to resolve problems found during testing and should therefore be considered as the minimum necessary maintenance level. Further maintenance should be applied in accordance with the guidance of the relevant software manufacturer.
  • The Message Broker supports any JMS 1.1 provider. The minimum embedded JRE is Java 1.5. Both of these factors need to be considered when selecting a JMS provider whose client will be embedded in Message Broker.
  • The minimum supported level of xlC/xlC++ runtime libraries is V9.0.0.3.
  • Defect support is available for virtualization environments where they relate to releases of this platform already supported by WebSphere Message Broker. Unless stated elsewhere in the system requirements, WebSphere Message Broker has not been specifically tested in virtualization environments. WebSphere Message Broker Support is therefore unable to assist in issues related to configuration and setup, or issues that are directly related to the virtualization environment itself.
Hardware Requirements
  • 64-bit IBM System p systems only, capable of running the required level of a compatible operating system with enough storage to meet the requirements of WebSphere Message Broker.
  • Any hardware capable of running other trademarked AIX systems from IBM or other vendors that have passed a set of certification tests for compliance with the AIX application binary and programming interfaces.
  • POWER7 requires WebSphere Message Broker V6.1.0.4 or later. Please also refer to IBM Developer Kits support for IBM Power 7 systems.
Operating Systems
Notes:
  1. Whilst AIX 5.3 TL04 was the minimum supported level prior to WMB V6.1.0.2, a problem has been identified with the broker's use of malloc buckets which is resolved by upgrading the bos.rte.libc fileset to at least 5.3.0.52. This version is available in AIX 5.3 TL05 SP2. Please refer to the README for further information.
  2. WMB V6.1.0.8 or later is required.
Databases
(required for the broker component only)
Brokers can access Information Integrator data sources, for user data, on WebSphere Information Integrator for Linux, UNIX, and Windows V8.2.
Brokers can access, via JDBC only, Information Integrator data sources for user data on WebSphere Information Integrator Classic Federation (IICF) for z/OS, where the WebSphere IICF client code is provided for the Message Broker platform.

Notes:
  1. Oracle 10g Release 2 (only that version) requires the fix for AIX APAR IY89080.
  2. Oracle Database Server requires the Oracle Runtime Client if using 32-bit Execution Groups.
  3. JDBC Type-4 transaction support using DB2 requires a minimum level of DB2 v9.1 Fix Pack 3 or later. Support on DB2 8 is not available.
  4. Only the connect-time failover feature, using a list of alternate servers, of Oracle RAC in non-XA environments is supported. The connect-time failover feature, using a list of alternate servers, of Oracle RAC is also supported in ODBC XA environments for supported Oracle versions from 10.2.0.4 and above, with WebSphere Message Broker V6.1.0.6 or later. Please note that this is only supported for 64 bit execution groups for this platform.
  5. Automatic Client Reroute for DB2 is supported.
  6. Informix support only for user databases. Large objects (LOBs) are not supported. Stored procedures are supported with WebSphere Message Broker V6.1.0.4 and Informix Client SDK V3.50 with FC4 Fix Pack.
  7. Globally coordinated transaction support (‘XA’) is provided. Dynamic registration of Oracle XA datasources is supported for 64bit execution groups on AIX with WebSphere MQ V6.0.2.5 plus APAR IZ40753.
  8. WebSphere Message Broker V6.1.0.2 is the minimum supported product level; APAR IC57602 must also be applied.
  9. WMB V6.1.0.5 or later is required.
  10. WMB V6.1.0.8 or later is required.
  11. IBM DB2 Database Server - System i support (non-XA only).
    a. Brokers can access DB2 Databases, for user data, on System i servers running OS/400 V5R2, V5R3 or V5R4 via DB2 Connect.

    b. This support is subject to the following restrictions:


      i. The broker database may not reside on the System i server.

      ii. Globally coordinated ('XA') transactions are not supported.

      iii. Database stored procedures on the System i server may be called, when using DB2 Connect, but not with System i Access for Windows.

      iv. Message flows containing Rules and Formatter Extension nodes may not access System i databases.

IBM DB2 Database Server - System z support:

    a. Brokers can access DB2 Databases, for user data, on System z servers via DB2 Connect. Supported versions of DB2 can be found here.

    b. This support is subject to the following restrictions:
      i. The broker database may not reside on the System z server.

      ii. Message flows containing Rules and Formatter Extension nodes may not access System z databases.
WebSphere MQ
Notes:
  1. WebSphere MQ V6.0.1.0 or later is required for globally coordinated transaction support (‘XA’).
  2. WebSphere Message Broker V6.1.0.3 or later is required.
  3. WebSphere Message Broker V6.1.0.5 or later is required.
Supported Adapters For specific enterprise information system (EIS) product versions supported by the v6.1 WebSphere Adapters embedded in WebSphere Message Broker please refer to the software requirements page at: Supported software for IBM WebSphere Adapters and IBM WebSphere Business Integration Adapters
  • SAP (System p and POWER hardware)
  • Siebel (System p and POWER hardware)
  • PeopleSoft (System p only)
Rules and Formatter Extension Please refer to the Rules and Formatter Extension installation readme for a list of supported databases.
WebSphere Service Registry and Repository
Notes:
  1. Support is provided when using 6.1 compatibility URLs.
    Documentation for the "compatibility URLs" mentioned can be found at: WebSphere Service Registry and Repository - Web service interface URLs


Change History
  • 29th May 2008: New format released (WebSphere Message Broker 6.1.0.2 information is also included).
  • 10th June 2008: Clarified the minumum supported level of xlC/xlC++ runtime libraries is V9.0.0.3.
  • 1st July 2008: Replaced note 4 in Databases section.
  • 16th September 2008: Added support for Informix Dynamic Server V10.00.
  • 27th November 2008: General update in support of the WebSphere Message Broker 6.1.0.3 release.
  • 6th April 2009: Added 'XA' support to DB2 9.5.
  • 11th June 2009: Added support for stored procedures on IDS, Oracle RAC in XA and dynamic registration of Oracle XA resources.
  • 17th December 2009: Added support for Microsoft SQL Server 2008.
  • 20th January 2010: Added support for IBM WebSphere MQ for AIX, V7.0.1.
  • 7th April 2010: Added support for IBM DB2 9.7.
  • 30th July 2010: Clarified POWER 7 hardware requirements.
  • 29th September 2010: Added support for Oracle 11g Release 2.
  • 15th November 2010: Added support for AIX 7.1.
  • 12th March 2012: Oracle RAC support clarification added.
  • 8th May 2012: Added support for WSRR 7.5.

Related information

WebSphere Broker detailed system requirements

Product Alias/Synonym

WMB WEB WMB with RFE

Rate this page:

(0 users)Average rating

Add comments

Document information


More support for:

WebSphere Message Broker
Documentation

Software version:

6.1

Operating system(s):

AIX

Reference #:

7010512

Modified date:

2007-10-25

Translate my page

Machine Translation

Content navigation