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Adding member to a group results in delay followed by blank page.

 Technote (troubleshooting)
 
Problem(Abstract)
In the IBM WebSphere Portal --> Manage Users and Groups portlet, clicking Add Member results in a delay followed by a blank page.
 
Cause

This problem occurs when the Manage Users and Groups portlet builds too long a list of users from which the administrator can choose the new member. In WebSphere Portal 6.0 this situation can occur if WebSphere Member Manager's (WMM's) maximumSearchResults setting is too high.
 
Diagnosing the problem

For WebSphere Portal 6.0:

Check the wmm.xml file for the maximumSearchResults parameter (default setting is 200):

    <wmm name="member manager"
    ...
    maximumSearchResults="200"
If this value is significantly more than 200, performance problems can lead to failures, To see why, recreate the problem with the following traces set:

    com.ibm.wps.portlets.manageprincipals.*=all:
    com.ibm.wps.portlets.manageprincipals.util.*=all:
    com.ibm.wps.portlets.manageprincipals.render.*=all:
    com.ibm.wps.portlets.admin.*=all:com.ibm.wps.puma.*=all:
    com.ibm.wps.services.puma.*=all:com.ibm.wps.commands.puma.*=all:
    com.ibm.wps.ac.*=all:com.ibm.wps.command.ac.*=all:com.ibm.wps.ac.impl.*=all:
    com.ibm.wps.engine.*=all:com.ibm.websphere.wmm.*=all:com.ibm.ws.wmm.*=all:
    WSMM=all

The trace.log will show the following:

Action to add a member to a group:

    ... LegacyActionD 2 com.ibm.wps.engine.commands.LegacyActionDispatcher processPortletAction() PortletWindow: "Control (Manage Users and Groups, ... ActionReference: "sa.manageprincipals.AddMember" ...
    ...
    ... ManagePrincip < com.ibm.wps.portlets.manageprincipals.ManagePrincipals actionPerformed
    RETURN selectedAction=manageprincipals.AddMember
    ...
    ... GeneralUtil   < com.ibm.wps.portlets.manageprincipals.util.GeneralUtil getActor RETURN  
    ...
A list is built for selecting which member to add to the group:

    ... WMM Trace Log < com.ibm.ws.wmm.ldap.LdapBeanImpl ExternalMemberSet search(...
    ...
A long list is returned here with entries similar to:

    {cn=cn:user1, uid=uid:user1}, memberType:0,memberIdentifier:[CN=user1,dc=yourcompany,dc=com / 5374399f11309e458ba61dc05c0526a2],parentMemberIdentifier:null {cn=cn:user1, uid=uid:user1}]
Then processing occurs for each domain name in the list (can take a long time and may cause the page request to timeout in the browser):

    ... PumaDNHelper  > com.ibm.wps.puma.util.PumaDNHelper normalizeDistinguishedName ENTRY
    CN=user1,dc=yourcompany,dc=com
 
Resolving the problem

There are two ways to resolve this problem in WebSphere Portal 6.0:

Option 1
    Edit the wmm.xml file and reset the maximumSearchResults parameter to the default of 200 (use the checkout/check-in procedure if in a cluster).

    Restart WebSphere Portal and test. You might have set maximumSearchResults to accommodate a large number of users, groups, and/or group member, so that you often receive the following when searching:
      EJPAL4000E: Too many matches found ...
    Administrators should use more specific search filters to avoid these errors. Exceeding the maximumSearchResults parameters causes administrative inefficiencies by having to page through hundreds of users/groups.

Option 2
    By default, when Add Members is clicked, the portlet attempts to find and show all users who are not currently members of the group. If there are a large number of users and a high setting for maximumSearchResults, this problem may occur. You can avoid it by following these steps:

    1. Click Launch --> Administration --> Portlet Management --> Portlets.

    2. Navigate to or search for the Manage Users and Groups portlet.

    3. Click the Configure (wrench) icon for the portlet and change the value of "showAllAddMembers" to No.

    As a result of these changes, the next time you attempt to add a member to a group, it will no longer search for all users who are not in the group. Instead you will see this message:
      EJPAL1010W: Sorry, no user or user group was found!

    Then you can search for the user(s) you want to add to the group.

For WebSphere Portal 6.1, use Option 2 to resolve the problem.
 
 
 

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Document information
 Product categories:
 Software
 Organizational Productivity, Portals & Collaboration
 Portals
 WebSphere Portal
 Administration Portlets
 Operating system(s):
  AIX, HP-UX, Linux, Solaris, Windows, i5/OS, z/OS
 Software version:
  6.0, 6.1
 Software edition:
  Enable, Express, Extend, Server
 Reference #:
  1367079
 IBM Group:
 Software Group
 Modified date:
 2009-11-03

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