IBM Support

Detailed system requirements for Tivoli Workload Scheduler, version 9.2

Detailed system requirements


Abstract

This document details the system requirements for IBM Tivoli Workload Scheduler, version 9.2.

Content

This document provides details of the system requirements for all Tivoli Workload Scheduler components on all supported operating systems.

The topics included are:

To download the Tivoli Workload Scheduler electronic images go to the Tivoli Workload Scheduler download page.

To view the Tivoli Workload Scheduler Release Notes, go to the Release Notes page.

To view the Tivoli Dynamic Workload Console System Requirements, go to the TDWC System Requirements page.

To access the Tivoli Workload Scheduler documentation, see the online Information Center


Top

Topics:

Acronyms and abbreviations used in the tables in this section

The following acronyms and abbreviations are used in the tables on this page:

BDDM Tivoli Workload Scheduler backup dynamic domain manager
BKM Tivoli Workload Scheduler backup master domain manager
CLI Command-line Client
CONN Tivoli Workload Scheduler Connector
DA Dynamic agent
DDM Tivoli Workload Scheduler dynamic domain manager
DM Tivoli Workload Scheduler domain manager
DWC Dynamic Workload Console
FP Fix Pack
FTA Tivoli Workload Scheduler fault-tolerant agent
MDM Tivoli Workload Scheduler master domain manager
SDK Eclipse-based Integration Workbench
TWS Tivoli Workload Scheduler
TWS for z/OS Agent Tivoli Workload Scheduler for z/OS Agent
WAS WebSphere Application Server

Supported operating systems for engine

For a complete list of supported operating systems, perform the following actions to produce a dynamic report:

  1. Go to the web page: http://publib.boulder.ibm.com/infocenter/prodguid/v1r0/clarity/index.html.
  2. Click the "Operating systems for a specific product" report.
  3. In the windows "Operating systems for a specific product", fill in the field Enter a full or partial product name with the value IBM Tivoli Workload Scheduler and click Search.
  4. In the Select version drop-down list, select the version (9.2) and click Submit to run the report.
  5. Table 2: Supported platforms

    Supported versions for the prerequisite database

    Tivoli Workload Scheduler requires the use of either the DB2® or the Oracle relational database. The supported versions are as follows:

    DB2
    Tivoli Workload Scheduler requires one of the following version:
    • DB2 10.1 Enterprise Server Edition
    • DB2 10.5 Enterprise Server Edition

    For more information about the DB2 software requirements, see the following DB2 documentation:

    The support for DB2 version 9.7 is continued only for the completion of the upgrade of Tivoli Workload Scheduler from version 8.5.x. After the upgrade is completed, the database must be upgraded or migrated to a supported level.

    Bundled DB2
    Tivoli Workload Scheduler is supplied with a version of the DB2 server and client for the supported operating systems. This version can be installed by you separately before the product installation.

    Note:The bundled version of DB2 is provided solely for use with Tivoli Workload Scheduler (see the product license for details).

    Oracle
    Tivoli Workload Scheduler requires the use of the following versions of Oracle, with or without the partitioning option installed (using Oracle without the partitioning option affects the event driven workload scheduling performance):
    • Oracle Database 11g Release 1 and Release 2 - Standard Edition (11.2.0.x) or later. This version does not support the partitioning feature.
    • Oracle Database 11g Release 1 and Release 2 - Enterprise Edition (11.2.0.x) or later.

    The Oracle database software is not supplied with Tivoli Workload Scheduler; you must use your own version of the Oracle database software. For a complete list of supported operating systems for Oracle see the Oracle documentation.

    Notes: The only supported type of Oracle Database Client is the Administrator client.

    Database considerations when upgrading
    When upgrading your database to version 9.2, if you have a heavy workload running in your environment, you might have to review the database node configuration and tuning. To avoid performance issues, refer to the IBM Tivoli Workload Scheduler V 9.1 Capacity Planning Guide. The recommendations in this document also appy to V9.2 of the product.

    Topics:

    Software requirements for Tivoli Workload Scheduler

    HP-UX on Itanium requires the following:

    • PHSS_34441 1.0 aC++ Runtime (IA: A.06.10, PA: A.03.70)

    The following libraries are required on Linux:

    • libstdc++.so.5
    • libstdc++.so.6
    • libgcc_s.so.1
    Note:
    On LINUX operating systems, you only need to check for the 32-bit libraries. On 64-bit machines if 32-bit libraries are installed then by default the 64-bit libs are also there.

    On AIX version 6.1 the minimum required operating system level is 6100-06-05-1115.

    On IBM i systems the JDK V1.7 must be installed in the /QOpenSys/QIBM/ProdData/JavaVM/jdk70/32bit/jre directory.

    Software requirements for the WebSphere Application Server

    WebSphere Application Server is no longer embedded and must be installed separately. An eImage for WebSphere Application server is provided with Tivoli Workload Scheduler, but it must be used solely with Tivoli Workload Scheduler. See the Downloadable files page for details about the WebSphere Application Server installation files. The supported version of WebSphere Application Server is V8.5.0.1 and later fixpacks. After the Tivoli Workload Scheduler V9.2 installation phase, also the WebSphere Application Server V8.5.5.0 is supported. Refer to the System Requirements for WebSphere Application Server v8.5 page for details.

    Software requirements for the Launchpad

    The Tivoli Workload Automation Launchpad is supported on all operating systems where Tivoli Workload Scheduler components can be installed.

    If you use the launchpad, it requires a supported Web browser to be launched. Alternatively, you can always install the product by using the installation wizard or the silent installation.

    For the launchpad, use one of the following browsers:

    • Firefox 2.0+
    • Internet Explorer 6.0+
    • Mozilla 1.7+
    • SeaMonkey 1.1.4+

    These browsers are not all available on all platforms; some of them might only be available in a special version from the manufacturer of your operating system. See Table 1 for details:

    Table 1: Launchpad browsers

    Operating system
    Supported browsers
    Download Websites and other information
    AIX

    Firefox, Mozilla, and SeaMonkey

    Web browsers for AIX

    SeaMonkey Download & Releases

    On AIX 6.1 if Firefox is installed you must run the launchpad from within a bash shell, whether you are running the launchpad on Firefox or Mozilla. However, if SeaMonkey is also installed, the bash shell is not required to use any browser.

    HP-UX

    Firefox and Mozilla

    HP-UX website - then search for: "Java Technology Software on HP-UX"

    Linux

    Firefox, Mozilla, and SeaMonkey

    Firefox and Thunderbird

    SeaMonkey Download & Releases

    Solaris

    Firefox, Mozilla, and SeaMonkey

    Sun freeware website or search the Internet

    SeaMonkey Download & Releases

    If Firefox is installed, you must run the launchpad from within a bash shell, whether you are running the launchpad on Firefox or Mozilla. However, if SeaMonkey is also installed, the bash shell is not required to use any browser.

    Windows

    Internet Explorer, Firefox, Mozilla, and SeaMonkey

    Windows Internet Explorer

    Firefox and Thunderbird

    SeaMonkey Download & Releases

    Notes
    1. This information, plus other information about how to launch the launchpad, is provided, platform by platform, in a readme.txt file in the root of the Launchpad directory on each DVD or electronic download image. However, this document contains more up-to-date information than the readme files.

    Supported operating systems and software requirements for the Integration Workbench

    The Tivoli Workload Scheduler Integration Workbench is available on the following platforms:

    • Linux on x86-64
    • Microsoft Windows on x86-64

    It requires Eclipse, version 4.2.2

    The version of the Java Development Kit used to develop all application programming interfaces and plug-ins is 1.7.

    Supported operating systems and software requirements for Job Brokering Definition Console

    The Tivoli Workload Scheduler Job Brokering Definition Console is available on the following platforms:

    • Linux on x86-64
    • Microsoft Windows on x86-64

    Supported LDAP Servers

    For a list of the LDAP servers supported by Tivoli Workload Scheduler, go to the Supported Software for WebSphere Application Server website, click the appropriate MDM/DWC platform link and read the LDAP servers using Federated Repository Configuration section.

    Support for Internet Protocol version 6

    Tivoli Workload Scheduler supports Internet Protocol version 6 (IPv6) in addition to IPv4. To help you in the transition from an IPv4 environment to a complete IPv6 environment, Tivoli Workload Scheduler provides IP dual-stack support. The product communicates using both IPv4 and IPv6 protocols simultaneously with other applications using IPv4 or IPv6.


    Topics:

    Permanent disk space requirements when installing the product

    Table 2: Disk space requirements (MB) summarizes the minimum disk space requirements when installing the Tivoli Workload Scheduler components and features on supported operating systems.

    Table 2: Disk space requirements (MB)
    Operating system MDM or BKM or
    DDM or BDDM
    Dynamic agent
    or
    z-centric agent
    Fault-tolerant agent
     
    CLI
     
    WAS
     
    AIX 2500 105 269 132 1700
    HP-UX 2000 148 336 197 4740
    Linux PPC 1200 215 215 90 1950
    Linux 390 2000 215 215 90 3600
    Linux 1100 215 215 90 2050
    Solaris Opteron 2000 265 265 109 1930
    Solaris SPARC 1200 265 265 109 2250
    Windows 2000 81 270 152 1780
    IBM iSeries   30      

     

     

    Notes:
    1. Space for RDBMS: These disk space requirements do not include the space required for the RDBMS software you have chosen, details of which can be obtained from their support documentation.

      Nor do they include the additional space requirement for the base support of Tivoli Workload Scheduler (without scheduling data), which is 250 MB, divided as follows:

      DB2
      • 200 megabytes in the DB2 installation path
      • 30 megabytes in the data tablespace path
      • 20 megabytes in the reports tablespace path
      Oracle
      • 30 megabytes in the data tablespace path
      • 20 megabytes in the reports tablespace path
    2. Space requirements for operating Tivoli Workload Scheduler: Table 2 does not include the space required to operate Tivoli Workload Scheduler. For this you must consider the additional space required for the following:
      • Database data
      • Symphony file
      • Archive files (and their retention period)
      • Log files (and their retention period)
      • Temporary files that are placed on the local hard drive
      • Files associated with the jobs managed by Tivoli Workload Scheduler

      The space required is very subjective and depends on how you use Tivoli Workload Scheduler. If you are already a user of the product, you will have an idea of how much space it currently occupies. However, you should bear in mind that each version of the system uses more disk space than the previous one. If you are a new user you will probably set up a test system to help you grow familiar with the product and you should be able to scale up the operating space requirements of the test system to give you an indication of how much space you will be using in a fully functional live system.

    Temporary space requirements

    Table 2 does not include the space requirements for the temporary installation files. These depend on the component you are installing, and are given in Table 3: Temporary disk space (MB)

    Table 3: Temporary disk space (MB)
    Operating system MDM or BKM or
    DDM or BDDM
    Dynamic agent
    or
    z-centric agent
    Fault-tolerant agent
     
    CLI
     
    AIX 1750 40 40 40
    HP-UX 1000 40 40 40
    Linux PPC 1000 40 40 40
    Linux 390 1000 40 40 40
    Linux 800 40 40 40
    Solaris Opteron 1000 40 40 40
    Solaris SPARC 1800 40 40 40
    Windows 1000 40 40 40
    IBM iSeries   30    

    Virtual memory swap space requirements

    Table 3 does not include the requirements for the virtual memory file (sometimes called page file or swap space). Tivoli Workload Scheduler requires a minimum of 1.5 GB of virtual memory swap space (recommended level is 2 GB) on the file system of any operating system.

    Memory requirements

    Table 4: Memory (MB) summarizes the memory requirements for the various components, on all operating systems:

    Table 4: Memory (MB)
    Memory MDM or BKM or
    DDM or BDDM
    Dynamic agent
    or
    z-centric agent
    Fault-tolerant agent
    CLI
    Recommended 2560 512 1024 512
    Required 2048 512 512 512

    Memory requirements for Installation Manager

    Tivoli Workload Scheduler and its components are installed using IBM Installation Manager. Table 5: Memory Requirements to run the Installation Manager (MB) summarizes the memory requirements indicated for running the Installation Manager in interactive or in silent mode.

    Table 5: Memory Requirements to run the Installation Manager (MB)
    Operating system Physical memory Temporary space
    Windows 512 10
    Solaris 512 10
    Linux 512 10
    AIX 1024 10

    Note:

    • To run the Installation Manager GUI on Red Hat Enterprise Linux Server 6 (64-bit), the following operating system libraries are required:
      • libXtst+
      • compat-libstdc+
    • To run the Installation Manager GUI on AIX, ensure that the operating system has the required operating system libraries listed in the Required gtk libraries for Installation Manager on AIX


    Top

    © Copyright International Business Machines Corporation 1991, 2013. All rights reserved. US Government Users Restricted Rights – Use, duplication or disclosure restricted by GSA ADP Schedule Contract with IBM Corp.


Original publication date

2014/1/16

Document information

More support for: IBM Workload Scheduler

Software version: 9.2

Operating system(s): AIX, HP-UX, IBM i, Linux, Platform Independent, Solaris, Windows

Reference #: 7041009

Modified date: 28 February 2014