IBM Support

Detailed system requirements for Tivoli Dynamic Workload Console, version 8.5

Product documentation


Abstract

This document details the system requirements for IBM Tivoli Dynamic Workload Console, version 8.5.

Content

This document provides details of the system requirements for Tivoli Dynamic Workload Console on all supported operating systems.

The topics included are:

To download the Tivoli Dynamic Workload Console electronic images go to the Tivoli Dynamic Workload Console download page.

To view the Release Notes, go to the Release Notes page.

To access the Tivoli Workload Scheduler documentation, see the online Information Center


Supported operating systems

Top

This section lists the operating systems supported at the time of the general availability of the product. To see an up-to-date list of the supported operating systems that were certified after the general availability, use the following link: http://www.ibm.com/software/sysmgmt/products/support/Tivoli_Supported_Platforms.html

The section contains the following topics:

Supported operating systems

Table 2 identifies the operating systems that are supported by the console (where the support is not full, details are supplied in the notes).

Table 2: Supported platforms
Operating Systems Tivoli Dynamic Workload Console
IBM AIX™ 5L  
     Versions 5.3, 6.1 X
HP-UX  
  Version 11i v2 Itanium® X
Version 11i v2 PA-RISC X
Version 11i v3 Itanium X
Version 11i v3 PA-RISC X
Microsoft® Windows®  
  Server 2003: Standard, Enterprise, and Data Center X
Server 2003: Standard and Enterprise for AMD64 and EMT64T Kernel 64 X
Server 2008: Standard, Enterprise, and Data Center X
Server 2008: Standard, Enterprise, and Data Center for AMD64 and EMT64T Kernel 64 X
Red Hat Enterprise Linux 4.0 (see note 1)  
  System x and eSeries (AMD64 and EM64T) Kernel 32 X
System x (AMD64 and EM64T) Kernel 64 X
System i™ Kernel 64 X
System p Kernel 64 X
System z™ Kernel 64 X
Red Hat Enterprise Linux 5.0 (see note 1)  
  System x and eSeries (AMD64 and EM64T) Kernel 32 X
System x (AMD64 and EM64T) Kernel 64 X
System i Kernel 64 X
System p Kernel 64 X
System z Kernel 64 X
Solaris Operating Environment  
  Version 9 X
Version 10 X
Version 10 AMD (Opteron) X
SUSE Linux Enterprise Server 9 and 10 (see note 1)  
  System x (IA32) and eSeries (AMD64 and EM64T) Kernel 32 X
System i, Kernel 64 X
System z, Kernel 64 X
System p, Kernel 64 X

Note:

  1. InstallShield installation on Linux operating systems needs the bc utility to be installed. For further information see http://community.installshield.com/archive.

Supported operating systems for the bundled application server

Tivoli Dynamic Workload Console installs, or upgrades to, the embedded version of IBM WebSphere™ Application Server, V6.1 with Fix Pack FP0000019, on the Integrated Solutions Console V7.1.0.6. All operating systems supported by Tivoli Dynamic Workload Console are supported by the application server. It is installed automatically. In the information relating to hardware and memory requirements in this document, the application server is treated as part of Tivoli Dynamic Workload Console, and its requirements are not listed separately.

Note:
The embedded WebSphere Application Server is provided solely for use with Tivoli Dynamic Workload Console (see the product license for details). This version has no limit on the number of CPUs on which it can be installed.

Topics:

Software requirements for Tivoli Dynamic Workload Console

Table 3 lists the software requirements for each supported operating system.

Table 3: Console software requirements
Minimum required patch level Additional prerequisites
IBM AIX  
  5L 5.3 with Service Pack 5300-04-01  
      6.1  
HP-UX PA-RISC  
  11i v2 (11.23) with Standard Patch Bundles of March 2006 and September 2004 Bundle 11i

The following patches:

  • PHNE_35351
  • PHNE_35765
11i v3 (11.31)
HP-UX Itanium (HPIA64)  
  11i v2 (11.23) with Standard Patch Bundles of March 2006 and September 2004 Bundle 11i + Java™ patches PHCO_30476 and PHSS_34201 (64 bit kernel support)

The following patches:

  • PHNE_35351
  • PHNE_35765
11i v3 (11.31)
Linux IA32  
  Red Hat Enterprise Linux AS, version 4 with Update 2

For all Linux IA32 operating systems:

  • libstdc++.so.5
  • libgcc_s.so.1
  • libstdc++-libc6.1-2.so.3 (or a soft link to libstdc++-libc6.2-2.so.3)

For Red Hat Enterprise Linux, version 5, to run the graphical installation wizard:

  • libXp.so.6
  • libXmu.so.6
Red Hat Enterprise Linux ES, version 4 with Update 2
Red Hat Enterprise Linux, version 5
SUSE Linux Enterprise Server, version 9 with SP2 or 3
SUSE Linux Enterprise Server, version 10
Linux X86_64  
  Red Hat Enterprise Linux AS, version 4 with Update 2

For all Linux X86_64 operating systems:

  • libstdc++.so.5
  • libgcc_s.so.1
  • libstdc++-libc6.1-2.so.3 (or a soft link to libstdc++-libc6.2-2.so.3) (linux 32 and 64 bit kernel support)

For Red Hat Enterprise Linux, version 5 (32 and 64 bit kernel support) to run the graphical installation wizard::

  • libXp.so.6
  • libXmu.so.6
Red Hat Enterprise Linux ES, version 4 with Update 2
Red Hat Enterprise Linux, version 5
SUSE Linux Enterprise Server, version 9 with SP2 or 3
SUSE Linux Enterprise Server, version 10
Linux System z  
  Red Hat Enterprise Linux AS, version 4 with Update 2

For all Linux System z operating systems:

  • libstdc++.so.5
  • libgcc_s.so.1
  • libstdc++-libc6.1-2.so.3 (or a soft link to libstdc++-libc6.2-2.so.3). (32 and 64 bit kernel support)

For Red Hat Enterprise Linux, version 5 to run the graphical installation wizard::

  • libXp.so.6
  • libXmu.so.6
Red Hat Enterprise Linux, version 5
SUSE Linux Enterprise Server, version 9 with SP2 or 3
SUSE Linux Enterprise Server, version 10
Linux PPC  
  Red Hat Enterprise Linux AS, version 4 with Update 2

For all Linux PPC operating systems:

  • libstdc++.so.5
  • libgcc_s.so.1
  • libstdc++-libc6.1-2.so.3 (or a soft link to libstdc++-libc6.2-2.so.3). (32 and 64 bit kernel support)

For Red Hat Enterprise Linux, version 5 (32 and 64 bit kernel support) to run the graphical installation wizard::

  • libXp.so.6
  • libXmu.so.6
Red Hat Enterprise Linux, version 5
SUSE Linux Enterprise Server, version 9 with SP2 or 3
SUSE Linux Enterprise Server, version 10
Linux System i  
  Red Hat Enterprise Linux AS, version 4 with Update 2

For all Linux System i operating systems:

  • libstdc++.so.5
  • libgcc_s.so.1
  • libstdc++-libc6.1-2.so.3 (or a soft link to libstdc++-libc6.2-2.so.3). (linux 32 and 64 bit kernel support)
Red Hat Enterprise Linux, version 5
SUSE Linux Enterprise Server, version 9 with SP2 or 3
SUSE Linux Enterprise Server, version 10
Sun Solaris SPARC  
  Sun Solaris operating environment, version 9 with the latest Patch Cluster None
Sun Solaris operating environment, version 10 AMD (Opteron) with the latest Patch Cluster
Sun Solaris x64  
  Sun Solaris operating environment, version 10 AMD (Opteron) with the latest Patch Cluster Patch 119964-05
Microsoft Windows  
  Server 2003, Datacenter with SP1 None
Server 2003, Enterprise with SP1
Server 2003, Standard with SP1
Server 2008, Datacenter with SP1
Server 2008, Enterprise with SP1
Server 2008, Standard with SP1
Vista Enterprise
Microsoft Windows x86_64  
  Server 2003 x64 Editions Service Pack 2
Server 2008 x64 Editions
Vista Enterprise x64 Editions

Software requirements for the bundled version of the embedded WebSphere Application Server

The software requirements for the bundled version of the embedded WebSphere Application Server are included in the requirements for the Tivoli Dynamic Workload Console on or with which it is installed.

System requirements for an external WebSphere Application Server

IBM WebSphere™ Application Server, V6.1 Base version with Fix Pack FP0000019 and fixes IFPK70813, IFPK72743, and SDK IFPK53569 installed plus Integrated Solutions Console v7.1 or higher (Tivoli Dynamic Workload Console will leverage Integrated Solution Console to version 7.1.0.6 if version is lower than this).

Software requirements for the Launchpad

The Tivoli Workload Automation Launchpad is supported on all operating systems where Tivoli Workload Scheduler components can be installed.

It requires a supported Web browser. Use one of the following:

  • Firefox 2.0
  • Internet Explorer 6.0
  • Mozilla 1.7
  • SeaMonkey 1.1.4

These browsers are not all available on all platforms. Some of them might only be available in a special version from the manufacturer of your operating system. See Table 4 for details:

Table 4: Launchpad browsers

Operating system
Supported browsers
Download Websites and other information
AIX

Firefox, Mozilla, and SeaMonkey

Web browsers for AIX

SeaMonkey Download & Releases

On AIX 5.3, at ML7 or later, if Firefox is installed you must run the launchpad from within a bash shell, whether you are running the launchpad on Firefox or Mozilla. However, if SeaMonkey is also installed the bash shell is not required to use any browser.

HP-UX

Firefox and Mozilla

HP-UX Web site - then search for: "Java Technology Software on HP-UX"

Linux

Firefox, Mozilla, and SeaMonkey

Firefox and Thunderbird

SeaMonkey Download & Releases

Solaris

Firefox and Mozilla

Sun freeware Web site or search the Internet

SeaMonkey Download & Releases

Windows

Internet Explorer, Firefox, Mozilla, and SeaMonkey

Windows Internet Explorer

Firefox and Thunderbird

SeaMonkey Download & Releases

Notes
  1. This information, plus other information about how to launch the launchpad, is provided, platform by platform, in a readme.txt file in the root of the Launchpad directory on each DVD or electronic download image. However, this document contains more up-to-date information than the readme files.
  2. To resolve a problem on Firefox and Mozilla with the display of tooltips, obtain and install the "Long Titles" add-on from: Firefox add-ons: Long Titles 1.3.
  3. The links to the Web sites indicated here are provided as a courtesy. They were correct when this document was published, but IBM cannot be held responsible if they change address or content, or are removed.
  4. Browsers at a later level might run the Launchpad correctly, but have not been tested. This means, for example, that you might prefer to disable the update of Firefox V2.0 to V3.0, which is, by default, automatic on some platforms, because Firefox 3.0 is not explicitly supported..

Supported LDAP Servers

The following is a list of the LDAP servers supported by Tivoli Dynamic Workload Console:

  • IBM Tivoli Directory Server 5.1, 5.2, or 6.0
  • IBM z/OS® Security Server 1.4, 1.5, or 1.6
  • IBM z/OS.e Security Server 1.4, 1.5, or 1.6
  • Windows Active Directory 2003
  • Sun ONE DS

Support for Internet Protocol version 6

Tivoli Dynamic Workload Console supports Internet Protocol version 6 (IPv6) in addition to IPv4. To help you in the transition from an IPv4 environment to a complete IPv6 environment, Tivoli Workload Scheduler provides IP dual-stack support. The product communicates using both IPv4 and IPv6 protocols simultaneously with other applications using IPv4 or IPv6.

Supported Browsers

Tivoli Dynamic Workload Console 8.5 requires a supported Web browser. Use one of the following:

  • Firefox 2.0
  • Internet Explorer 6.0 FP2
  • Internet Explorer 7.0

Topics:

Permanent disk space requirements

Table 5 summarizes the minimum disk space requirements of the Tivoli Dynamic Workload Console on supported operating systems.

Table 5: Disk space (MB)
Operating system Tivoli Dynamic Workload Console
(see note 1)
AIX 1030
HP-UX 1080
Linux 1050
Solaris 1090
Windows 1030

Note:

  1. Space for integrated installation: A Tivoli Workload Scheduler component and the Tivoli Dynamic Workload Console can be installed together in an integrated installation where they share, among other things, an instance of the embedded WebSphere Application Server. This integrated installation is called a Tivoli Workload Automation instance.

    The values indicated in Table 5 are for the installation of a Tivoli Dynamic Workload Console not integrated with the Tivoli Workload Scheduler, and include the instance of the embedded WebSphere Application Server.

  2. The corresponding values for the installation of the Tivoli Dynamic Workload Console integrated with the Tivoli Workload Scheduler or on an external WebSphere Application Server are shown in Table 6, which indicates the disk space required by the Tivoli Dynamic Workload Console, not including the disk space required by WebSphere Application Server.

    Table 6: Disk space (MB) required for integrated installation of a Tivoli Workload Scheduler and the Tivoli Dynamic Workload Console
    Operating system Tivoli Dynamic Workload Console (not including WebSphere Application Server required space)
    AIX 720
    HP-UX 720
    Linux 720
    Solaris 720
    Windows 720

    Note that the values indicated in the above table show the disk space required by the Tivoli Dynamic Workload Console alone. For the disk space required by WebSphere Application Server or by Tivoli Workload Scheduler, refer to the relevant documentation.

Temporary space requirements

Table 5 and Table 6 do not include the space requirements for the temporary installation files. These depend on the component you are installing, and are given in Table 7:

Table 7: Temporary disk space
Operating system Tivoli Dynamic Workload Console
AIX 325
HP-UX 325
Linux 325 + 75 MB in /var/tmp
Solaris 325 + 75 MB in /var/tmp
Windows 325

Virtual memory swap space requirements

Previous tables do not include the requirements for the virtual memory file (sometimes called page file or swap space). Tivoli Dynamic Workload Console requires a minimum of 1 GB of virtual memory swap space (recommended level is 2 GB) on the file system of any operating system.

Memory requirements

Table 8 summarizes the memory requirements for the various components, on all operating systems:

Table 8: Memory
Memory Tivoli Dinamic Workload Console with embedded or external WebSphere Application Server
Tivoli Dinamic Workload Console integrated with Master Domain Manager or Backup manager. (see Note) Tivoli Dinamic Workload Console integrated with Connector (see note Note)
Recommended 1536 2048 1536
Required 1024 1024 1024

Note: The memory requirements indicated in these columns includes Tivoli Workload Scheduler memory requirements.

Top

© Copyright International Business Machines Corporation 1991, 2008. All rights reserved. US Government Users Restricted Rights – Use, duplication or disclosure restricted by GSA ADP Schedule Contract with IBM Corp.

Original publication date

2008/12/12

Document information

More support for: IBM Workload Scheduler
Tivoli Dynamic Workload Console

Software version: 8.5

Operating system(s): AIX, HP-UX, Linux, Solaris, Windows

Reference #: 7012176

Modified date: 11 March 2009


Translate this page: