IBM Support

Microsoft Windows Client Requirements

Troubleshooting


Problem

Hardware and Software Requirements for IBM Spectrum Protect™ Windows Backup-Archive and API Client

Cause

Tip: The product now known as IBM Spectrum Protect™ was named IBM Tivoli® Storage Manager in releases earlier than Version 7.1.3. To learn more about the rebranding transition, see  technote 1963634.
 

Overview of IBM Spectrum Protect™ Client and Server supported operating systems and platforms:   http://www.ibm.com/support/docview.wss?uid=swg21243309
Overview of IBM Tivoli Storage Manager Client and Server supported operating systems and platforms:  http://www.ibm.com/support/docview.wss?uid=swg21994042
 

Latest Client and Server downloads:   http://www.ibm.com/support/docview.wss?uid=swg21239415
 

Resolving The Problem


Hardware and Software Requirements

Version 8.1
Version 7.1
 


Version 8.1

Hardware
Operating System
Communication Protocol

System:
x64: An AMD64 or EM64T processor or multi-processor based computer
 

Disk Space:
1.5 GB disk space is required to install the client
Note: using the web user interface requires minimum 4,4 GB disc space (preferred 9 GB disc space)

Memory:
128 MB RAM is required to install the client
Note: using the web user interface requires minimum 4 GB RAM (preferred 8 GB RAM)

Backup/Archive client (including Web client) and API client require one of the following:

  • Windows Server 2012 and Windows Server 2012 Server Core, all editions all SPs supported1

  • Windows Server 2012 R2 and Windows Server 2012 R2 Server Core, all editions, all SPs supported2

  • Windows 2016 Server and Windows Server 2016 Server Core, all editions(*),3

  • Windows 2019 Server and Windows Server 2019 Server Core, all editions(*),4
    (Beginning with backup-archive client v8.1.7)

  • Windows 8.1, all editions, all SPs supported 5

  • Windows 10, all editions except Mobile(*)

(*) only Long-Term Servicing Channel (LTSC) product's are supported

One for the following, which are included in the base Windows product packages:

  • TCP/IP (the only one used for Web client)

  • Named Pipes (used in conjunction with IBM Spectrum Protect server running on same Windows machine)

Shared Memory (used in conjunction with IBM Spectrum Protect server running on same Windows machine)

Additional Software:

  • For information on which IBM Spectrum Protect client functions are supported on which hardware, see Function table

  • The Web client requires Java: JRE 7 or JRE 8

    Note:

    • In backup-archive client Version 8.1.0 web client is supported when running in Microsoft Internet Explorer, Mozilla Firefox, Microsoft Edge, Google Chrome browsers.

    • In backup-archive client Version 8.1.2-8.1.6.x,  you can no longer use the web client to connect to the IBM Spectrum Protect V8.1.2 or later V8 server or the V7.1.8 or later V7 server.
      For more information, see Using the web client in the new security environment .

    • Beginning with IBM Spectrum Protect™ Version 8.1.7,  a new web user interface for file-restore operations is supported. This web user interface is supported only on windows server operating systems, and when running in Mozilla Firefox, Microsoft Edge, or Google Chrome browsers. The web user interface must connect to the IBM Spectrum Protect V8.1.2 or later V8 server or the V7.1.8 or later V7 server. For more information see:  8.1.7 backup-archive client New features and updates

  • Automated System Recovery (ASR) for EFI and non-EFI systems

  • Support for Microsoft Hyper-V is documented in IBM Spectrum Protect™ support for Microsoft Hyper-V technote

  • Supported levels for NetApp Data ONTAP: http://www.ibm.com/support/docview.wss?uid=swg21474217
     

1 Note on Windows 2012:

  • IBM Spectrum Protect Backup Archive client for Windows provides support for Windows Storage Server 2012 for functionality that is also available and supported by IBM Spectrum Protect on the Windows Server 2012 Editions.

2 Note on Windows 2012 R2:

  • IBM Spectrum Protect Backup Archive client for Windows provides support for Windows Storage Server 2012 R2 Editions for functionality that is also available and supported by IBM Spectrum Protect on the Windows Server 2012 R2 Editions.

  • The following are known issues with Windows Server 2012 R2:
    To perform an application-consistent backup or restore by using Work Folders in Windows Server 2012 R2, apply the Microsoft hotfix for knowledge base article 2909185. See details at http://support.microsoft.com/kb/2909185 .

3 Note on Windows 2016:

  • IBM Spectrum Protect Backup Archive client for Windows provides support for Windows Storage Server 2016 for functionality that is also available and supported by IBM Spectrum Protect on the Windows Server 2016 Editions.

4 Note on Windows 2019:

  • IBM Spectrum Protect Backup Archive client for Windows provides support for Windows Storage Server 2019 for functionality that is also available and supported by IBM Spectrum Protect on the Windows Server 2019 Editions.

5 Note on Windows 8.1:

  • The following are known issues with Windows 8.1:
    Backups of the new Placeholder files in Windows 8.1 will not handle the new reparse tag information correctly, causing it to be backed up and restored.


 


Version 7.1

Hardware
Operating System
Communication Protocol

System:
32-bit: An x32 or compatible processor, or multi-processor based computer
x64: An AMD64 or EM64T processor or multi-processor based computer
 

Disk Space:
1.5 GB disk space is required to install the client
 

Memory:
128 MB RAM is required to install the client

Backup/Archive client (including Web client) and API client require one of the following:

  • Windows 2008 Server and Windows 2008 Server Core, all editions, all SPs supported

  • Windows Server 2008 R2 and Windows Server 2008 R2 Server Core, all editions, all SPs supported

  • Windows 2012 Server and Windows Server 2012 Server Core, all editions and SPs supported1

  • Windows Server 2012 R2 and Windows Server 2012 R2 Server Core, all editions, all SPs supported 2

  • Windows 2016 Server and Windows Server 2016 Server Core, all editions(*),3
    (beginning with v7.1.8)

  • Windows 7, all editions, all SPs supported

  • Windows 8, all editions, all SPs supported

  • Windows 8.1, all editions, all SPs supported4

  • Windows 10, all editions except Mobile(*)
    (beginning with v7.1.3.2)

(*) only Long-Term Servicing Channel (LTSC) product's are supported

One for the following, which are included in the base Windows product packages:

  • TCP/IP (the only one used for Web client)

  • Named Pipes (used in conjunction with IBM Spectrum Protect server running on same Windows machine)

Shared Memory (used in conjunction with IBM Spectrum Protect server running on same Windows machine)

Additional Software:

  • For information on which IBM Spectrum Protect client functions are supported on which hardware, see Function table

  • The Web client requires:

    • prior to 7.1.2.1: the Java plugin that is included in JRE 7

    • beginning with 7.1.2.1: Java plugin that is included in JRE 7 or JRE 8
      Note: The client is supported when running in Microsoft Internet Explorer, Mozilla Firefox or Google Chrome browsers with the required plugin.

  • Only 64-bit clients can be run on 64-bit machines.

  • Automated System Recovery (ASR) for EFI and non-EFI systems

  • Supported for Microsoft Hyper-V is documented in this IBM Technote

  • Supported levels for NetApp Data ONTAP: http://www.ibm.com/support/docview.wss?uid=swg21474217

  • Virtual Machine backups initiated by the Data Protection for VMware product are only supported on Windows 2008, 64-bit and Windows Server 2012. (Backup in a guest VM is supported for all listed Windows versions)

  • The following GPFS versions are supported:

    • GPFS 3.5.0 or higher fix pack levels

    • GPFS 4.1.0.10 (TL1) or higher fix pack levels (beginning with backup-archive client 7.1.2)

    • GPFS 4.1.1 or higher fix pack levels (beginning with backup-archive client 7.1.3)

    • GPFS 4.2.0 or higher fix pack levels (beginning with backup-archive client 7.1.4.4)

    • GPFS 4.2.1 or higher fix pack levels (beginning with backup-archive client 7.1.6)
       

1 Note on Windows 2012:

  • IBM Spectrum Protect Backup Archive client for Windows provides support for Windows Storage Server 2012 for functionality that is also available and supported by IBM Spectrum Protect on the Windows Server 2012 Editions.

2 Note on Windows 2012 R2:

  • IBM Spectrum Protect Backup Archive client for Windows provides support for Windows Storage Server 2012 R2 Editions for functionality that is also available and supported by IBM Spectrum Protect on the Windows Server 2012 R2 Editions.

  • The following are known issues with Windows Server 2012 R2:
    To perform an application-consistent backup or restore by using Work Folders in Windows Server 2012 R2, apply the Microsoft hotfix for knowledge base article 2909185. See details at http://support.microsoft.com/kb/2909185 .

3 Note on Windows 2016:

  • IBM Spectrum Protect Backup Archive client for Windows provides support for Windows Storage Server 2016 for functionality that is also available and supported by IBM Spectrum Protect on the Windows Server 2016 Editions.

4 Note on Windows 8.1:

  • IBM Spectrum Protect Backup Archive client for Windows provides support for Windows 8.1 for functionality that is also available and supported by IBM Spectrum Protect on Windows 8.

  • The following are known issues with Windows 8.1:
    Backups of the new Placeholder files in Windows 8.1 will not handle the new reparse tag information correctly, causing it to be backed up and restored.


Versions past End of Support (EOS)

Version 6.4 is past End of Support (EOS). See the V6.4 Client:
- EOS page: http://www.ibm.com/support/docview.wss?uid=swg22011587
- Requirements web page: http://www.ibm.com/support/docview.wss?uid=swg21998572

Version 6.3 is past End of Support (EOS). See the V6.3 Client:
- EOS page: http://www.ibm.com/support/docview.wss?uid=swg21982265
- Requirements web page: http://www.ibm.com/support/docview.wss?uid=swg21994532

Version 6.2 is past End of Support (EOS). See the V6.2 Client:
- EOS page: http://www.ibm.com/support/docview.wss?uid=swg21671647
- Requirements web page: http://www.ibm.com/support/docview.wss?uid=swg21700847

Version 6.1 is past End of Support (EOS). See the V6.1 Client:
- EOS page: http://www.ibm.com/support/docview.wss?uid=swg21635108
- Requirements web page: http://www.ibm.com/support/docview.wss?uid=swg21700845

Version 5.5 is past End of Support (EOS). See the V5.5 Client:
- EOS page: http://www.ibm.com/support/docview.wss?uid=swg21635108
- Requirements web page: http://www.ibm.com/support/docview.wss?uid=swg21700848
 

NOTE:

  • The LAN-Free client also requires IBM Tivoli Storage Manager for Storage Area Networks (5608-SAN).
     


Client Components Offered

Administrative
Backup/Archive
HSM
API
Command Line Interface
Graphical User Interface
Command Line Interface
Web Browser Interface
Graphical User
Command Line Interface
Interface 
yes
yes
yes
yes
yes

 
 

Related information

Latest client downloads
Overview Spectrum Protect Operating Systems
Overview TSM Operating Systems
HW&SW requirements HSM for Windows
Featured Documents Spectrum Protect

Cross reference information
Product Component Platform Version Edition
Tivoli Storage Manager Client

Document information

More support for: Tivoli Storage Manager