IBM Support

Microsoft Windows Client Requirements

Technote (troubleshooting)


Problem(Abstract)

Hardware and Software Requirements for IBM Spectrum Protect™ Windows Backup-Archive and API Client

Cause

Tip: The product now known as IBM Spectrum Protect™ was named IBM Tivoli® Storage Manager in releases earlier than Version 7.1.3. To learn more about the rebranding transition, see technote 1963634.

Overview of IBM Spectrum Protect™ Client and Server supported operating systems and platforms: http://www.ibm.com/support/docview.wss?uid=swg21243309
Overview of IBM Tivoli Storage Manager Client and Server supported operating systems and platforms: http://www.ibm.com/support/docview.wss?uid=swg21994042

Latest Client and Server downloads: http://www.ibm.com/support/docview.wss?uid=swg21239415


Resolving the problem

Hardware and Software Requirements



Version 8.1
Version 7.1



Version 8.1
Hardware
Operating System
Communication Protocol, Other
System:
x64: An AMD64 or EM64T processor or multi-processor based computer

Disk Space:
1.5 GB disk space is required to install the client

Memory:
128 MB RAM is required to install the client
Backup/Archive client (including Web client) and API client require one of the following:
  • Windows Server 2012 and Windows Server 2012 Server Core, all editions all SPs supported 1
  • Windows Server 2012 R2 and Windows Server 2012 R2 Server Core, all editions, all SPs supported 2
  • Windows 2016 Server and Windows Server 2016 Server Core, all editions 3
  • Windows 8.1, all editions, all SPs supported 4
  • Windows 10, all editions except Mobile
One for the following, which are included in the base Windows product packages:

  • TCP/IP (the only one used for Web client)
  • Named Pipes (used in conjunction with IBM Spectrum Protect server running on same Windows machine)

Shared Memory (used in conjunction with IBM Spectrum Protect server running on same Windows machine)
Notes:
  • For information on which IBM Spectrum Protect client functions are supported on which hardware, see Function table
  • The Web client requires Java: JRE 7 or JRE 8
    Note: The client is supported when running in Microsoft Internet Explorer, Mozilla Firefox, Microsoft Edge, Google Chrome browsers.
  • Automated System Recovery (ASR) for EFI and non-EFI systems
  • Support for Microsoft Hyper-V is documented in this IBM Technote
  • Supported levels for NetApp Data ONTAP:
    http://www.ibm.com/support/docview.wss?uid=swg21474217

1. Note on Windows 2012:

  • IBM Spectrum Protect Backup Archive client for Windows provides support for Windows Storage Server 2012 for functionality that is also available and supported by IBM Spectrum Protect on the Windows Server 2012 Editions.

2. Note on Windows 2012 R2:
  • IBM Spectrum Protect Backup Archive client for Windows provides support for Windows Storage Server 2012 R2 Editions for functionality that is also available and supported by IBM Spectrum Protect on the Windows Server 2012 R2 Editions.
  • The following are known issues with Windows Server 2012 R2:
    To perform an application-consistent backup or restore by using Work Folders in Windows Server 2012 R2, apply the Microsoft hotfix for knowledge base article 2909185. See details at http://support.microsoft.com/kb/2909185.

3. Note on Windows 2016:
  • IBM Spectrum Protect Backup Archive client for Windows provides support for Windows Storage Server 2016 for functionality that is also available and supported by IBM Spectrum Protect on the Windows Server 2016 Editions.

4. Note on Windows 8.1:
  • The following are known issues with Windows 8.1:
    Backups of the new Placeholder files in Windows 8.1 will not handle the new reparse tag information correctly, causing it to be backed up and restored.


Version 7.1
Hardware
Operating System
Communication Protocol, Other
System:
32-bit: An x32 or compatible processor, or multi-processor based computer
x64: An AMD64 or EM64T processor or multi-processor based computer

Disk Space:
1.5 GB disk space is required to install the client

Memory:
128 MB RAM is required to install the client
Backup/Archive client (including Web client) and API client require one of the following:

  • Windows 2008 Server and Windows 2008 Server Core, all editions, all SPs supported
  • Windows Server 2008 R2 and Windows Server 2008 R2 Server Core, all editions, all SPs supported
  • Windows 2012 Server and Windows Server 2012 Server Core, all editions and SPs supported 1
  • Windows Server 2012 R2 and Windows Server 2012 R2 Server Core, all editions, all SPs supported 2
  • Windows 2016 Server and Windows Server 2016 Server Core, all editions 3
    (beginning with v7.1.8)
  • Windows 7, all editions, all SPs supported
  • Windows 8, all editions, all SPs supported
  • Windows 8.1, all editions, all SPs supported 4
  • Windows 10, all editions except Mobile
    (beginning with v7.1.3.2)
One for the following, which are included in the base Windows product packages:

  • TCP/IP (the only one used for Web client)
  • Named Pipes (used in conjunction with IBM Spectrum Protect server running on same Windows machine)

Shared Memory (used in conjunction with IBM Spectrum Protect server running on same Windows machine)
Notes:
  • For information on which IBM Spectrum Protect client functions are supported on which hardware, see Function table
  • The Web client requires:
    • prior to 7.1.2.1: the Java plugin that is included in JRE 7
    • beginning with 7.1.2.1: Java plugin that is included in JRE 7 or JRE 8
      Note: The client is supported when running in Microsoft Internet Explorer, Mozilla Firefox or Google Chrome browsers with the required plugin.
  • Only 64-bit clients can be run on 64-bit machines.
  • Automated System Recovery (ASR) for EFI and non-EFI systems
  • Supported for Microsoft Hyper-V is documented in this IBM Technote
  • Supported levels for NetApp Data ONTAP:http://www.ibm.com/support/docview.wss?uid=swg21474217
  • Virtual Machine backups initiated by the Data Protection for VMware product are only supported on Windows 2008, 64-bit and Windows Server 2012. (Backup in a guest VM is supported for all listed Windows versions)
  • The following GPFS versions are supported:
    • GPFS 3.5.0 or higher fix pack levels
    • GPFS 4.1.0.10 (TL1) or higher fix pack levels (beginning with backup-archive client 7.1.2)
    • GPFS 4.1.1 or higher fix pack levels (beginning with backup-archive client 7.1.3)
    • GPFS 4.2.0 or higher fix pack levels (beginning with backup-archive client 7.1.4.4)
    • GPFS 4.2.1 or higher fix pack levels (beginning with backup-archive client 7.1.6)

1. Note on Windows 2012:
  • IBM Spectrum Protect Backup Archive client for Windows provides support for Windows Storage Server 2012 for functionality that is also available and supported by IBM Spectrum Protect on the Windows Server 2012 Editions.

2. Note on Windows 2012 R2:
  • IBM Spectrum Protect Backup Archive client for Windows provides support for Windows Storage Server 2012 R2 Editions for functionality that is also available and supported by IBM Spectrum Protect on the Windows Server 2012 R2 Editions.
  • The following are known issues with Windows Server 2012 R2:
    To perform an application-consistent backup or restore by using Work Folders in Windows Server 2012 R2, apply the Microsoft hotfix for knowledge base article 2909185. See details at http://support.microsoft.com/kb/2909185.

3. Note on Windows 2016:
  • IBM Spectrum Protect Backup Archive client for Windows provides support for Windows Storage Server 2016 for functionality that is also available and supported by IBM Spectrum Protect on the Windows Server 2016 Editions.

4. Note on Windows 8.1:
  • IBM Spectrum Protect Backup Archive client for Windows provides support for Windows 8.1 for functionality that is also available and supported by IBM Spectrum Protect on Windows 8.
  • The following are known issues with Windows 8.1:
    Backups of the new Placeholder files in Windows 8.1 will not handle the new reparse tag information correctly, causing it to be backed up and restored.





Version 6.4 is past End of Support (EOS). See the V6.4 Client:
Version 6.3 is past End of Support (EOS). See the V6.3 Client:
Version 6.2 is past End of Support (EOS). See the V6.2 Client:
Version 6.1 is past End of Support (EOS). See the V6.1 Client:
Version 5.5 is past End of Support (EOS). See the V5.5 Client:



Note: LAN-free client also requires IBM Tivoli Storage Manager for SAN (5608-SAN)


Administrative
Backup/Archive
HSM
API
Command Line Interface
Graphical User Interface
Command Line Interface
Web Browser Interface
Graphical User Interface
Command Line Interface
Interface 
yes
yes
yes
yes
yes

Related information

Latest client downloads
Overview Spectrum Protect Operating Systems
Overview TSM Operating Systems
HW&SW requirements HSM for Windows
Featured Documents Spectrum Protect


Cross reference information
Segment Product Component Platform Version Edition
Storage Management Tivoli Storage Manager Client

Document information

More support for: Tivoli Storage Manager
Client


Translate this page: