IBM Support

Linux on POWER Client Requirements

Technote (troubleshooting)


Problem(Abstract)

Hardware and Software Requirements for IBM Spectrum Protect™ Linux on POWER Backup-Archive and API Client (formerly known as Linux iSeries/pSeries client)

Cause

Tip: The product now known as IBM Spectrum Protect™ was named IBM Tivoli® Storage Manager in releases earlier than Version 7.1.3. To learn more about the rebranding transition, see technote 1963634.

Overview of IBM Spectrum Protect™ Client and Server supported operating systems and platforms: http://www.ibm.com/support/docview.wss?uid=swg21243309
Overview of IBM Tivoli Storage Manager Client and Server supported operating systems and platforms: http://www.ibm.com/support/docview.wss?uid=swg21994042

Latest Client and Server downloads: http://www.ibm.com/support/docview.wss?uid=swg21239415


Resolving the problem

Hardware and Software Requirements


In the tables below the minimum supported levels are listed. In general, all operating system service pack and maintenance levels are supported. Any exceptions are noted in the tables below.

Version 8.1
Version 7.1

Version 8.1

Hardware
Operating System
Communication Protocol
System:
IBM System p or IBM System i, with POWER processors, as supported by Linux distribution

Disk Space:
500 MB disk space is required to install the client

Memory:
No additional RAM is required for product installation. RAM requirements for running the product vary widely and depend on your environment, configuration, and tasks that you perform. Additional RAM might be required to run the product.
API only Big Endian support
  • SLES 11 (64 bit)
  • RHEL 6 (64 bit)
  • RHEL 7 (64 bit)

API & Backup-Archive Little Endian support
  • SLES 12 (64 bit)
  • RHEL 7 (64-bit)*
  • Ubuntu 14.04 (64 bit)
  • Ubuntu 16.04 (64 bit)
* support started with RHEL 7.1.
  • TCP/IP, which comes standard with Linux
  • Shared Memory (with Linux on Power TSM server only)
Additional Software
  • The Java GUI and Web backup-archive client requires Java: JRE 7 or JRE 8
    Note: The Web client is supported when running in a Mozilla Firefox browser.
  • For EXT2/EXT3/XFS ACL support, you need the acl package.
  • The image backup and restore functions for LVM2 volumes require libdevmapper.so Version 1.01 or higher. If the library is at a lower level than required or it is not available, image backups for LVM2 volumes fail.
    The libdevmapper.so library is distributed with the device mapper packages. On RHEL, the package is called device-mapper-libs and on SLES it is called device-mapper.
  • The following IBM Spectrum Scale versions (previously known as GPFS) are supported on Little Endian:
    IBM Spectrum Scale version Supported on operating systems
    IBM Spectrum Scale 4.2.1 or higher fix pack

    (Beginning with IBM Spectrum Protect™ Client v8.1.0)

    • SLES 12.1 and later service pack and maintenance levels
    • RH 7.1 and later service pack and maintenance levels
    • Ubuntu 14.04.4 and later service pack and maintenance levels
      Note: On Ubuntu 14.04.4 the IBM Spectrum Scale 4.2.1 requires Kernel 4.2.0-27
    BM Spectrum Scale 4.2.1.1 or higher fix pack

    (Beginning with IBM Spectrum Protect™ Client v8.1.0)

    • Ubuntu 16.04 and later service pack and maintenance levels
      Note: On Ubuntu 16.04 the IBM Spectrum Scale 4.2.1.1 requires Kernel 4.4.0-31
    IBM Spectrum Scale 4.2.2 or higher fix pack

    (Beginning with IBM Spectrum Protect™ Client v8.1.0)

    • SLES 12.1 and later service pack and maintenance levels
    • RH 7.1 and later service pack and maintenance levels
    IBM Spectrum Scale 4.2.3 or higher fix pack

    (Beginning with IBM Spectrum Protect™ Client v8.1.2)

    • SLES 12.1 and later service pack and maintenance levels
    • RH 7.1 and later service pack and maintenance levels
    • Ubuntu 14.04.4 and later service pack and maintenance levels
      Note: On Ubuntu 14.04.4 the IBM Spectrum Scale 4.2.3 requires minimum Kernel 4.2.0-27
    • Ubuntu 16.04 and later service pack and maintenance levels
      Note: On Ubuntu 16.04 the IBM Spectrum Scale 4.2.3 requires minimum Kernel 4.4.0-31
    • IBM Spectrum Scale SOBAR is supported, beginning with IBM Spectrum Protect™ Client v8.1.4.
      Note:
      • On IBM Spectrum Scale 4.2.3 you need at least 4.2.3.5 fix pack.
      • Installation of IBM Spectrum Protect Backup-Archive client and IBM Spectrum Protect for Space Management client in the same (matching) release level is required
      • For IBM Spectrum Protect for Space Management client requirements see: http://www.ibm.com/support/docview.wss?uid=swg22009800


    Version 7.1

    Hardware
    Operating System
    Communication Protocol
    System:
    IBM System p or IBM System i, with POWER processors, as supported by Linux distribution

    Disk Space:
    500 MB disk space is required to install the client, and all language packs.

    Memory:
    No additional RAM is required for product installation. RAM requirements for running the product vary widely and depend on your environment, configuration, and tasks that you perform. Additional RAM might be required to run the product.
    Big Endian support
    • SLES 11 (64 bit)
    • RHEL 5 (64 bit)
    • RHEL 6 (64 bit)
    • RHEL 7 (64 bit) (beginning with 7.1.1 client)

    Little Endian support
    • SLES 12 (64 bit)
      (beginning with 7.1.2 API client and 7.1.4 backup-archive client)
    • RHEL 7.1 (64-bit)
      (beginning with 7.1.2 API client and 7.1.4 backup-archive client)
    • Ubuntu 14.04 (64 bit)
      (beginning with 7.1.2 API client and 7.1.4.4 backup-archive client)
    • Ubuntu 16.04 (64 bit)(beginning the with 7.1.6.3 client)

    Note:
    • GPFS file system support on Ubuntu 14.04 (beginning with 7.1.6 client)
    • no GPFS file system support on Ubuntu 16.04
    • TCP/IP, which comes standard with Linux
    • Shared Memory (with Linux on Power TSM server only)
    Additional Software
    • Java GUI and Web backup-archive client require:
      • prior to 7.1.2.1:
        • Java GUI requires Java JRE 7
        • The Web client requires the Java plugin that is included in JRE 7
      • beginning with 7.1.2.1:
        • Java GUI requires Java: JRE 7 or JRE 8
        • The Web client requires the Java plugin that is included in JRE 7 or JRE 8.
      Note: The client is supported when running in a Firefox browser with the required plugin.
    • For EXT2/EXT3/XFS ACL support, you need the acl package.
    • The image backup and restore functions for LVM2 volumes require libdevmapper.so Version 1.01 or higher. If the library is at a lower level than required or it is not available, image backups for LVM2 volumes fail.
      The libdevmapper.so library is distributed with the device mapper packages. On RHEL, the package is called device-mapper-libs and on SLES it is called device-mapper.
    • The following GPFS versions are supported on Big Endian:
      • GPFS 3.5.0 or higher fix pack levels
      • GPFS 4.1.0 or higher fix pack levels (beginning with backup-archive client 7.1.1)
      • GPFS 4.1 TL1 is supported for RHEL 7 (beginning with backup-archive client 7.1.2)
        Note: RHEL 7 requires GPFS 4.1.0.10 (TL1) or higher fix pack levels
      • GPFS 4.1.1 or higher fix pack levels (beginning with backup-archive client 7.1.3)
      • GPFS 4.2.0 or higher fix pack levels (beginning with backup-archive client 7.1.4)
    • The following GPFS versions are supported on Little Endian:
      • GPFS 4.1.1.3 or higher fix pack levels (beginning with backup-archive client 7.1.4)
      • GPFS 4.2.0 or higher fix pack levels (beginning with backup-archive client 7.1.4.4)
      • GPFS 4.2.1 or higher fix pack levels (beginning with backup-archive client 7.1.6)
        Note: Ubuntu 14.04.4 (Kernel 4.2.0.27) requires GPFS 4.2.1 or higher fix pack levels
    • To use the Common Inventory Technology components in a pure 64-bit Linux environment the following 32-bit run-time support packages should be installed:
      • with RHEL 7, the compat-libstdc++-33 package is required.
      • with SLES 12, the libstdc++33-32bit package is required
        (note: this package is provided by SUSE Legacy Module, see https://www.suse.com/products/server/features/modules.html).
      • with Ubuntu 14.04, the libstdc++5:i386 package is required.
    • Journal Based Backup (JBB) is:
      • supported on RHEL 7, in addition to previously supported distributions, beginning with 7.1.2 backup-archive client
      • supported on RHEL 7.1 beginning with 7.1.4 backup- archive client



    Version 6.4 is past End of Support (EOS). See the V6.4 Client:


    Version 6.3 is past End of Support (EOS). See the V6.3 Client:
    Version 6.2 is past End of Support (EOS). See the V6.2 Client: Version 6.1 is past End of Support (EOS). See the V6.1 Client: Version 5.5 is past End of Support (EOS). See the V5.5 Client:


    Note: LAN-free client also requires IBM Tivoli Storage Manager for SAN (5608-SAN)

    Administrative
    Backup/Archive
    HSM
    API
    Command Line Interface
    Graphical User Interface
    Command Line Interface
    Web Browser Interface
    Graphical User Interface
    Command Line Interface
    Interface 
    yes
    yes
    yes
    yes
     
     
    yes

    Related information

    Latest client downloads
    Overview Spectrum Protect Operating Systems
    Overview TSM Operating Systems
    Featured Documents Spectrum Protect

    Cross reference information
    Segment Product Component Platform Version Edition
    Storage Management Tivoli Storage Manager Client

    Document information

    More support for: Tivoli Storage Manager
    Client


    Translate this page: