Troubleshooting
Problem
Tivoli Storage Manager server on Windows can be started successfully in the foreground but it stops immediately when it is attempted to start as service.
Symptom
The server console.log file show the following error :
ANR0226S The database ID file could not be found for server startup.
Cause
Server instance registry entries are incorrect or not set .
Diagnosing The Problem
Set the service console log as instructed in a Technote within URL section and start server service. If ANR0226S is shown, look if following registry entries exist using regedit :
HKEY_LOCAL_MACHINE\SOFTWARE\IBM\ADSM\CurrentVersion\Server.
The serverX entries have no or incorrect path specified.
Resolving The Problem
Change directory to the instance directory where the dsmserv.dbid file resides and run :
"c:\Program Files\Tivoli\TSM\server\dsmserv.exe" -k server1 update
This will create the correct entries.
Adjust the "-k server1" option to your instance name.
Related Information
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Document Information
Modified date:
17 June 2018
UID
swg21621874