Domino for IBM i (i5/OS): What system fixes are required?

Technote (FAQ)


Question

What system fixes are required for an IBM Lotus® Domino® server for i? (the new name for i5/OS®)

Answer

Keeping your server current with the latest fixes helps minimize potential problems. This document contains information about the fixes required for Domino running on IBM i.
IBM recommends that all systems are kept current by installing the latest available:

  • Cumulative PTF Packages
  • Group PTFs
  • Specific PTFs required by Domino


Cumulative PTF Packages

Cumulative PTF packages are the primary method of providing preventive maintenance for IBM i. The Rochester Support Center's Recommended Fixes site provides information on the latest Cumulative PTF packages.


Recommended Group PTFs

Group PTFs are a collections of fixes for a specific functions. To browse current Group PTFs, refer to the Preventive Service Planning - PSP database and select the All Group PTFs by Release view.

The following Group PTFs are recommended to be at the latest level:

  • Java Group PTF
  • DB2/400 Group PTF
  • IBM HTTP Server for i Group PTF
  • BRMS Group PTF

PTFs required by Domino

The following individual PTFs are required for Domino. Some of the PTFs are available in current cumulative PTF packages.

NOTE: The Java product 5761JV1 runs on both IBM i 6.1 and i 7.1. And Java product 5770JV1 runs on IBM i 7.2.

7.2 (V7R2)

Product PTF
Description
Available on
Cumulative
PTF Package
5770-SS1
5770-999
N/A IBM i and Licensed Internal Code (recommended)
CUM Package SF99720 (latest level)
HIPER Group SF99719 Level 20 at least
Database Group SF99702 Level 3 at least
N/A
5770-JV1 SI55241 SI55150 Java SE 7 32 bit JDK70 SR8 N/A
5770-JV1 SI55244 SI55149 Java SE 7 64 bit JDK70 SR8 N/A
In addition to those before, the following PTFs are minimally required for Domino 9.0.1 Java.
5770-JV1 N/A Java Group PTF (latest level)
Java Group SF99716 Level 3 at least
N/A
5770-JV1 SI55047 SI54652 Java SE 6 32 bit JDK60 SR16 FP2 N/A
5770-JV1 SI55046 SI55229 Java SE 6 64 bit JDK60 SR16 FP2 N/A

7.1 (V7R1)

Product PTF
Description
Available on
Cumulative
PTF Package
5770-SS1 SI49001 OSP-OTHER-THREADS-WAIT allow compatible behaviors for LE
MF48664 Required Requisite
C3037710
5770-SS1 SI40760 OSP-INCORROUT QP0LFLOP get link information C1116710
5770-SS1 SI38397 OSP-PERFM QlgLstat64() produces too many page faults (recommended) C0096710
5770-999 MF49028 Licensed Internal Code extensions
(recommended)
C0096710
In addition to those before, following PTFs are minimally required for Domino 9.0.1 Java.
5761-JV1 N/A Java Group PTF (latest level)
Java Group SF99572 Level 14 at least
N/A
5761-JV1 SI50423
SI50387
SI50453
JDK60-32 IBM Technology for Java SR14 C3298710
5761-JV1 SI50415
SI50389
SI50452
JDK60-64 IBM Technology for Java SR14 C3298710
Following PTFs REQUIRED for Domino 9.0 Java
5761-JV1 N/A Java SE 6 64 bit C0096710
5761-JV1 N/A Java Group PTF (latest level)
Java Group SF99572 Level 12 at least
N/A
5761-JV1 SI48541
SI48558
JDK60-32 IBM Technology for Java SR12 C3037710
5761-JV1 SI48543
SI48605
SI48621
JDK60-64 IBM Technology for Java SR12 C3037710

6.1 (V6R1)

Product PTF
Description
Available on
Cumulative
PTF Package
5761-SS1 SI40759 OSP-INCORROUT QP0LFLOP get link information C1256610
5761-SS1 SI38353 OSP-PERFM QlgLstat64() produces too many page faults
(SI39353 for 6.1.1)
C0215610
5761-999 MF49024 Licensed Internal Code extensions
(MF49025 for 6.1.1)
C0215610
5761-JV1 SI42689 JVA-RUN JDK60-32 Critical security vulnerability alert
(Option 11)
C1102610
5761-JV1 SI42678 JVA-RUN JDK 6.0 Class Library Updates
(Option 10) - Classic JVM was not supported from Domino 8.5.1 and future release
C1102610
5761-JV1 SI42686 JVA-RUN JDK50-32 Critical security vulnerability alert
(Option 8)
C1102610
5761-SS1 SI42682 RUN JDK5 Class library updates
(Option 7) - Classic JVM was not supported from Domino 8.5.1 and future release
C1102610
In addition to those before, following PTFs are minimally required for Domino 9.0.1 Java.
5761-JV1 N/A Java Group PTF (latest level)
Java Group SF99572 Level 14 at least
N/A
5761-JV1 SI50423
SI50387
SI50453
JDK60-32 IBM Technology for Java SR14 C3312610
5761-JV1 SI50415
SI50389
SI50452
JDK60-64 IBM Technology for Java SR14 C3312610
Following PTFs REQUIRED for Domino 9.0 Java.
5761-JV1 N/A Java SE 6 64 bit C8064610
5761-JV1 N/A Java Group PTF (latest level)
Java Group SF99562 Level 23 at least
N/A
5761-JV1 SI48541
SI48558
JDK60-32 IBM Technology for Java SR12 C3058610
5761-JV1 SI48543
SI48605
SI48621
JDK60-64 IBM Technology for Java SR12 C3058610
Domino 8.5.x
In addition to those before, following PTFs are minimally required for Domino 8.5.3 Java.
5761-JV1 SI42084 JVA-RUN JDK60-32 IBM Technology for Java SR9 C1102610
In addition to those before, following PTFs are minimally required for Domino 8.5.2 Java.
5761-JV1 SI36936 JVA-RUN JDK60-32 IBM Technology for Java SR7 C0047610
5761-JV1 SI36898 JVA-RUN JDK60-32 IBM Technology for Java SR7 C0047610
In addition to those before, following PTFs are minimally required for Domino 8.5.1 Java.
5761-JV1 SI34525 JVA-RUN JDK60-32 IBM Technology for Java SR4 C9279610
5761-JV1 SI34728 JVA-RUN JDK60-32 IBM Technology for Java SR4 C9279610
5761-JV1 SI34703 JVA-RUN JDK60-32 IBM Technology for Java SR4 C9279610
Following PTFs REQUIRED for Domino 8.5 Java
5761-JV1 SI30218 Java SE 6 32 bit C8064610
5761-JV1 SF99562 Java Group PTF (latest level) N/A
5761-JV1 SI31636 JDK60-32 IBM Technology for Java 6.0 SR1 C8190610
5761-JV1 SI31649 JDK60-32 IBM Technology for Java 6.0 SR1 C8190610
5761-JV1 SI31401 JDK60-32 IBM Technology for Java 6.0 SR1 C8190610
5761-JV1 SI30610 JDK60-32 IBM Technology for Java 6.0 SR1 C8190610
5761-JV1 SI32130 JDK60-32 INI RegisterNatives causes VM crash C8288610
5761-JV1 SI32362 JVA-RUN JDK60-32 IBM Technology for Java startup failure C8288610

5.4 (V5R4) - This release does not support Domino 9.0.

Product PTF
Description
Available on
Cumulative
PTF Package
5722-999 MF40520 LIC-MSGCPF3888 *PGM, *SRVPGM AND *MODULE RESTORE FROM FUTURE.
Restore of *PGM, *SRVPGM and *MODULE objects created on a future release fails with MSGCPF3888.
C8057540
5722-SS1 SI27180 OSP-DB-INCORROUT WITH SQ CCSID TRANSLATION C7226540
5722-SS1 SI27294 JVA-INCORROUT JAVA PROGRAM RESTORE FROM FUTURE RELEASE FAILS. Restored Java programs created on a future release fail to function properly C7226540
5722-SS1 SI24683 OSP-THREADS-PERFM FASTER THREAD LOCAL STORAGE ACCESS METHOD C7107540
5722-JV1 SI42688 JVA-RUN JDK60-32 Critical security vulnerability alert
(Option 11)
C1137540
5722-JV1 SI42683 JVA-RUN JDK 6.0 Class Library Updates
(Option 10) - Classic JVM was not supported from Domino 8.5.1 and future release
C1137540
5722-JV1 SI42685 JVA-RUN JDK50-32 Critical security vulnerability alert
(Option 8)
C1137540
5722-JV1 SI42680 RUN JDK5 Class library updates
(Option 7) - Classic JVM was not supported from Domino 8.5.1 and future release
C1137540
Domino 8.5.x
In addition to those before, following PTFs are minimally required for Domino 8.5.3 Java.
5722-JV SI42172 JVA-RUN JDK60-32 IBM Technology for Java SR9 C1137540
In addition to those before, following PTFs are minimally required for Domino 8.5.2 Java.
5722-JV1 SI36930 JVA-RUN JDK60-32 IBM Technology for Java SR7 C0117540
5722-JV1 SI37308 JVA-RUN JDK60-32 IBM Technology for Java SR7 C0117540
In addition to those before, following PTFs are minimally required for Domino 8.5.1 Java.
5722-JV1 SI34522 JVA-RUN JDK60-32 IBM Technology for Java SR4 C9321540
5722-JV1 SI34657 JVA-RUN JDK60-32 IBM Technology for Java SR4 C9321540
5722-JV1 SI34705 JVA-RUN JDK60-32 IBM Technology for Java SR4 C9321540
Following PTFs REQUIRED for Domino 8.5 Java
5722-JV1 SF99291 Java Group PTF (latest level) N/A
5722-JV1 SI31729 JDK60-32 IBM Technology for Java 6.0 SR1 C8183540
5722-JV1 SI31399 JDK60-32 IBM Technology for Java 6.0 SR1 C8183540
5722-JV1 SI31733 JDK60-32 IBM Technology for Java 6.0 SR1 C8183540
5722-JV1 SI30705 JDK60-32 IBM Technology for Java 6.0 SR1 C8183540
5722-JV1 SI32126 JDK60-32 INI RegisterNatives causes VM crash C8305540
5722-JV1 SI32364 JVA-RUN JDK60-32 IBM Technology for Java startup failure C8305540

V5R3 - This release is no longer in service.

Product PTF
Description
Available on
Cumulative
PTF Package
5722-SS1 SI27173 OSP-DB INCORROUT WITH SQ CCSID TRANSLATION
After upgrading an iSeries running Domino from V5R2 to V5R3/V5R4, some administrators find that the server ID (server.id file) is sporadically missing. This is caused by SQ picking up a bad CCSID intermittently.
C7303530
5722-SS1 SI16689 OSP-INCORROUT C RUNTIME SETLOCALE CHANGE
In certain situations, calls to the setlocale() routine return an empty string rather than the correct locale string. The locale has been set correctly by setlocale(), but the string result is empty rather than having the correct value.
C5032530

Related information

IBM i Information Center
System i Guide to fixes
Domino 8.5 for i: Software Requirements
Domino 9.0 for i: Software requirements
A simplified Chinese translation is available

Rate this page:

(0 users)Average rating

Document information


More support for:

IBM Domino

Software version:

8.0, 8.5, 8.5.1, 8.5.2, 8.5.3, 9.0, 9.0.1

Operating system(s):

IBM i, i5/OS

Software edition:

All Editions, Social Edition

Reference #:

1305543

Modified date:

2008-12-30

Translate my page

Machine Translation

Content navigation