Skip to main content

Software  >  Lotus  >  

Domino 8 installation on Linux fails without error

 Technote (troubleshooting)
 
Problem
A new installation of Lotus® Domino® 8 server on RedHat Enterprise Linux® (RHEL) fails. When you attempt to run the installation, the system returns to the command prompt without generating any errors.
 
Symptom
The installer prompts for installation in console mode, then fails immediately after that response. The installer program never launches the setup.jar file, so the /tmp/nuish.err file is zero bytes and the /tmp/DominoInstall.log file is not created.
 
Cause
The Domino 8 installer is Java-based and uses its own JVM to run. Thus, the installer's first step is to extract its Java binaries to /tmp so that it can launch the setup application. In this particular case, the mount options on the /tmp file system had an option enabled (noexec) that does not allow execution of binaries.
 
Diagnosing the problem
The standard install log files such as nuish.err and DominoInstall.og are not useful in this scenario. You can use the following command to generate an output log file for troubleshooting:

    > ./install -is:log /tmp/mylog.txt

The mylog.txt file contained the following error message for this case:

    "file name: ibm_linux_142sr8.bin
    ERROR: Invalid bundled JVM. Missing 'jvm' file."

From this error, you can narrow the investigation to the temporary Java that the installer extracts to /tmp. The administrator confirmed that there was ample free space in /tmp and that the Java extract was complete. You can confirm free space with this command:

    > df -k /tmp

The administrator also confirmed that the permission on the /tmp directory was correctly set to 1777. To check permission, use the following command:

    > ls -ald /tmp

The root cause was identified after checking the mount options for the /tmp file system. The administrator discovered that the noexec and nosuid options were enabled. The options were set as part of the hardening procedure for the operating system. You can use the following command to check the mount options:

    > mount

    (Note that this command lists all the file systems that are configured in the /etc/fstab system configuration file. Thus, you need to locate the /tmp file system entry and verify the option in the fourth field.)


noexec is defined as = Do not allow execution of any binaries on the mounted file system. This option might be useful for a server that has file systems containing binaries for architectures other than its own.
 
Resolving the problem
To resolve the problem, edit the /etc/fstab file and remove the noexec and nosuid options for /tmp. You should reboot the operating system to allow the /tmp filesystem to be remounted without the options.
 
 
 

Copyright and trademark information
IBM, the IBM logo and ibm.com are trademarks of International Business Machines Corp., registered in many jurisdictions worldwide. Other product and service names might be trademarks of IBM or other companies. A current list of IBM trademarks is available on the Web at "Copyright and trademark information" at www.ibm.com/legal/copytrade.shtml.
Rate this page
Please take a moment to complete this form to help us better serve you.
This material provides me with the information I need.




This material is clear and easy to understand.




Did the information help you to achieve your goal?
What updates, improvements, or related information would you like to see in this document?
Your response will be used to improve our document content. Requests for assistance, if applicable, should be submitted through your normal support channel as we cannot respond from this site.
Input the verification number to submit feedback:
Document information
 Product categories:
 Software
 Messaging Applications
 Advanced Messaging
 Lotus Domino
 Lotus Domino Server
 Operating system(s):
  AIX, Linux, Solaris
 Software version:
  8.0
 Reference #:
  1295755
 IBM Group:
 Software Group
 Modified date:
 2008-03-07

Translate My Page
 
 

Rate this page

Help us improve this page. Your response will be used to improve our document content. Requests for assistance, if applicable, should be submitted through your normal support channel as we cannot respond from this site.